# Elastic Agent fault by Fleet manager

**URL:** https://discuss.elastic.co/t/elastic-agent-fault-by-fleet-manager/272347
**Category:** Beats
**Tags:** elastic-agent
**Created:** [May 7, 2021, 1:44am UTC](https://discuss.elastic.co/t/elastic-agent-fault-by-fleet-manager/272347 "2021-05-07T01:44:19Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![root](https://avatars.discourse-cdn.com/v4/letter/r/cc9497/32.png) [@root](https://discuss.elastic.co/u/root)
#### Post date: [May 7, 2021, 1:44am UTC](https://discuss.elastic.co/t/elastic-agent-fault-by-fleet-manager/272347/1 "2021-05-07T01:44:19Z")

</div>

09:30:24.756

elastic\_agent

[elastic\_agent][info] The Elastic Agent is currently in BETA and should not be used in production

09:30:24.756

elastic\_agent

[elastic\_agent][info] The Elastic Agent is currently in BETA and should not be used in production

09:30:24.756

elastic\_agent

[elastic\_agent][error] failed to load markeropen /opt/Elastic/Agent/data/.update-marker: no such file or directory

09:30:27.198

elastic\_agent

[elastic\_agent][info] Detecting execution mode

09:30:27.198

elastic\_agent

[elastic\_agent][warn] DEPRECATED: Treating the CommonName field on X.509 certificates as a host name when no Subject Alternative Names are present is going to be removed. Please update your certificates if needed. Will be removed in version: 8.0.0

09:30:27.198

elastic\_agent

[elastic\_agent][error] failed to load markeropen /opt/Elastic/Agent/data/.update-marker: no such file or directory

09:30:27.198

elastic\_agent

[elastic\_agent][info] Detecting execution mode

09:30:27.198

elastic\_agent

[elastic\_agent][info] Agent is managed by Fleet

09:30:27.198

elastic\_agent

[elastic\_agent][info] Agent is managed locally

09:30:27.198

elastic\_agent

[elastic\_agent][info] capabilities file not found in /opt/Elastic/Agent/capabilities.yml

09:30:27.198

elastic\_agent

[elastic\_agent][info] capabilities file not found in /opt/Elastic/Agent/capabilities.yml

09:30:27.198

elastic\_agent

[elastic\_agent][info] EXPERIMENTAL - Inputs with variables are currently experimental and should not be used in production

09:30:27.198

elastic\_agent

[elastic\_agent][info] EXPERIMENTAL - Inputs with variables are currently experimental and should not be used in production

09:30:27.198

elastic\_agent

[elastic\_agent][info] Docker provider skipped, unable to connect: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

09:30:27.198

elastic\_agent

[elastic\_agent][info] Docker provider skipped, unable to connect: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

09:30:27.199

elastic\_agent

[elastic\_agent][info] Starting stats endpoint

09:30:27.199

elastic\_agent

[elastic\_agent][info] Agent is starting

09:30:27.199

elastic\_agent

[elastic\_agent][info] Starting stats endpoint

09:30:27.199

elastic\_agent

[elastic\_agent][info] Metrics endpoint listening on: /tmp/elastic-agent/elastic-agent.sock (configured: unix:///tmp/elastic-agent/elastic-agent.sock)

09:30:27.199

elastic\_agent

[elastic\_agent][info] Agent is starting

09:30:27.199

elastic\_agent

[elastic\_agent][info] Metrics endpoint listening on: /tmp/elastic-agent/elastic-agent.sock (configured: unix:///tmp/elastic-agent/elastic-agent.sock)

09:30:27.199

elastic\_agent

[elastic\_agent][warn] failed to ack update open /opt/Elastic/Agent/data/.update-marker: no such file or directory

09:30:27.199

elastic\_agent

[elastic\_agent][info] Agent is stopped

09:30:27.199

elastic\_agent

[elastic\_agent][info] New State ID is 3hJsKxox

09:30:27.199

elastic\_agent

[elastic\_agent][info] Configuration changes detected

09:30:27.199

elastic\_agent

[elastic\_agent][info] New State ID is BbM5KubA

09:30:27.199

elastic\_agent

[elastic\_agent][info] Converging state requires execution of 4 step(s)

09:30:27.200

elastic\_agent

[elastic\_agent][info] Converging state requires execution of 1 step(s)

09:30:27.200

elastic\_agent

[elastic\_agent][info] filebeat.7.12.0 already exists in /opt/Elastic/Agent/data/elastic-agent-08e204/downloads/filebeat-7.12.0-linux-x86\_64.tar.gz. Skipping operation operation-fetch

09:30:27.200

elastic\_agent

[elastic\_agent][info] filebeat.7.12.0 already exists in /opt/Elastic/Agent/data/elastic-agent-08e204/downloads/filebeat-7.12.0-linux-x86\_64.tar.gz. Skipping operation operation-fetch

09:30:27.200

elastic\_agent

[elastic\_agent][info] endpoint-security.7.12.0 already exists in /opt/Elastic/Agent/data/elastic-agent-08e204/downloads/endpoint-security-7.12.0-linux-x86\_64.tar.gz. Skipping operation operation-fetch

09:30:27.200

elastic\_agent

[elastic\_agent][info] endpoint-security.7.12.0 already exists in /opt/Elastic/Agent/data/elastic-agent-08e204/downloads/endpoint-security-7.12.0-linux-x86\_64.tar.gz. Skipping operation operation-fetch

09:30:27.200

elastic\_agent

[elastic\_agent][info] 2021-05-07T09:30:14+08:00: type: 'STATE': sub\_type: 'STARTING' message: Application: endpoint-security--7.12.0[c17588d0-aed3-11eb-b4ad-01a877605530]: State changed to STARTING: Starting

09:30:27.200

elastic\_agent

[elastic\_agent][info] filebeat.7.12.0 already exists in /opt/Elastic/Agent/data/elastic-agent-08e204/downloads/filebeat-7.12.0-linux-x86\_64.tar.gz. Skipping operation operation-fetch

09:30:27.200

elastic\_agent

[elastic\_agent][info] waiting for installer of pipeline 'default' to finish

09:30:27.201

elastic\_agent

[elastic\_agent][info] filebeat.7.12.0 already exists in /opt/Elastic/Agent/data/elastic-agent-08e204/downloads/filebeat-7.12.0-linux-x86\_64.tar.gz. Skipping operation operation-fetch

09:30:27.201

elastic\_agent

[elastic\_agent][info] Signaling application to stop because of shutdown: filebeat--7.12.0--36643631373035623733363936343635

09:30:27.201

elastic\_agent

[elastic\_agent][info] 2021-05-07T09:30:19+08:00: type: 'STATE': sub\_type: 'STARTING' message: Application: filebeat--7.12.0[c17588d0-aed3-11eb-b4ad-01a877605530]: State changed to STARTING: Starting

09:30:27.201

elastic\_agent

[elastic\_agent][info] metricbeat.7.12.0 already exists in /opt/Elastic/Agent/data/elastic-agent-08e204/downloads/metricbeat-7.12.0-linux-x86\_64.tar.gz. Skipping operation operation-fetch

09:30:27.201

elastic\_agent

[elastic\_agent][info] metricbeat.7.12.0 already exists in /opt/Elastic/Agent/data/elastic-agent-08e204/downloads/metricbeat-7.12.0-linux-x86\_64.tar.gz. Skipping operation operation-fetch

09:30:27.201

elastic\_agent

[elastic\_agent][info] 2021-05-07T09:30:20+08:00: type: 'STATE': sub\_type: 'RUNNING' message: Application: filebeat--7.12.0[c17588d0-aed3-11eb-b4ad-01a877605530]: State changed to RUNNING: Running

09:30:27.201

elastic\_agent

[elastic\_agent][info] 2021-05-07T09:30:23+08:00: type: 'STATE': sub\_type: 'STARTING' message: Application: metricbeat--7.12.0[c17588d0-aed3-11eb-b4ad-01a877605530]: State changed to STARTING: Starting

09:30:27.201

elastic\_agent

[elastic\_agent][error] Elastic Agent status changed to: 'error'

09:30:27.201

elastic\_agent

[elastic\_agent][error] 2021-05-07T09:30:09+08:00: type: 'ERROR': sub\_type: 'FAILED' message: Application: filebeat--7.12.0--36643631373035623733363936343635[08a88b19-c1fe-4656-a423-04ee51473d3f]: State changed to FAILED: context canceled

09:30:27.201

elastic\_agent

[elastic\_agent][info] filebeat.7.12.0 already exists in /opt/Elastic/Agent/data/elastic-agent-08e204/downloads/filebeat-7.12.0-linux-x86\_64.tar.gz. Skipping operation operation-fetch

09:30:27.202

elastic\_agent

[elastic\_agent][info] filebeat.7.12.0 already exists in /opt/Elastic/Agent/data/elastic-agent-08e204/downloads/filebeat-7.12.0-linux-x86\_64.tar.gz. Skipping operation operation-fetch

09:30:27.202

elastic\_agent

[elastic\_agent][info] operation 'operation-install' skipped for filebeat.7.12.0

09:30:27.202

elastic\_agent

[elastic\_agent][info] 2021-05-07T09:30:24+08:00: type: 'STATE': sub\_type: 'STARTING' message: Application: filebeat--7.12.0--36643631373035623733363936343635[c17588d0-aed3-11eb-b4ad-01a877605530]: State changed to STARTING: Starting

09:30:27.202

elastic\_agent

[elastic\_agent][info] Elastic Agent status changed to: 'online'

09:30:27.202

elastic\_agent

[elastic\_agent][info] Signaling application to stop because of shutdown: metricbeat--7.12.0--36643631373035623733363936343635

09:30:27.202

elastic\_agent

[elastic\_agent][error] Elastic Agent status changed to: 'error'

09:30:27.202

elastic\_agent

[elastic\_agent][info] metricbeat.7.12.0 already exists in /opt/Elastic/Agent/data/elastic-agent-08e204/downloads/metricbeat-7.12.0-linux-x86\_64.tar.gz. Skipping operation operation-fetch

09:30:27.202

elastic\_agent

[elastic\_agent][info] 2021-05-07T09:30:09+08:00: type: 'STATE': sub\_type: 'STOPPED' message: Application: filebeat--7.12.0--36643631373035623733363936343635[08a88b19-c1fe-4656-a423-04ee51473d3f]: State changed to STOPPED: Stopped

09:30:27.202

elastic\_agent

[elastic\_agent][info] metricbeat.7.12.0 already exists in /opt/Elastic/Agent/data/elastic-agent-08e204/downloads/metricbeat-7.12.0-linux-x86\_64.tar.gz. Skipping operation operation-fetch

09:30:27.202

elastic\_agent

[elastic\_agent][info] New State ID is BbM5KubA

09:30:27.202

elastic\_agent

[elastic\_agent][info] operation 'operation-install' skipped for metricbeat.7.12.0

09:30:27.202

elastic\_agent

[elastic\_agent][info] Converging state requires execution of 1 step(s)

09:30:27.202

elastic\_agent

[elastic\_agent][info] 2021-05-07T09:30:24+08:00: type: 'STATE': sub\_type: 'STARTING' message: Application: metricbeat--7.12.0--36643631373035623733363936343635[c17588d0-aed3-11eb-b4ad-01a877605530]: State changed to STARTING: Starting

09:30:27.203

elastic\_agent

[elastic\_agent][info] Updating internal state

09:30:27.203

elastic\_agent

[elastic\_agent][info] 2021-05-07T09:30:24+08:00: type: 'STATE': sub\_type: 'RUNNING' message: Application: metricbeat--7.12.0[c17588d0-aed3-11eb-b4ad-01a877605530]: State changed to RUNNING: Running

09:30:27.203

elastic\_agent

[elastic\_agent][info] 2021-05-07T09:30:25+08:00: type: 'STATE': sub\_type: 'RUNNING' message: Application: filebeat--7.12.0--36643631373035623733363936343635[c17588d0-aed3-11eb-b4ad-01a877605530]: State changed to RUNNING: Running

09:30:27.203

elastic\_agent

[elastic\_agent][info] 2021-05-07T09:30:25+08:00: type: 'STATE': sub\_type: 'RUNNING' message: Application: metricbeat--7.12.0--36643631373035623733363936343635[c17588d0-aed3-11eb-b4ad-01a877605530]: State changed to RUNNING: Running

09:31:22.204

elastic\_agent

[elastic\_agent][info] 2021-05-07T09:31:14+08:00: type: 'STATE': sub\_type: 'RUNNING' message: Application: endpoint-security--7.12.0[c17588d0-aed3-11eb-b4ad-01a877605530]: State changed to DEGRADED: Missed last check-in

09:31:22.204

elastic\_agent

[elastic\_agent][warn] Elastic Agent status changed to: 'degraded'

09:32:17.205

elastic\_agent

[elastic\_agent][error] Elastic Agent status changed to: 'error'

09:32:17.205

elastic\_agent

[elastic\_agent][error] 2021-05-07T09:32:14+08:00: type: 'ERROR': sub\_type: 'FAILED' message: Application: endpoint-security--7.12.0[c17588d0-aed3-11eb-b4ad-01a877605530]: State changed to FAILED: Missed two check-ins

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 4, 2021, 1:44am UTC](https://discuss.elastic.co/t/elastic-agent-fault-by-fleet-manager/272347/2 "2021-06-04T01:44:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
