# Elastic agent - Fleet x509: certificate signed by unknown authority

**URL:** <https://discuss.elastic.co/t/elastic-agent-fleet-x509-certificate-signed-by-unknown-authority/256330>\
**Category:** Elastic Security\
**Tags:** elastic-stack-security, fleet, elastic-agent\
**Created:** [November 23, 2020, 9:31am UTC](https://discuss.elastic.co/t/elastic-agent-fleet-x509-certificate-signed-by-unknown-authority/256330 "2020-11-23T09:31:58Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![111412](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/111412/32/79495_2.png) [@111412](https://discuss.elastic.co/u/111412)\
**Post date:** [November 23, 2020, 9:31am UTC](https://discuss.elastic.co/t/elastic-agent-fleet-x509-certificate-signed-by-unknown-authority/256330/1 "2020-11-23T09:31:58Z")

</div>

The error message is as follows 🤣  
{"log.level":"error","@timestamp":"2020-11-23T15:59:58.735+0800","log.logger":"publisher\_pipeline\_output","log.origin":{"file.name":"pipeline/output.go","file.line":154},"message":"Failed to connect to backoff(elasticsearch([https://node1.elastic.test.com:9200](https://node1.elastic.test.com:9200))): Get "[https://node1.elastic.test.com:9200](https://node1.elastic.test.com:9200)": x509: certificate signed by unknown authority","ecs.version":"1.6.0"}

The FILEBEAK configuration file in Elastic Agent is as follows :

# ---------------------------- Elasticsearch Output ----------------------------

output.elasticsearch:

# Array of hosts to connect to.

hosts: ["[https://node1.elastic.test.com:9200](https://node1.elastic.test.com:9200)"]

# Protocol - either `http` (default) or `https`.

protocol: "https"  
ssl.verification\_mode: "none"

# ssl.enabled: "true

ssl.certificate: "/etc/logstash/certs/logstash/logstash.crt"  
ssl.certificate\_authorities: "/etc/logstash/certs/ca/ca.crt"  
ssl.key: "/etc/logstash/certs/logstash/logstash.key"

# Authentication credentials - either API key or username/password.

#api\_key: "id:api\_key"  
username: "elastic"  
password: "8rXntxqQEZ9HLg"

How can I solve it?

---

<div class="post-metadata">

**Author:** ![sholzhauer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sholzhauer/32/110282_2.png) [@sholzhauer](https://discuss.elastic.co/u/sholzhauer)\
**Post date:** [October 4, 2021, 11:48am UTC](https://discuss.elastic.co/t/elastic-agent-fleet-x509-certificate-signed-by-unknown-authority/256330/2 "2021-10-04T11:48:12Z")

</div>

Hi, the config looks like you are having fleet talk to your logstash instance based on the certificates configured, that shouldn't be the case.

`elastic agent --> fleet server --> elastic` is the flow.

The error you are having is due to not having given the correct CA trusted file.  
You are most likely using a self signed cert which isn't natively trusted by the system and you will have to provide a trust CA file on enrollment.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 4, 2022, 8:18am UTC](https://discuss.elastic.co/t/elastic-agent-fleet-x509-certificate-signed-by-unknown-authority/256330/4 "2022-11-04T08:18:14Z")

</div>


