# Elastic\_agent.metricbeat error fetching data from metricsets.kubernetes.system

**URL:** <https://discuss.elastic.co/t/elastic-agent-metricbeat-error-fetching-data-from-metricsets-kubernetes-system/358398>\
**Category:** Elastic Agent\
**Tags:** metricbeat\
**Created:** [April 29, 2024, 7:30am UTC](https://discuss.elastic.co/t/elastic-agent-metricbeat-error-fetching-data-from-metricsets-kubernetes-system/358398 "2024-04-29T07:30:01Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Subrahmanyam\_Veerank](https://avatars.discourse-cdn.com/v4/letter/s/d78d45/32.png) [@Subrahmanyam\_Veerank](https://discuss.elastic.co/u/Subrahmanyam_Veerank)\
**Post date:** [April 29, 2024, 7:30am UTC](https://discuss.elastic.co/t/elastic-agent-metricbeat-error-fetching-data-from-metricsets-kubernetes-system/358398/1 "2024-04-29T07:30:01Z")

</div>

Sir,

Deployed elastic agent (fleet managed) in kubernetes cluster but the metric related details are not getting shown in the dashboards and observing the below errors. Kindly help us resolve the issue.

[elastic\_agent.metricbeat][error] Error fetching data for metricset kubernetes.system: error doing HTTP request to fetch 'system' Metricset data: error making http request: Get "[https://worker2-accountshr:10250/stats/summary](https://worker2-accountshr:10250/stats/summary)": lookup worker2-accountshr on 10.11.10.11:53: no such host

elastic\_agent.metricbeat  
[elastic\_agent.metricbeat][error] Error fetching data for metricset kubernetes.volume: error doing HTTP request to fetch 'volume' Metricset data: error making http request: Get "[https://worker2-accountshr:10250/stats/summary](https://worker2-accountshr:10250/stats/summary)": lookup worker2-accountshr on 10.11.10.11:53: no such host

---

<div class="post-metadata">

**Author:** ![Subrahmanyam\_Veerank](https://avatars.discourse-cdn.com/v4/letter/s/d78d45/32.png) [@Subrahmanyam\_Veerank](https://discuss.elastic.co/u/Subrahmanyam_Veerank)\
**Post date:** [April 29, 2024, 9:06am UTC](https://discuss.elastic.co/t/elastic-agent-metricbeat-error-fetching-data-from-metricsets-kubernetes-system/358398/2 "2024-04-29T09:06:37Z")

</div>

As per my observation the elastic agent is not able resolve the dns of worker2-accountshr..

---

<div class="post-metadata">

**Author:** ![Subrahmanyam\_Veerank](https://avatars.discourse-cdn.com/v4/letter/s/d78d45/32.png) [@Subrahmanyam\_Veerank](https://discuss.elastic.co/u/Subrahmanyam_Veerank)\
**Post date:** [April 29, 2024, 10:02am UTC](https://discuss.elastic.co/t/elastic-agent-metricbeat-error-fetching-data-from-metricsets-kubernetes-system/358398/3 "2024-04-29T10:02:32Z")

</div>

By adding the ip of the nodes in the rancher for the elastic have resolved the issue.
