# Elastic Agent on Ubuntu 14.04 constantly updating, never makes a connection

**URL:** <https://discuss.elastic.co/t/elastic-agent-on-ubuntu-14-04-constantly-updating-never-makes-a-connection/285036>\
**Category:** Beats\
**Tags:** docker, elastic-agent\
**Created:** [September 23, 2021, 11:48pm UTC](https://discuss.elastic.co/t/elastic-agent-on-ubuntu-14-04-constantly-updating-never-makes-a-connection/285036 "2021-09-23T23:48:47Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![robrien](https://avatars.discourse-cdn.com/v4/letter/r/13edae/32.png) [@robrien](https://discuss.elastic.co/u/robrien)\
**Post date:** [September 23, 2021, 11:48pm UTC](https://discuss.elastic.co/t/elastic-agent-on-ubuntu-14-04-constantly-updating-never-makes-a-connection/285036/1 "2021-09-23T23:48:47Z")

</div>

I have a server I am unable to get the elastic agent to run on.

When running the elastic-agent commands I am not finding much relevant in my searches.

```auto
Error: failed to communicate with Elastic Agent daemon: rpc error: code = Unavailable desc = connection error: desc = "transport: Error while dialing dial unix /var/lib/elastic-agent/data/tmp/elastic-agent-control.sock: connect: no such file or directory"
root@vmjamadb:/etc/elastic-agent# elastic-agent inspect
no fleet config retrieved yet

```

I do not understand the logs well enough to get past this.

```auto
2021-09-20T14:02:21.279-0700 INFO application/application.go:66 Detecting execution mode
2021-09-20T14:02:21.280-0700 INFO application/application.go:91 Agent is managed by Fleet
2021-09-20T14:02:21.280-0700 INFO capabilities/capabilities.go:59 capabilities file not found in /etc/elastic-agent/capabilities.yml
2021-09-20T14:02:21.511-0700 INFO [composable.providers.docker] docker/docker.go:43 Docker provider skipped, unable to connect: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?
2021-09-20T14:02:21.511-0700 INFO [api] api/server.go:62 Starting stats endpoint
2021-09-20T14:02:21.512-0700 INFO application/managed_mode.go:291 Agent is starting
2021-09-20T14:02:21.512-0700 INFO [api] api/server.go:64 Metrics endpoint listening on: /usr/share/elastic-agent/data/tmp/elastic-agent.sock (configured: unix:///usr/share/elastic-agent/data/tmp/elastic-agent.sock)
2021-09-20T14:02:23.571-0700 INFO stateresolver/stateresolver.go:48 New State ID is NGMWS3oY
2021-09-20T14:02:23.571-0700 INFO stateresolver/stateresolver.go:49 Converging state requires execution of 3 step(s)
2021-09-20T14:02:24.309-0700 INFO operation/operation_fetch.go:75 downloaded binary 'filebeat.7.14.1' into '/usr/share/elastic-agent/data/elastic-agent-703d58/downloads/filebeat-7.14.1-linux-x86_64.tar.gz' as part of operation 'operation-fetch'
2021-09-20T14:02:28.812-0700 INFO log/reporter.go:40 2021-09-20T14:02:28-07:00 - message: Application: filebeat--7.14.1[4a7167a1-9a0b-4a79-b9fc-c21dfd92ad10]: State changed to STARTING: Starting - type: 'STATE' - sub_type: 'STARTING'
2021-09-20T14:02:30.621-0700 INFO operation/operation_fetch.go:75 downloaded binary 'metricbeat.7.14.1' into '/usr/share/elastic-agent/data/elastic-agent-703d58/downloads/metricbeat-7.14.1-linux-x86_64.tar.gz' as part of operation 'operation-fetch'
2021-09-20T14:02:31.470-0700 INFO log/reporter.go:40 2021-09-20T14:02:31-07:00 - message: Application: filebeat--7.14.1[4a7167a1-9a0b-4a79-b9fc-c21dfd92ad10]: State changed to RUNNING: Running - type: 'STATE' - sub_type: 'RUNNING'
2021-09-20T14:02:35.056-0700 INFO log/reporter.go:40 2021-09-20T14:02:35-07:00 - message: Application: metricbeat--7.14.1[4a7167a1-9a0b-4a79-b9fc-c21dfd92ad10]: State changed to STARTING: Starting - type: 'STATE' - sub_type: 'STARTING'
2021-09-20T14:02:37.504-0700 INFO operation/operator.go:260 operation 'operation-install' skipped for filebeat.7.14.1
2021-09-20T14:02:38.129-0700 INFO log/reporter.go:40 2021-09-20T14:02:38-07:00 - message: Application: filebeat--7.14.1--36643631373035623733363936343635[4a7167a1-9a0b-4a79-b9fc-c21dfd92ad10]: State changed to STARTING: Starting - type: 'STATE' - sub_type: 'STARTING'
2021-09-20T14:02:38.167-0700 INFO log/reporter.go:40 2021-09-20T14:02:38-07:00 - message: Application: metricbeat--7.14.1[4a7167a1-9a0b-4a79-b9fc-c21dfd92ad10]: State changed to RUNNING: Running - type: 'STATE' - sub_type: 'RUNNING'
2021-09-20T14:02:39.118-0700 INFO operation/operator.go:260 operation 'operation-install' skipped for metricbeat.7.14.1
2021-09-20T14:02:39.375-0700 INFO stateresolver/stateresolver.go:66 Updating internal state
2021-09-20T14:02:39.391-0700 INFO log/reporter.go:40 2021-09-20T14:02:39-07:00 - message: Application: metricbeat--7.14.1--36643631373035623733363936343635[4a7167a1-9a0b-4a79-b9fc-c21dfd92ad10]: State changed to STARTING: Starting - type: 'STATE' - sub_type: 'STARTING'

```

I successfully enroll the server to the Elastic Cloud fleet server, however it sits at updating and never progresses.

This may or may not be unrelated, but I have a second Ubuntu 14.04 server I am unable to get the elastic agent working on.  
For the elastic agent commands, I get the same results as above.

Here's this log file:

```auto
2021-09-23T15:51:40.870-0700 INFO application/application.go:66 Detecting execution mode
2021-09-23T15:51:40.872-0700 INFO application/application.go:91 Agent is managed by Fleet
2021-09-23T15:51:40.872-0700 INFO capabilities/capabilities.go:59 capabilities file not found in /etc/elastic-agent/capabilities.yml
2021-09-23T15:51:41.171-0700 INFO [api] api/server.go:62 Starting stats endpoint
2021-09-23T15:51:41.171-0700 INFO application/managed_mode.go:291 Agent is starting
2021-09-23T15:51:41.171-0700 WARN application/managed_mode.go:293 agent was previously unenrolled. To reactivate please reconfigure or enroll again.
2021-09-23T15:51:41.171-0700 INFO [api] api/server.go:64 Metrics endpoint listening on: /usr/share/elastic-agent/data/tmp/elastic-agent.sock (configured: unix:///usr/share/elastic-agent/data/tmp/elastic-agent.sock)
2021-09-23T16:01:41.170-0700 INFO [composable.providers.docker] docker/watcher.go:308 No events received within 10m0s, restarting watch call
2021-09-23T16:11:51.170-0700 INFO [composable.providers.docker] docker/watcher.go:308 No events received within 10m0s, restarting watch call
2021-09-23T16:22:01.171-0700 INFO [composable.providers.docker] docker/watcher.go:308 No events received within 10m0s, restarting watch call
2021-09-23T16:32:11.171-0700 INFO [composable.providers.docker] docker/watcher.go:308 No events received within 10m0s, restarting watch call
2021-09-23T16:42:21.171-0700 INFO [composable.providers.docker] docker/watcher.go:308 No events received within 10m0s, restarting watch call

```

I had another error that appeared earlier in the day, however after restarting the service, I did not have another log file like this. I could have fixed this, or this could be the underlying cause for why this won't work.

```auto
2021-09-23T15:00:46.913-0700 INFO application/application.go:66 Detecting execution mode
2021-09-23T15:00:46.915-0700 INFO application/application.go:91 Agent is managed by Fleet
2021-09-23T15:00:46.915-0700 INFO capabilities/capabilities.go:59 capabilities file not found in /etc/elastic-agent/capabilities.yml
2021-09-23T15:00:47.379-0700 INFO [api] api/server.go:62 Starting stats endpoint
2021-09-23T15:00:47.379-0700 INFO application/managed_mode.go:291 Agent is starting
2021-09-23T15:00:47.379-0700 INFO [api] api/server.go:64 Metrics endpoint listening on: /var/lib/elastic-agent/data/tmp/elastic-agent.sock (configured: unix:///var/lib/elastic-agent/data/tmp/elastic-agent.sock)
2021-09-23T15:00:49.428-0700 INFO stateresolver/stateresolver.go:48 New State ID is smmnz7ST
2021-09-23T15:00:49.428-0700 INFO stateresolver/stateresolver.go:49 Converging state requires execution of 4 step(s)
2021-09-23T15:00:50.362-0700 INFO log/reporter.go:40 2021-09-23T15:00:50-07:00 - message: Application: endpoint-security--7.14.1[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to STARTING: Starting - type: 'STATE' - sub_type: 'STARTING'
2021-09-23T15:00:55.434-0700 INFO log/reporter.go:40 2021-09-23T15:00:55-07:00 - message: Application: filebeat--7.14.1[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to STARTING: Starting - type: 'STATE' - sub_type: 'STARTING'
2021-09-23T15:00:56.639-0700 INFO log/reporter.go:40 2021-09-23T15:00:56-07:00 - message: Application: filebeat--7.14.1[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to RUNNING: Running - type: 'STATE' - sub_type: 'RUNNING'
2021-09-23T15:00:58.888-0700 INFO log/reporter.go:40 2021-09-23T15:00:58-07:00 - message: Application: metricbeat--7.14.1[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to STARTING: Starting - type: 'STATE' - sub_type: 'STARTING'
2021-09-23T15:00:59.253-0700 INFO operation/operator.go:260 operation 'operation-install' skipped for filebeat.7.14.1
2021-09-23T15:00:59.534-0700 INFO log/reporter.go:40 2021-09-23T15:00:59-07:00 - message: Application: filebeat--7.14.1--36643631373035623733363936343635[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to STARTING: Starting - type: 'STATE' - sub_type: 'STARTING'
2021-09-23T15:00:59.963-0700 INFO operation/operator.go:260 operation 'operation-install' skipped for metricbeat.7.14.1
2021-09-23T15:01:00.175-0700 INFO log/reporter.go:40 2021-09-23T15:01:00-07:00 - message: Application: metricbeat--7.14.1--36643631373035623733363936343635[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to STARTING: Starting - type: 'STATE' - sub_type: 'STARTING'
2021-09-23T15:01:00.180-0700 INFO stateresolver/stateresolver.go:66 Updating internal state
2021-09-23T15:01:00.188-0700 ERROR log/reporter.go:36 2021-09-23T15:01:00-07:00 - message: Application: metricbeat--7.14.1[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to FAILED: 1 error occurred:

2021-09-23T15:01:00.180-0700 INFO stateresolver/stateresolver.go:66 Updating internal state
2021-09-23T15:01:00.188-0700 ERROR log/reporter.go:36 2021-09-23T15:01:00-07:00 - message: Application: metricbeat--7.14.1[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to FAILED: 1 error occurred:
        * 1 error: Error creating runner from config: 1 error: error finding ListUnits Method: no supported list Units function: map[]

 - type: 'ERROR' - sub_type: 'FAILED'
2021-09-23T15:01:00.188-0700 ERROR status/reporter.go:236 Elastic Agent status changed to: 'error'
2021-09-23T15:01:00.742-0700 INFO log/reporter.go:40 2021-09-23T15:01:00-07:00 - message: Application: filebeat--7.14.1--36643631373035623733363936343635[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to RUNNING: Running - type: 'STATE' - sub_type: 'RUNNING'
2021-09-23T15:01:01.447-0700 INFO log/reporter.go:40 2021-09-23T15:01:01-07:00 - message: Application: metricbeat--7.14.1--36643631373035623733363936343635[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to RUNNING: Running - type: 'STATE' - sub_type: 'RUNNING'
2021-09-23T15:01:07.416-0700 INFO log/reporter.go:40 2021-09-23T15:01:07-07:00 - message: Application: endpoint-security--7.14.1[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to CONFIG: - type: 'STATE' - sub_type: 'CONFIG'
2021-09-23T15:01:10.197-0700 INFO status/reporter.go:236 Elastic Agent status changed to: 'online'
2021-09-23T15:01:10.203-0700 INFO log/reporter.go:40 2021-09-23T15:01:10-07:00 - message: Application: metricbeat--7.14.1[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to RESTARTING: - type: 'STATE' - sub_type: 'STARTING'
2021-09-23T15:01:10.203-0700 INFO log/reporter.go:40 2021-09-23T15:01:10-07:00 - message: Application: metricbeat--7.14.1[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to STARTING: Starting - type: 'STATE' - sub_type: 'STARTING'
2021-09-23T15:01:10.203-0700 INFO log/reporter.go:40 2021-09-23T15:01:10-07:00 - message: Application: metricbeat--7.14.1[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to RESTARTING: Restarting - type: 'STATE' - sub_type: 'STARTING'
2021-09-23T15:01:10.958-0700 INFO log/reporter.go:40 2021-09-23T15:01:10-07:00 - message: Application: metricbeat--7.14.1[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to STARTING: Starting - type: 'STATE' - sub_type: 'STARTING'
2021-09-23T15:01:11.459-0700 ERROR status/reporter.go:236 Elastic Agent status changed to: 'error'
2021-09-23T15:01:11.461-0700 ERROR log/reporter.go:36 2021-09-23T15:01:11-07:00 - message: Application: metricbeat--7.14.1[78b6fc6a-264a-4abd-8e09-cab4a2e3fe38]: State changed to FAILED: 1 error occurred:
        * 1 error: Error creating runner from config: 1 error: error finding ListUnits Method: no supported list Units function: map[]

```

---

<div class="post-metadata">

**Author:** ![robrien](https://avatars.discourse-cdn.com/v4/letter/r/13edae/32.png) [@robrien](https://discuss.elastic.co/u/robrien)\
**Post date:** [September 23, 2021, 11:50pm UTC](https://discuss.elastic.co/t/elastic-agent-on-ubuntu-14-04-constantly-updating-never-makes-a-connection/285036/2 "2021-09-23T23:50:40Z")

</div>

I do not know why this is tagged Docker, other than I found a person with similar issues, but that person was using docker.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 22, 2021, 1:51am UTC](https://discuss.elastic.co/t/elastic-agent-on-ubuntu-14-04-constantly-updating-never-makes-a-connection/285036/3 "2021-10-22T01:51:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
