# Elastic agent random shutdown/goes offline

**URL:** https://discuss.elastic.co/t/elastic-agent-random-shutdown-goes-offline/325223
**Category:** Elasticsearch
**Tags:** docker
**Created:** [February 10, 2023, 8:27am UTC](https://discuss.elastic.co/t/elastic-agent-random-shutdown-goes-offline/325223 "2023-02-10T08:27:41Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![fontexD](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fontexd/32/117095_2.png) [@fontexD](https://discuss.elastic.co/u/fontexD)
#### Post date: [February 10, 2023, 8:27am UTC](https://discuss.elastic.co/t/elastic-agent-random-shutdown-goes-offline/325223/1 "2023-02-10T08:27:41Z")

</div>

Ive deployed a elk stack with elastic kibana and fleet server, all going smooth using self-gen self-created certs for transport all the way and my own ssl in front via ingress

version 6.2.1  
created with elk operator in k8s 1.25.5  
im not using any proxy just nginx ingress

i get logs metric everything ! but at random times like every x 30-45 min agent goes offline for short time then comes online again

this is the log from the agent

and no there is NO connectvity error on the network, did alot of testing and benchmarking

[elastic\_agent][warn] Possible transient error during checkin with fleet-server, retrying  
21:48:40.396  
elastic\_agent  
[elastic\_agent][warn] Possible transient error during checkin with fleet-server, retrying  
21:52:22.736  
elastic\_agent  
[elastic\_agent][error] Cannot checkin in with fleet-server, retrying  
21:58:43.844  
elastic\_agent  
[elastic\_agent][error] Cannot checkin in with fleet-server, retrying  
22:12:32.261  
elastic\_agent  
[elastic\_agent][error] Cannot checkin in with fleet-server, retrying  
22:26:44.187  
elastic\_agent  
[elastic\_agent][error] Cannot checkin in with fleet-server, retrying  
22:38:12.181  
elastic\_agent  
[elastic\_agent][error] Cannot checkin in with fleet-server, retrying  
22:51:49.649  
elastic\_agent  
[elastic\_agent][error] Cannot checkin in with fleet-server, retrying  
22:54:39.891  
elastic\_agent  
[elastic\_agent][info] service.HandleSignals invoked stop function. Shutting down  
22:54:39.891  
elastic\_agent  
[elastic\_agent][info] Shutting down Elastic Agent and sending last events...  
22:54:39.891  
elastic\_agent  
[elastic\_agent][error] checkin retry loop was stopped  
22:54:39.998  
elastic\_agent  
[elastic\_agent][info] Shutting down completed.  
22:54:39.998  
elastic\_agent  
[elastic\_agent][info] Stats endpoint (127.0.0.1:6791) finished: accept tcp 127.0.0.1:6791: use of closed network connection  
22:59:00.697  
elastic\_agent  
[elastic\_agent][info] APM instrumentation disabled  
22:59:00.716  
elastic\_agent  
[elastic\_agent][info] Gathered system information  
22:59:00.750  
elastic\_agent  
[elastic\_agent][info] Detected available inputs and outputs  
22:59:00.751  
elastic\_agent  
[elastic\_agent][info] Capabilities file not found in C:\Program Files\Elastic\Agent\capabilities.yml  
22:59:00.751  
elastic\_agent  
[elastic\_agent][info] Determined allowed capabilities  
22:59:00.804  
elastic\_agent  
[elastic\_agent][info] Parsed configuration and determined agent is managed by Fleet  
22:59:00.833  
elastic\_agent  
[elastic\_agent][info] Starting stats endpoint  
22:59:00.833  
elastic\_agent  
[elastic\_agent][info] Metrics endpoint listening on: 127.0.0.1:6791 (configured: [http://localhost:6791](http://localhost:6791))  
22:59:00.837  
elastic\_agent  
[elastic\_agent][info] Docker provider skipped, unable to connect: protocol not available  
22:59:01.045  
elastic\_agent  
[elastic\_agent][info] restoring current policy from disk  
22:59:01.071  
elastic\_agent  
[elastic\_agent][info] Source URI changed from "[https://artifacts.elastic.co/downloads/](https://artifacts.elastic.co/downloads/)" to "[https://artifacts.elastic.co/downloads/](https://artifacts.elastic.co/downloads/)"  
22:59:01.073  
elastic\_agent  
[elastic\_agent][info] Updating running component model  
22:59:01.315  
elastic\_agent  
[elastic\_agent][info] Spawned new component windows/metrics-default: Starting: spawned pid '26520'  
22:59:01.315  
elastic\_agent  
[elastic\_agent][info] Spawned new unit windows/metrics-default-windows/metrics-windows-6c01787c-8085-434e-a80f-0dbc38cc5b19: Starting: spawned pid '26520'  
22:59:01.315  
elastic\_agent  
[elastic\_agent][info] Spawned new unit windows/metrics-default: Starting: spawned pid '26520'  
22:59:01.404  
elastic\_agent  
[elastic\_agent][info] Spawned new component log-default: Starting: spawned pid '23380'  
22:59:01.404  
elastic\_agent  
[elastic\_agent][info] Spawned new unit log-default-logfile-system-e199b296-bd50-4066-b9ea-85ebebe3bed2: Starting: spawned pid '23380'

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 10, 2023, 8:28am UTC](https://discuss.elastic.co/t/elastic-agent-random-shutdown-goes-offline/325223/2 "2023-03-10T08:28:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
