# Elastic Agent

**URL:** <https://discuss.elastic.co/t/elastic-agent/265670>\
**Category:** Endpoint Security\
**Tags:** fleet\
**Created:** [February 26, 2021, 9:12pm UTC](https://discuss.elastic.co/t/elastic-agent/265670 "2021-02-26T21:12:36Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Cosmin\_Ciobanu1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cosmin_ciobanu1/32/78785_2.png) [@Cosmin\_Ciobanu1](https://discuss.elastic.co/u/Cosmin_Ciobanu1)\
**Post date:** [February 26, 2021, 9:12pm UTC](https://discuss.elastic.co/t/elastic-agent/265670/1 "2021-02-26T21:12:36Z")

</div>

Hi!  
I try to install Elastic Agent on my Windows and I have Elastic Stack on Ubuntu,  
but I have a big issue.  
"Certificate is valid for 10.10.10.19, not 10.10.10.19" is my error.  
It seem pretty sus.  
Any idea?  
Thank you!

---

<div class="post-metadata">

**Author:** ![Cosmin\_Ciobanu1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cosmin_ciobanu1/32/78785_2.png) [@Cosmin\_Ciobanu1](https://discuss.elastic.co/u/Cosmin_Ciobanu1)\
**Post date:** [February 27, 2021, 3:27pm UTC](https://discuss.elastic.co/t/elastic-agent/265670/2 "2021-02-27T15:27:08Z")

</div>

I've resolved this and now I get "failed: fail to ack to fleet: Post "[https://0.0.0.0:5601/api/fleet/agents/0ab048c0-7903-11eb-bd1d-eb9cc937dc33/acks?":](https://0.0.0.0:5601/api/fleet/agents/0ab048c0-7903-11eb-bd1d-eb9cc937dc33/acks?%22:) dial tcp 0.0.0.0:5601: connectex: No connection could be made because the target machine actively refused it."  
My problem is that I have Kibana on 10.10.10.19 IP and it is trying to use localhost. Where should I change this?  
Thank you!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 27, 2021, 3:27pm UTC](https://discuss.elastic.co/t/elastic-agent/265670/3 "2021-03-27T15:27:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
