# Elastic APM agent not getting started after adding it into Weblogic startup script

**URL:** <https://discuss.elastic.co/t/elastic-apm-agent-not-getting-started-after-adding-it-into-weblogic-startup-script/254561>\
**Category:** APM\
**Tags:** java\
**Created:** [November 6, 2020, 5:29pm UTC](https://discuss.elastic.co/t/elastic-apm-agent-not-getting-started-after-adding-it-into-weblogic-startup-script/254561 "2020-11-06T17:29:01Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![bishanjitk](https://avatars.discourse-cdn.com/v4/letter/b/b5ac83/32.png) [@bishanjitk](https://discuss.elastic.co/u/bishanjitk)\
**Post date:** [November 6, 2020, 5:29pm UTC](https://discuss.elastic.co/t/elastic-apm-agent-not-getting-started-after-adding-it-into-weblogic-startup-script/254561/1 "2020-11-06T17:29:01Z")

</div>

```auto
2020-11-05 02:49:33,459 [main] ERROR co.elastic.apm.agent.util.DependencyInjectingServiceLoader - unable to instantiate 'co.elastic.apm.agent.httpclient.HttpClientInstr
umentation', unsupported class version error: co/elastic/apm/agent/httpclient/HttpClientInstrumentation has been compiled by a more recent version of the Java Runtime (
class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
2020-11-05 02:49:33,460 [main] ERROR co.elastic.apm.agent.util.DependencyInjectingServiceLoader - unable to instantiate 'co.elastic.apm.agent.httpclient.HttpClientAsync
Instrumentation', unsupported class version error: co/elastic/apm/agent/httpclient/HttpClientAsyncInstrumentation has been compiled by a more recent version of the Java
Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
2020-11-05 02:49:33,461 [main] ERROR co.elastic.apm.agent.util.DependencyInjectingServiceLoader - unable to instantiate 'co.elastic.apm.agent.httpclient.HttpRequestHead
ersInstrumentation', unsupported class version error: co/elastic/apm/agent/httpclient/HttpRequestHeadersInstrumentation has been compiled by a more recent version of th
e Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
2020-11-05 02:49:39,621 [main] INFO co.elastic.apm.agent.impl.ElasticApmTracer - Tracer switched to RUNNING state
Error: Could not find or load main class Agent
2020-11-05 02:49:39,874 [elastic-apm-init-instrumentation-shutdown-hook] INFO co.elastic.apm.agent.impl.ElasticApmTracer - Tracer switched to STOPPED state
2020-11-05 02:49:39,874 [elastic-apm-init-instrumentation-shutdown-hook] INFO co.elastic.apm.agent.report.ApmServerReporter - dropped events because of full queue: 0
2020-11-05 02:49:39,883 [elastic-apm-init-instrumentation-shutdown-hook] INFO co.elastic.apm.agent.report.IntakeV2ReportingEventHandler - Reported events: 0
2020-11-05 02:49:39,883 [elastic-apm-init-instrumentation-shutdown-hook] INFO co.elastic.apm.agent.report.IntakeV2ReportingEventHandler - Dropped events: 0
2020-11-05 02:49:39,884 [elastic-apm-circuit-breaker] INFO co.elastic.apm.agent.impl.circuitbreaker.CircuitBreaker - Stopping the Circuit Breaker thread.
2020-11-05 02:49:39,933 [elastic-apm-remote-config-poller] ERROR co.elastic.apm.agent.bci.IndyBootstrap - null
java.nio.channels.ClosedByInterruptException: null
        at java.nio.channels.spi.AbstractInterruptibleChannel.end(AbstractInterruptibleChannel.java:202) ~[?:1.8.0_191]
        at sun.nio.ch.FileChannelImpl.size(FileChannelImpl.java:315) ~[?:1.8.0_191]
        at com.sun.nio.zipfs.ZipFileSystem.findEND(ZipFileSystem.java:963) ~[zipfs.jar:1.8.0_191]
        at com.sun.nio.zipfs.ZipFileSystem.initCEN(ZipFileSystem.java:1030) ~[zipfs.jar:1.8.0_191]
        at com.sun.nio.zipfs.ZipFileSystem.<init>(ZipFileSystem.java:130) ~[zipfs.jar:1.8.0_191]
        at com.sun.nio.zipfs.ZipFileSystemProvider.newFileSystem(ZipFileSystemProvider.java:117) ~[zipfs.jar:1.8.0_191]
        at java.nio.file.FileSystems.newFileSystem(FileSystems.java:326) ~[?:1.8.0_191]
        at java.nio.file.FileSystems.newFileSystem(FileSystems.java:276) ~[?:1.8.0_191]
        at co.elastic.apm.agent.util.PackageScanner.getClassNames(PackageScanner.java:66) ~[?:?]
        at co.elastic.apm.agent.bci.IndyBootstrap.getClassNamesFromBundledPlugin(IndyBootstrap.java:303) ~[?:?]
        at co.elastic.apm.agent.bci.IndyBootstrap.bootstrap(IndyBootstrap.java:278) [?:?]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_191]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_191]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_191]
        at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_191]
        at java.lang.IndyBootstrapDispatcher.bootstrap(IndyBootstrapDispatcher.java:31) [?:1.8.0_191]
        at java.lang.invoke.CallSite.makeSite(CallSite.java:310) [?:1.8.0_191]
        at java.lang.invoke.MethodHandleNatives.linkCallSiteImpl(MethodHandleNatives.java:307) [?:1.8.0_191]
        at java.lang.invoke.MethodHandleNatives.linkCallSite(MethodHandleNatives.java:297) [?:1.8.0_191]
        at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:1293) [?:1.8.0_191]
        at co.elastic.apm.agent.configuration.ApmServerConfigurationSource.tryFetchConfig(ApmServerConfigurationSource.java:185) [?:?]
        at co.elastic.apm.agent.configuration.ApmServerConfigurationSource.access$100(ApmServerConfigurationSource.java:53) [?:?]
        at co.elastic.apm.agent.configuration.ApmServerConfigurationSource$2.withConnection(ApmServerConfigurationSource.java:166) [?:?]
        at co.elastic.apm.agent.configuration.ApmServerConfigurationSource$2.withConnection(ApmServerConfigurationSource.java:163) [?:?]
        at co.elastic.apm.agent.report.ApmServerClient.execute(ApmServerClient.java:254) [?:?]
        at co.elastic.apm.agent.configuration.ApmServerConfigurationSource.fetchConfig(ApmServerConfigurationSource.java:163) [?:?]
        at co.elastic.apm.agent.configuration.ApmServerConfigurationSource.pollConfig(ApmServerConfigurationSource.java:131) [?:?]
        at co.elastic.apm.agent.configuration.ApmServerConfigurationSource.access$000(ApmServerConfigurationSource.java:53) [?:?]
        at co.elastic.apm.agent.configuration.ApmServerConfigurationSource$1.run(ApmServerConfigurationSource.java:117) [?:?]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_191]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_191]
        at java.lang.Thread.run(Thread.java:748) [?:1.8.0_191]
2020-11-05 02:49:40,029 [elastic-apm-server-healthcheck] WARN co.elastic.apm.agent.report.ApmServerHealthChecker - Elastic APM server http://localhost:8200/ is not ava
ilable (Connection refused (Connection refused))
2020-11-05 02:49:40,030 [elastic-apm-remote-config-poller] ERROR co.elastic.apm.agent.configuration.ApmServerConfigurationSource - Connection refused (Connection refuse
d)

```

---

<div class="post-metadata">

**Author:** ![ylasri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ylasri/32/86120_2.png) [@ylasri](https://discuss.elastic.co/u/ylasri)\
**Post date:** [November 6, 2020, 5:33pm UTC](https://discuss.elastic.co/t/elastic-apm-agent-not-getting-started-after-adding-it-into-weblogic-startup-script/254561/2 "2020-11-06T17:33:46Z")

</div>

Make sure your APM server is running (curl localhost:8200)  
I suggest to use Agent version 1.18.1

---

<div class="post-metadata">

**Author:** ![felixbarny](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/felixbarny/32/27341_2.png) [@felixbarny](https://discuss.elastic.co/u/felixbarny)\
**Post date:** [November 7, 2020, 7:42am UTC](https://discuss.elastic.co/t/elastic-apm-agent-not-getting-started-after-adding-it-into-weblogic-startup-script/254561/3 "2020-11-07T07:42:59Z")

</div>

Seems to be the same issue than this one: [APM Agent does not start](https://discuss.elastic.co/t/apm-agent-does-not-start/252054/3)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 28, 2020, 3:43am UTC](https://discuss.elastic.co/t/elastic-apm-agent-not-getting-started-after-adding-it-into-weblogic-startup-script/254561/4 "2020-11-28T03:43:06Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
