# Elastic apm agent Read timed out issue

**URL:** <https://discuss.elastic.co/t/elastic-apm-agent-read-timed-out-issue/266818>\
**Category:** APM\
**Tags:** java\
**Created:** [March 10, 2021, 2:08pm UTC](https://discuss.elastic.co/t/elastic-apm-agent-read-timed-out-issue/266818 "2021-03-10T14:08:03Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![shurankain](https://avatars.discourse-cdn.com/v4/letter/s/958977/32.png) [@shurankain](https://discuss.elastic.co/u/shurankain)\
**Post date:** [March 10, 2021, 2:08pm UTC](https://discuss.elastic.co/t/elastic-apm-agent-read-timed-out-issue/266818/1 "2021-03-10T14:08:04Z")

</div>

We are using kibana 7.7 and co.elastic.apm:apm-agent-attach:1.21.0 and getting error soon after apm server starts. It makes our services visible in kibana, but anyway it logs such errors every 5 minutes: `[elastic-apm-remote-config-poller] ERROR co.elastic.apm.agent.configuration.ApmServerConfigurationSource - Read timed out`

In config we use only 3 properties and they all configured correctly:

```auto
service_name=...
application_packages=...
server_url=...

```

Maybe someone knows what is the problem? Or at least how to disable this errors logging, we do not want to read any remote config from server in our app.

---

<div class="post-metadata">

**Author:** ![Eyal\_Koren](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/eyal_koren/32/36830_2.png) [@Eyal\_Koren](https://discuss.elastic.co/u/Eyal_Koren)\
**Post date:** [March 10, 2021, 3:57pm UTC](https://discuss.elastic.co/t/elastic-apm-agent-read-timed-out-issue/266818/2 "2021-03-10T15:57:25Z")

</div>

Hi and welcome to our forum!

This error means that [agent central configuration](https://www.elastic.co/guide/en/kibana/7.7/agent-configuration.html) cannot be applied to this agent. If you don't need/want to use this feature, you can ignore these messages. If you do want it, you would need to configure a [Kibana endpoint](https://www.elastic.co/guide/en/kibana/7.7/agent-configuration.html#_apm_server_setup). If you did that as well and it still doesn't work, try looking in the APM Server logs to see if provides more info.

---

<div class="post-metadata">

**Author:** ![shurankain](https://avatars.discourse-cdn.com/v4/letter/s/958977/32.png) [@shurankain](https://discuss.elastic.co/u/shurankain)\
**Post date:** [March 11, 2021, 11:42am UTC](https://discuss.elastic.co/t/elastic-apm-agent-read-timed-out-issue/266818/3 "2021-03-11T11:42:23Z")

</div>

> [@shurankain](#):
>
> ApmServerConfigurationSource

Thanks a lot for your answer, maybe tere is some config value exists, that could disable this polling, to avoid undesired connection to server every 5 minutes and stop this logging at the same time?

---

<div class="post-metadata">

**Author:** ![Eyal\_Koren](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/eyal_koren/32/36830_2.png) [@Eyal\_Koren](https://discuss.elastic.co/u/Eyal_Koren)\
**Post date:** [March 11, 2021, 1:04pm UTC](https://discuss.elastic.co/t/elastic-apm-agent-read-timed-out-issue/266818/4 "2021-03-11T13:04:22Z")

</div>

There is - [`central_config`](https://www.elastic.co/guide/en/apm/agent/java/current/config-core.html#config-central-config), sorry for not mentioning it 🙏

---

<div class="post-metadata">

**Author:** ![shurankain](https://avatars.discourse-cdn.com/v4/letter/s/958977/32.png) [@shurankain](https://discuss.elastic.co/u/shurankain)\
**Post date:** [March 11, 2021, 2:00pm UTC](https://discuss.elastic.co/t/elastic-apm-agent-read-timed-out-issue/266818/5 "2021-03-11T14:00:20Z")

</div>

Great, thanks again, you saved me a lot of time 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 8, 2021, 2:00pm UTC](https://discuss.elastic.co/t/elastic-apm-agent-read-timed-out-issue/266818/6 "2021-04-08T14:00:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
