# Elastic APM not working due to error "Exception Type: TransportException Exception Value: HTTP 503: {"accepted":0,"errors":\[{"message":"queue is full"}\]}"

**URL:** https://discuss.elastic.co/t/elastic-apm-not-working-due-to-error-exception-type-transportexception-exception-value-http-503-accepted-0-errors-message-queue-is-full/322284
**Category:** APM
**Tags:** server
**Created:** [January 2, 2023, 6:43am UTC](https://discuss.elastic.co/t/elastic-apm-not-working-due-to-error-exception-type-transportexception-exception-value-http-503-accepted-0-errors-message-queue-is-full/322284 "2023-01-02T06:43:16Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![SUNA](https://avatars.discourse-cdn.com/v4/letter/s/f05b48/32.png) [@SUNA](https://discuss.elastic.co/u/SUNA)
#### Post date: [January 2, 2023, 6:43am UTC](https://discuss.elastic.co/t/elastic-apm-not-working-due-to-error-exception-type-transportexception-exception-value-http-503-accepted-0-errors-message-queue-is-full/322284/1 "2023-01-02T06:43:17Z")

</div>

Hi Team,

Elastic APM metrics not showing due to error "Exception Type: TransportException  
Exception Value: HTTP 503: {"accepted":0,"errors":[{"message":"queue is full"}]}"

Could you please help to clear queue to fix APM issue.

Currently my APM dashboard not working due to error below error

```auto
file_path: /var/www/api.wakefit.co/venv/lib/python3.6/site-packages/elasticapm/transport/base.py
func_name: handle_transport_fail
line_no: 334
Failed to submit message: 'HTTP 503: {"accepted":0,"errors":[{"message":"queue is full"}]}\n'
TransportException

Server time: Tue, 27 Dec 2022 06:36:38 +0530

Traceback:

File "/var/www/api.wakefit.co/venv/lib/python3.6/site-packages/elasticapm/transport/base.py" in _flush
  275. self.send(data, forced_flush=forced_flush)

File "/var/www/api.wakefit.co/venv/lib/python3.6/site-packages/elasticapm/transport/http.py" in send
  108. raise TransportException(message, data, print_trace=print_trace)

Exception Type: TransportException
Exception Value: HTTP 503: {"accepted":0,"errors":[{"message":"queue is full"}]}

```

Currently my APM dashboard error as below

```auto
![image|690x232](upload://7rH2lrrze1n5QV90soZdu4z2AtA.jpeg)

```

Could you please help to debug this issue and how to clear queue

---

<div class="post-metadata">

### Author: ![SUNA](https://avatars.discourse-cdn.com/v4/letter/s/f05b48/32.png) [@SUNA](https://discuss.elastic.co/u/SUNA)
#### Post date: [January 2, 2023, 6:45am UTC](https://discuss.elastic.co/t/elastic-apm-not-working-due-to-error-exception-type-transportexception-exception-value-http-503-accepted-0-errors-message-queue-is-full/322284/2 "2023-01-02T06:45:00Z")

</div>

Below APM Dashboard error

 ![Screenshot 2023-01-02 at 12.14.39 PM](https://us1.discourse-cdn.com/elastic/original/3X/5/3/53ee2c4ab3838c1f436402a0e970bcc641e889a6.jpeg)

---

<div class="post-metadata">

### Author: ![simitt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/simitt/32/106406_2.png) [@simitt](https://discuss.elastic.co/u/simitt)
#### Post date: [January 3, 2023, 8:03am UTC](https://discuss.elastic.co/t/elastic-apm-not-working-due-to-error-exception-type-transportexception-exception-value-http-503-accepted-0-errors-message-queue-is-full/322284/3 "2023-01-03T08:03:38Z")

</div>

Hi @SUNA ,

When the internal queue fills up, this is mostly due to mapping mismatches if the index template setup wasn't successful or due to the APM Server being overloaded. Since you don't see any data in the Kibana UI, I suspect that something with the setup might be wrong. Currently we have too little details to make any more specific suggestions. As a start, you should take a look at the APM Server logs and check if there are any errors, indicating what is the root cause of the queue filling up.

If you share any error logs in this forum, please redact any sensitive information before sharing, and also include some meta information around the version, installation method and how you set up the Elasticsearch index templates.

The APM Server guide has a [troubleshooting section for when the queue fills up](https://www.elastic.co/guide/en/apm/guide/7.17/common-problems.html#queue-full), please give it a read.

---

<div class="post-metadata">

### Author: ![SUNA](https://avatars.discourse-cdn.com/v4/letter/s/f05b48/32.png) [@SUNA](https://discuss.elastic.co/u/SUNA)
#### Post date: [January 3, 2023, 10:17am UTC](https://discuss.elastic.co/t/elastic-apm-not-working-due-to-error-exception-type-transportexception-exception-value-http-503-accepted-0-errors-message-queue-is-full/322284/4 "2023-01-03T10:17:40Z")

</div>

Thanks @simitt for your reply. will troubleshoot as you suggested.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 24, 2023, 6:18am UTC](https://discuss.elastic.co/t/elastic-apm-not-working-due-to-error-exception-type-transportexception-exception-value-http-503-accepted-0-errors-message-queue-is-full/322284/5 "2023-01-24T06:18:16Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
