# Elastic APM server is not available (Failed to connect to /0.0.0.0:8200)

**URL:** <https://discuss.elastic.co/t/elastic-apm-server-is-not-available-failed-to-connect-to-0-0-0-0-8200/151639>\
**Category:** APM\
**Created:** [October 9, 2018, 1:36pm UTC](https://discuss.elastic.co/t/elastic-apm-server-is-not-available-failed-to-connect-to-0-0-0-0-8200/151639 "2018-10-09T13:36:07Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![sri\_lakshmi](https://avatars.discourse-cdn.com/v4/letter/s/bb73d2/32.png) [@sri\_lakshmi](https://discuss.elastic.co/u/sri_lakshmi)\
**Post date:** [October 9, 2018, 1:36pm UTC](https://discuss.elastic.co/t/elastic-apm-server-is-not-available-failed-to-connect-to-0-0-0-0-8200/151639/1 "2018-10-09T13:36:07Z")

</div>

Hello Team,

I implemented java agent with spring boot application in docker  
ELK-6.4.2  
APM-Server-6.4.2  
APM-Agent : 0.7.0  
Java: 1.8.0\_161

elasticapm.properties file:

```
          service_name=my-cool-service
          application_packages=org.example
          server_url=http://0.0.0.0:8200
          logging.log_level=DEBUG
          active=true
          instrument=true

```

When i start the apm-server it is Connection to backoff(elasticsearch([http://10.0.1.221:9200](http://10.0.1.221:9200))) established,and one log file is visualized in kibana dashboard but No services were found.when i checked the docker logs it is showing like this

 ![apm-dockerlogs](https://us1.discourse-cdn.com/elastic/original/3X/5/a/5a795c1b15ef36eb52f42509a2b5eb3e8fe4d1ae.png)

This is my springboot application:

 ![apm](https://us1.discourse-cdn.com/elastic/original/3X/d/b/db398d4b5a0eb947f02ca332f82bbc3ca8496c1a.png)

please suggest me how to solve the issue  
Thanks in advance,  
Sri

---

<div class="post-metadata">

**Author:** ![felixbarny](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/felixbarny/32/27341_2.png) [@felixbarny](https://discuss.elastic.co/u/felixbarny)\
**Post date:** [October 11, 2018, 11:16am UTC](https://discuss.elastic.co/t/elastic-apm-server-is-not-available-failed-to-connect-to-0-0-0-0-8200/151639/2 "2018-10-11T11:16:33Z")

</div>

Hi and thanks for trying Elastic APM. This section in the troubleshooting guide may help you:  
[https://www.elastic.co/guide/en/apm/agent/java/current/trouble-shooting.html#trouble-shooting-no-data](https://www.elastic.co/guide/en/apm/agent/java/current/trouble-shooting.html#trouble-shooting-no-data)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 1, 2018, 7:16am UTC](https://discuss.elastic.co/t/elastic-apm-server-is-not-available-failed-to-connect-to-0-0-0-0-8200/151639/3 "2018-11-01T07:16:36Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
