# Elastic cloud - Cluster failing to restart - log4j JVM security issue

**URL:** <https://discuss.elastic.co/t/elastic-cloud-cluster-failing-to-restart-log4j-jvm-security-issue/292058>\
**Category:** Elasticsearch\
**Created:** [December 15, 2021, 11:18pm UTC](https://discuss.elastic.co/t/elastic-cloud-cluster-failing-to-restart-log4j-jvm-security-issue/292058 "2021-12-15T23:18:41Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ralph\_v](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ralph_v/32/99071_2.png) [@Ralph\_v](https://discuss.elastic.co/u/Ralph_v)\
**Post date:** [December 15, 2021, 11:18pm UTC](https://discuss.elastic.co/t/elastic-cloud-cluster-failing-to-restart-log4j-jvm-security-issue/292058/1 "2021-12-15T23:18:41Z")

</div>

Hello there,

Is anyone else experiencing problems restarting their older version \<7.2 elastic cloud cluster?  
I am following the recommendation for the Log4j vulnerability, which is for cloud users to restart their clusters. But in my case, it is not passing the 'Validating prerequisites' step.

 ![Screen Shot 2021-12-15 at 6.15.13 PM](https://us1.discourse-cdn.com/elastic/original/3X/1/e/1ea675d805805340ef94ea03091f240c880aeeaf.png)

> **Solutions and Mitigations:**
> 
> Deployments hosted in Elastic Cloud have been updated to leverage the JVM Option -Dlog4j2.formatMsgNoLookups=true which will take effect on restart of the deployment and on any config change to the Elasticsearch deployment.
> 
> For users running a cluster on a minor version older than 7.2, we recommend a restart.
> 
> The simplest way to restart a deployment is to do the following:
> 
> 1. Log in to the Cloud UI. Navigate to the “deployments” section in Elasticsearch Service.
> 2. Select the deployment you’d like to restart.
> 3. In the “manage” menu, select “restart”. Any kind of restart will work: “no downtime” restarts are fine.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 16, 2021, 7:53am UTC](https://discuss.elastic.co/t/elastic-cloud-cluster-failing-to-restart-log4j-jvm-security-issue/292058/2 "2021-12-16T07:53:54Z")

</div>

Please see [Support for Elastic Cloud, Hosted Elasticsearch | Elastic](https://www.elastic.co/cloud/elasticsearch-service/support) on how to raise a support ticket for Elastic Cloud 🙂

---

<div class="post-metadata">

**Author:** ![Ralph\_v](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ralph_v/32/99071_2.png) [@Ralph\_v](https://discuss.elastic.co/u/Ralph_v)\
**Post date:** [December 16, 2021, 3:05pm UTC](https://discuss.elastic.co/t/elastic-cloud-cluster-failing-to-restart-log4j-jvm-security-issue/292058/3 "2021-12-16T15:05:11Z")

</div>

Hi dadoonet,  
I do have a ticket open with Elastic, but it is looking like they will take the 72h to get to it, not exactly to have it solved.  
And at this point, I can't even see the snapshots on the dashboard anymore.

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [December 16, 2021, 7:14pm UTC](https://discuss.elastic.co/t/elastic-cloud-cluster-failing-to-restart-log4j-jvm-security-issue/292058/4 "2021-12-16T19:14:58Z")

</div>

@Ralph_v Did you try to reapply the plan / restart again?

---

<div class="post-metadata">

**Author:** ![Ralph\_v](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ralph_v/32/99071_2.png) [@Ralph\_v](https://discuss.elastic.co/u/Ralph_v)\
**Post date:** [December 16, 2021, 7:45pm UTC](https://discuss.elastic.co/t/elastic-cloud-cluster-failing-to-restart-log4j-jvm-security-issue/292058/5 "2021-12-16T19:45:38Z")

</div>

Hi stephenb,  
I did try restarting multiple times, and with different configuration also. Nothing worked

Earlier today there was a restart requested by 'system' and the cluster is online again. I am waiting on support to learn what was the issue.  
But at this point, I am afraid of restarting other clusters.

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [December 16, 2021, 7:50pm UTC](https://discuss.elastic.co/t/elastic-cloud-cluster-failing-to-restart-log4j-jvm-security-issue/292058/6 "2021-12-16T19:50:06Z")

</div>

Yes / Agree I would wait till you hear back from Support.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 13, 2022, 7:50pm UTC](https://discuss.elastic.co/t/elastic-cloud-cluster-failing-to-restart-log4j-jvm-security-issue/292058/7 "2022-01-13T19:50:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
