# Elastic Cluster on Azure Cloud - Linux - one server fails to startup while the other is successful

**URL:** <https://discuss.elastic.co/t/elastic-cluster-on-azure-cloud-linux-one-server-fails-to-startup-while-the-other-is-successful/241021>\
**Category:** Elasticsearch\
**Created:** [July 13, 2020, 5:56pm UTC](https://discuss.elastic.co/t/elastic-cluster-on-azure-cloud-linux-one-server-fails-to-startup-while-the-other-is-successful/241021 "2020-07-13T17:56:32Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Yamini\_Shashank](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yamini_shashank/32/66024_2.png) [@Yamini\_Shashank](https://discuss.elastic.co/u/Yamini_Shashank)\
**Post date:** [July 13, 2020, 5:56pm UTC](https://discuss.elastic.co/t/elastic-cluster-on-azure-cloud-linux-one-server-fails-to-startup-while-the-other-is-successful/241021/1 "2020-07-13T17:56:32Z")

</div>

Here is a configuration of a 2 node elastic cluster:

node.max\_local\_storage\_nodes: 2  
cluster.name: elasticsearch  
node.name: server2  
path.data: /etc/elasticsearch/data  
path.logs: /etc/elasticsearch/logs  
discovery.seed\_hosts: ["IPServer1","IPServer 2"]  
network.host: IPServer 2  
network.bind\_host: IPServer2  
node.master: true  
http.port: PORT

node.max\_local\_storage\_nodes: 2  
cluster.name: elasticsearch  
node.name: server1  
path.data: /etc/elasticsearch/data  
path.logs: /etc/elasticsearch/logs  
discovery.seed\_hosts: ["IPServer1","IPServer 2"]  
network.host: IPServer1  
network.bind\_host: IPServer1  
node.master: true  
http.port: PORT

While Server 1 launched successfully, the second server failed to start with this exception:  
'\> # ERROR: [1] bootstrap checks failed

> [1]: system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk  
> ERROR: Elasticsearch did not exit normally - check the logs at /etc/elasticsearch/logs/elasticsearch.log'

The logs do not indicate anything other than what is shared above..  
What could possibly be wrong with the above for a production setup..?  
@dadoonet, any suggestions or point me in a direction?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 14, 2020, 10:43pm UTC](https://discuss.elastic.co/t/elastic-cluster-on-azure-cloud-linux-one-server-fails-to-startup-while-the-other-is-successful/241021/2 "2020-07-14T22:43:36Z")

</div>

> [@Yamini\_Shashank](#):
>
> [1]: system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk

That would be this one [System call filter check | Elasticsearch Guide [8.11] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/_system_call_filter_check.html)

---

<div class="post-metadata">

**Author:** ![Yamini\_Shashank](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yamini_shashank/32/66024_2.png) [@Yamini\_Shashank](https://discuss.elastic.co/u/Yamini_Shashank)\
**Post date:** [July 16, 2020, 9:52am UTC](https://discuss.elastic.co/t/elastic-cluster-on-azure-cloud-linux-one-server-fails-to-startup-while-the-other-is-successful/241021/3 "2020-07-16T09:52:55Z")

</div>

Thank you for the response.  
I had seen this earlier as well.

> 'To pass the system call filter check you must either fix any configuration errors on your system that prevented system call filters from installing'

What does "system" mean here? Is it Elasticsearch or the OS or JVM?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 16, 2020, 10:39pm UTC](https://discuss.elastic.co/t/elastic-cluster-on-azure-cloud-linux-one-server-fails-to-startup-while-the-other-is-successful/241021/4 "2020-07-16T22:39:58Z")

</div>

The OS.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 13, 2020, 10:39pm UTC](https://discuss.elastic.co/t/elastic-cluster-on-azure-cloud-linux-one-server-fails-to-startup-while-the-other-is-successful/241021/5 "2020-08-13T22:39:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
