# Elastic Doesnt work after enabling security settings on ubuntu

**URL:** <https://discuss.elastic.co/t/elastic-doesnt-work-after-enabling-security-settings-on-ubuntu/206858>\
**Category:** Elasticsearch\
**Created:** [November 6, 2019, 7:45pm UTC](https://discuss.elastic.co/t/elastic-doesnt-work-after-enabling-security-settings-on-ubuntu/206858 "2019-11-06T19:45:04Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jayasri\_Cimba](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jayasri_cimba/32/50397_2.png) [@Jayasri\_Cimba](https://discuss.elastic.co/u/Jayasri_Cimba)\
**Post date:** [November 6, 2019, 7:45pm UTC](https://discuss.elastic.co/t/elastic-doesnt-work-after-enabling-security-settings-on-ubuntu/206858/1 "2019-11-06T19:45:04Z")

</div>

Caused by: java.lang.reflect.InvocationTargetException

Caused by: org.elasticsearch.ElasticsearchException: failed to initialize a TrustManagerFactory

Caused by: java.nio.file.AccessDeniedException: /etc/elasticsearch/elastic-certificates.p12  
[2019-11-06T18:59:19,626][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [node-1] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: failed to load plugin class [org.elasticsearch.xpack.core.XPackPlugin]

Caused by: java.lang.IllegalStateException: failed to load plugin class [org.elasticsearch.xpack.core.XPackPlugin]

Caused by: java.lang.reflect.InvocationTargetException

Caused by: org.elasticsearch.ElasticsearchException: failed to initialize a TrustManagerFactory

Caused by: java.nio.file.AccessDeniedException: /etc/elasticsearch/elastic-certificates.p12

---

<div class="post-metadata">

**Author:** ![learnelastic](https://avatars.discourse-cdn.com/v4/letter/l/ee7513/32.png) [@learnelastic](https://discuss.elastic.co/u/learnelastic)\
**Post date:** [November 6, 2019, 8:38pm UTC](https://discuss.elastic.co/t/elastic-doesnt-work-after-enabling-security-settings-on-ubuntu/206858/2 "2019-11-06T20:38:50Z")

</div>

It says AccessDenied exception for -

java.nio.file.AccessDeniedException: /etc/elasticsearch/elastic-certificates.p12

Can you check permission of this file.

Thanks

---

<div class="post-metadata">

**Author:** ![Jayasri\_Cimba](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jayasri_cimba/32/50397_2.png) [@Jayasri\_Cimba](https://discuss.elastic.co/u/Jayasri_Cimba)\
**Post date:** [November 6, 2019, 9:12pm UTC](https://discuss.elastic.co/t/elastic-doesnt-work-after-enabling-security-settings-on-ubuntu/206858/3 "2019-11-06T21:12:52Z")

</div>

> [@learnelastic](#):
>
> /etc/elasticsearch/elastic-certificates.p12

root@elastic-trial:/usr/share/elasticsearch/bin# ls -l /etc/elasticsearch/elastic-certificates.p12  
-rw------- 1 root elasticsearch 3443 Nov 6 17:47 /etc/elasticsearch/elastic-certificates.p12

this is what I get when I look for permissions

---

<div class="post-metadata">

**Author:** ![learnelastic](https://avatars.discourse-cdn.com/v4/letter/l/ee7513/32.png) [@learnelastic](https://discuss.elastic.co/u/learnelastic)\
**Post date:** [November 6, 2019, 10:03pm UTC](https://discuss.elastic.co/t/elastic-doesnt-work-after-enabling-security-settings-on-ubuntu/206858/4 "2019-11-06T22:03:33Z")

</div>

change ownership as mentioned below and try again -

chown elasticsearch /etc/elasticsearch/elastic-certificates.p12

you need to be root to run this command.

---

<div class="post-metadata">

**Author:** ![Jayasri\_Cimba](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jayasri_cimba/32/50397_2.png) [@Jayasri\_Cimba](https://discuss.elastic.co/u/Jayasri_Cimba)\
**Post date:** [November 7, 2019, 7:09pm UTC](https://discuss.elastic.co/t/elastic-doesnt-work-after-enabling-security-settings-on-ubuntu/206858/5 "2019-11-07T19:09:44Z")

</div>

Thanks a lot .. it helped

And also this link : [https://www.server-world.info/en/note?os=CentOS\_7&p=elasticstack7&f=12](https://www.server-world.info/en/note?os=CentOS_7&p=elasticstack7&f=12)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 5, 2019, 7:23pm UTC](https://discuss.elastic.co/t/elastic-doesnt-work-after-enabling-security-settings-on-ubuntu/206858/6 "2019-12-05T19:23:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
