# Elastic Endpoint failed

**URL:** <https://discuss.elastic.co/t/elastic-endpoint-failed/358366>\
**Category:** Elastic Security\
**Created:** [April 28, 2024, 10:12am UTC](https://discuss.elastic.co/t/elastic-endpoint-failed/358366 "2024-04-28T10:12:32Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![mustafa.husny](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mustafa.husny/32/77154_2.png) [@mustafa.husny](https://discuss.elastic.co/u/mustafa.husny)\
**Post date:** [April 28, 2024, 10:12am UTC](https://discuss.elastic.co/t/elastic-endpoint-failed/358366/1 "2024-04-28T10:12:32Z")

</div>

I am running elastic v8.13 on linux machine  
I am trying to monitor K8S cluster (SIEM - FIM and EDR)  
the agent is installed and I can get all nodes, then I added the system and FIM integration with no issues, the issue happen when I am trying to add Elastic Endpoint security integration, it fails with error

failed install endpoint service error:Util.cpp:92 Service ElasticEndpoint already exists:exit status 21

Can anyone advice how can I troubleshoot or the root cause of the issue?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 26, 2024, 10:13am UTC](https://discuss.elastic.co/t/elastic-endpoint-failed/358366/2 "2024-05-26T10:13:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
