# Elastic-hadoop access failing due to SSL check

**URL:** https://discuss.elastic.co/t/elastic-hadoop-access-failing-due-to-ssl-check/328857
**Category:** Elasticsearch
**Tags:** es-hadoop
**Created:** [March 29, 2023, 7:28pm UTC](https://discuss.elastic.co/t/elastic-hadoop-access-failing-due-to-ssl-check/328857 "2023-03-29T19:28:26Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![NN1](https://avatars.discourse-cdn.com/v4/letter/n/ebca7d/32.png) [@NN1](https://discuss.elastic.co/u/NN1)
#### Post date: [March 29, 2023, 7:28pm UTC](https://discuss.elastic.co/t/elastic-hadoop-access-failing-due-to-ssl-check/328857/1 "2023-03-29T19:28:26Z")

</div>

I am trying to connect to a https ES node through my external table created in hdfs cluster. I connect to this hdfs cluster from my linux server using beeline and created the external table setting the property 'es.net.ssl.truststore.location'  
tried placing the .jks keystore file in a hdfs path and used this path against this property and it throws the error "org.elasticsearch.hadoop.EsHadoopIllegalArgumentException: Expected to find keystore file at "  
tried placing the file on a the local server from where i connect to the hive and set that path as 'file:///' and that fails too  
i see posts about placing the jks file in classpath , can you please confirm where exactly this needs to be placed

---

<div class="post-metadata">

### Author: ![Keith\_Massey](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/keith_massey/32/83666_2.png) [@Keith\_Massey](https://discuss.elastic.co/u/Keith_Massey)
#### Post date: [March 29, 2023, 9:27pm UTC](https://discuss.elastic.co/t/elastic-hadoop-access-failing-due-to-ssl-check/328857/2 "2023-03-29T21:27:18Z")

</div>

It's hard to tell exactly what's wrong from what you describe, but you have seen this? [Security | Elasticsearch for Apache Hadoop [8.6] | Elastic](https://www.elastic.co/guide/en/elasticsearch/hadoop/current/security.html#keystore)  
Specifically:

```auto
This can be done by placing it on each node’s local file system, or by adding the keystore to the job’s classpath.

```

Do you have it accessible at the same location on each node? Or are you attempting to put it in your classpath?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 26, 2023, 9:27pm UTC](https://discuss.elastic.co/t/elastic-hadoop-access-failing-due-to-ssl-check/328857/3 "2023-04-26T21:27:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
