# Elastic JDBC connectivity failing from Tableau,Dbeaver clients

**URL:** <https://discuss.elastic.co/t/elastic-jdbc-connectivity-failing-from-tableau-dbeaver-clients/180494>\
**Category:** Elasticsearch\
**Created:** [May 10, 2019, 6:23am UTC](https://discuss.elastic.co/t/elastic-jdbc-connectivity-failing-from-tableau-dbeaver-clients/180494 "2019-05-10T06:23:05Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![mukeshdantuluri](https://avatars.discourse-cdn.com/v4/letter/m/4af34b/32.png) [@mukeshdantuluri](https://discuss.elastic.co/u/mukeshdantuluri)\
**Post date:** [May 10, 2019, 6:23am UTC](https://discuss.elastic.co/t/elastic-jdbc-connectivity-failing-from-tableau-dbeaver-clients/180494/1 "2019-05-10T06:23:05Z")

</div>

We are trying to connect elastic search from Dbeaver and Tableau , but unable to do the same .  
Below is the client we are using :  
[https://www.elastic.co/downloads/jdbc-client](https://www.elastic.co/downloads/jdbc-client)

We are facing issues while connecting . Below is the error we get .

(elastic\_search\_jdbc-16a91c1fa71-412915256966a3ec)  
2019-05-10 11:44:43.514 - \> Start org.jkiss.dbeaver.ext.generic [2.3.94.201905052017]  
2019-05-10 11:44:43.515 - \> Start org.jkiss.dbeaver.ext.es.ui [1.0.19.201905052017]  
2019-05-10 11:44:44.028 - Can't fetch database data types  
org.jkiss.dbeaver.DBException: SQL Error: action [indices:admin/create] is unauthorized for user [adametricsjdbc]  
at org.jkiss.dbeaver.model.impl.jdbc.cache.JDBCObjectCache.loadObjects(JDBCObjectCache.java:131)  
at org.jkiss.dbeaver.model.impl.jdbc.cache.JDBCObjectCache.getAllObjects(JDBCObjectCache.java:70)  
at org.jkiss.dbeaver.ext.generic.model.GenericDataSource.initialize(GenericDataSource.java:432)  
at org.jkiss.dbeaver.registry.DataSourceDescriptor.connect(DataSourceDescriptor.java:782)  
at org.jkiss.dbeaver.runtime.jobs.ConnectJob.run(ConnectJob.java:70)  
at org.jkiss.dbeaver.model.runtime.AbstractJob.run(AbstractJob.java:102)  
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)  
Caused by: java.sql.SQLInvalidAuthorizationSpecException: action [indices:admin/create] is unauthorized for user [adametricsjdbc]  
at org.elasticsearch.xpack.sql.client.JreHttpUrlConnection$SqlExceptionType.asException(JreHttpUrlConnection.java:322)  
at org.elasticsearch.xpack.sql.client.JreHttpUrlConnection.parserError(JreHttpUrlConnection.java:199)  
at org.elasticsearch.xpack.sql.client.JreHttpUrlConnection.request(JreHttpUrlConnection.java:161)  
at org.elasticsearch.xpack.sql.client.HttpClient.lambda$post$1(HttpClient.java:101)  
at org.elasticsearch.xpack.sql.client.JreHttpUrlConnection.http(JreHttpUrlConnection.java:65)  
at org.elasticsearch.xpack.sql.client.HttpClient.lambda$post$2(HttpClient.java:100)  
at java.security.AccessController.doPrivileged(Native Method)  
at org.elasticsearch.xpack.sql.client.HttpClient.post(HttpClient.java:99)  
at org.elasticsearch.xpack.sql.client.HttpClient.query(HttpClient.java:76)  
at org.elasticsearch.xpack.sql.jdbc.JdbcHttpClient.query(JdbcHttpClient.java:55)  
at org.elasticsearch.xpack.sql.jdbc.JdbcStatement.initResultSet(JdbcStatement.java:160)  
at org.elasticsearch.xpack.sql.jdbc.JdbcStatement.execute(JdbcStatement.java:151)  
at org.elasticsearch.xpack.sql.jdbc.JdbcStatement.executeQuery(JdbcStatement.java:40)  
at org.elasticsearch.xpack.sql.jdbc.JdbcDatabaseMetaData.getTypeInfo(JdbcDatabaseMetaData.java:838)  
at org.jkiss.dbeaver.model.impl.jdbc.exec.JDBCDatabaseMetaDataImpl.getTypeInfo(JDBCDatabaseMetaDataImpl.java:1235)  
at org.jkiss.dbeaver.model.impl.jdbc.cache.JDBCBasicDataTypeCache.prepareObjectsStatement(JDBCBasicDataTypeCache.java:54)  
at org.jkiss.dbeaver.model.impl.jdbc.cache.JDBCObjectCache.loadObjects(JDBCObjectCache.java:100)  
... 6 more  
2019-05-10 11:44:44.072 - Can't get column 'TABLE\_OWNER': Invalid column label [TABLE\_OWNER]  
2019-05-10 11:44:44.083 - Connected (elastic\_search\_jdbc-16a91c1fa71-412915256966a3ec, Elasticsearch JDBC Driver [6.6])

---

<div class="post-metadata">

**Author:** ![matriv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matriv/32/43656_2.png) [@matriv](https://discuss.elastic.co/u/matriv)\
**Post date:** [May 11, 2019, 1:31pm UTC](https://discuss.elastic.co/t/elastic-jdbc-connectivity-failing-from-tableau-dbeaver-clients/180494/2 "2019-05-11T13:31:23Z")

</div>

Could you please provide us with your server version you're trying to connect to?

Also it seems that you're currently using **6.6** version of the JDBC driver. We recommend you to upgrade so that you use the same JDBC version as the one of the server.

---

<div class="post-metadata">

**Author:** ![sunilmchaudhari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sunilmchaudhari/32/9475_2.png) [@sunilmchaudhari](https://discuss.elastic.co/u/sunilmchaudhari)\
**Post date:** [May 13, 2019, 7:23am UTC](https://discuss.elastic.co/t/elastic-jdbc-connectivity-failing-from-tableau-dbeaver-clients/180494/3 "2019-05-13T07:23:08Z")

</div>

Hi Matriv,  
We are using ES-5.6 version.

---

<div class="post-metadata">

**Author:** ![matriv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matriv/32/43656_2.png) [@matriv](https://discuss.elastic.co/u/matriv)\
**Post date:** [May 23, 2019, 4:11pm UTC](https://discuss.elastic.co/t/elastic-jdbc-connectivity-failing-from-tableau-dbeaver-clients/180494/4 "2019-05-23T16:11:47Z")

</div>

I'm afraid you'd need to upgrade to at least 6.8 or even better to 7.1 (7.2 is also gonna be released soon), since the SQL functionality was declared GA with 6.7.

Please also make sure that you are using the exact same version of the JDBC driver as the version of your deployed ES cluster.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 20, 2019, 4:11pm UTC](https://discuss.elastic.co/t/elastic-jdbc-connectivity-failing-from-tableau-dbeaver-clients/180494/5 "2019-06-20T16:11:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
