# Elastic Lab 1.4

**URL:** <https://discuss.elastic.co/t/elastic-lab-1-4/269131>\
**Category:** Logstash\
**Created:** [April 2, 2021, 6:52pm UTC](https://discuss.elastic.co/t/elastic-lab-1-4/269131 "2021-04-02T18:52:28Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Troy\_Kelley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/troy_kelley/32/86522_2.png) [@Troy\_Kelley](https://discuss.elastic.co/u/Troy_Kelley)\
**Post date:** [April 2, 2021, 6:52pm UTC](https://discuss.elastic.co/t/elastic-lab-1-4/269131/1 "2021-04-02T18:52:28Z")

</div>

Hello,

I am working through the elastic lab 1.4. I am not using virtual lab, I am running mine locally.

For some reason I did not have the blogs\_sql.conf when I installed Elastic. So, I found an example on the web, created the file, and put it into the datasets directory.

Now I am trying to run logstash with the following command from the lab manual

./logstash-7.8.0/bin/logstash -f datasets/blogs\_sql.conf

I get a reflector error like this

An illegal reflective access operation has occurred

Also, I get a lot of output, but most errors are associated with permissions like the one below.

Error: unable to load /home/troy/elastic/postgresql-42.2.9.jar from :jdbc\_driver\_library, file not readable (please check user and group permissions for the path)  
Exception: LogStash::PluginLoadingError

I have done a chmod on all the files, and the permissions should be fine. Please let me know if you have any ideas as to what the problem is.

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [April 2, 2021, 8:10pm UTC](https://discuss.elastic.co/t/elastic-lab-1-4/269131/2 "2021-04-02T20:10:45Z")

</div>

> [@Troy\_Kelley](#):
>
> the permissions should be fine

And yet logstash says they are not. I would suggest using strace (or the equivalent on your flavour of UNIX) to trace all the system calls. Write all that to a file and after the error grep for postgresql-42 in it.

You can ignore the illegal reflective access message. At some point whoever owns that code will get around to fixing it and a new version of logstash will pick up the new code.

---

<div class="post-metadata">

**Author:** ![Troy\_Kelley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/troy_kelley/32/86522_2.png) [@Troy\_Kelley](https://discuss.elastic.co/u/Troy_Kelley)\
**Post date:** [April 7, 2021, 2:47pm UTC](https://discuss.elastic.co/t/elastic-lab-1-4/269131/3 "2021-04-07T14:47:52Z")

</div>

Looks like I dont even have the tables of blog data for the postgres database.

Pipeline\_id:main  
Plugin: \<LogStash::Inputs::Jdbc jdbc\_user=\>"postgres",  
jdbc\_password=\>, statement=\>"SELECT \* from blogs",  
jdbc\_driver\_library=\>"/home/troy/elastic/postgresql-42.2.19.jar",  
jdbc\_connection\_string=\>"jdbc:postgresql://db\_server:5432/",  
id=\>"1d9770372769750dbc0e037d2dd104b39ce6859f3cd417749585bd72b460cdee",  
jdbc\_driver\_class=\>"org.postgresql.Driver", enable\_metric=\>true,  
codec=\>\<LogStash::Codecs::Plain  
id=\>"plain\_f3475974-8694-41d6-b097-40540228cac4", enable\_metric=\>true,  
charset=\>"UTF-8"\>, jdbc\_paging\_enabled=\>false, jdbc\_page\_size=\>100000,  
jdbc\_validate\_connection=\>false, jdbc\_validation\_timeout=\>3600,  
jdbc\_pool\_timeout=\>5, sql\_log\_level=\>"info",  
connection\_retry\_attempts=\>1,  
connection\_retry\_attempts\_wait\_time=\>0.5, plugin\_timezone=\>"utc",  
last\_run\_metadata\_path=\>"/home/troy/.logstash\_jdbc\_last\_run",  
use\_column\_value=\>false, tracking\_column\_type=\>"numeric",  
clean\_run=\>false, record\_last\_run=\>true, lowercase\_column\_names=\>true,  
use\_prepared\_statements=\>false\>

The part of the lab is on page 13 of the attached document.

I am trying to recreate the lab locally.

Thanks,

(Attachment Lab Guide Elasticsearch Engineer I(1).pdf is missing)

---

<div class="post-metadata">

**Author:** ![Troy\_Kelley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/troy_kelley/32/86522_2.png) [@Troy\_Kelley](https://discuss.elastic.co/u/Troy_Kelley)\
**Post date:** [April 7, 2021, 2:59pm UTC](https://discuss.elastic.co/t/elastic-lab-1-4/269131/4 "2021-04-07T14:59:20Z")

</div>

Actually, looks like I fixed it. The ingest for the local machine is  
a CSV file, which I found. Thanks.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 5, 2021, 2:59pm UTC](https://discuss.elastic.co/t/elastic-lab-1-4/269131/5 "2021-05-05T14:59:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
