# Elastic nodes started to give hardware error on esxi 8.01c servers

**URL:** https://discuss.elastic.co/t/elastic-nodes-started-to-give-hardware-error-on-esxi-8-01c-servers/346208
**Category:** Elasticsearch
**Created:** [November 1, 2023, 2:47pm UTC](https://discuss.elastic.co/t/elastic-nodes-started-to-give-hardware-error-on-esxi-8-01c-servers/346208 "2023-11-01T14:47:00Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![cemkayar](https://avatars.discourse-cdn.com/v4/letter/c/ec9cab/32.png) [@cemkayar](https://discuss.elastic.co/u/cemkayar)
#### Post date: [November 1, 2023, 2:47pm UTC](https://discuss.elastic.co/t/elastic-nodes-started-to-give-hardware-error-on-esxi-8-01c-servers/346208/1 "2023-11-01T14:47:00Z")

</div>

Hi,  
After upgrading ESXi servers from 7.0.3l to 8.0.1c some of the elastic clusters started to give hardware errors during index hash. If move the problematic elastics VMs to the old version of the esxi servers (7.0.3l version) again, the problem is fixed. What do we need to do on vm or elastic app to understand the root cause?

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [November 1, 2023, 3:02pm UTC](https://discuss.elastic.co/t/elastic-nodes-started-to-give-hardware-error-on-esxi-8-01c-servers/346208/2 "2023-11-01T15:02:03Z")

</div>

Hello and welcome,

It is not clear if this is an issue with Elasticsearch or with your infrastructure.

Is the Elasticsearch service running on those VMs giving some error, or the error is in the VM itself?

---

<div class="post-metadata">

### Author: ![cemkayar](https://avatars.discourse-cdn.com/v4/letter/c/ec9cab/32.png) [@cemkayar](https://discuss.elastic.co/u/cemkayar)
#### Post date: [November 1, 2023, 3:20pm UTC](https://discuss.elastic.co/t/elastic-nodes-started-to-give-hardware-error-on-esxi-8-01c-servers/346208/3 "2023-11-01T15:20:08Z")

</div>

The VMs are running on the ESXi cluster as a virtual machine. Elastic services are running on those VMs. The hardware error logs came across in elastic logs.  
Actually I am asking to understand it was related to VMware ESXi or elastic.

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [November 1, 2023, 3:27pm UTC](https://discuss.elastic.co/t/elastic-nodes-started-to-give-hardware-error-on-esxi-8-01c-servers/346208/4 "2023-11-01T15:27:43Z")

</div>

> [@cemkayar](#):
>
> The hardware error logs came across in elastic logs.  
> Actually I am asking to understand it was related to VMware ESXi or elastic.

Which Logs? Your system logs or Elastic Service logs? You need to share it.

From what you shared this seems to be a ESXi issue, not an Elastic issue.

---

<div class="post-metadata">

### Author: ![cemkayar](https://avatars.discourse-cdn.com/v4/letter/c/ec9cab/32.png) [@cemkayar](https://discuss.elastic.co/u/cemkayar)
#### Post date: [November 1, 2023, 3:29pm UTC](https://discuss.elastic.co/t/elastic-nodes-started-to-give-hardware-error-on-esxi-8-01c-servers/346208/5 "2023-11-01T15:29:52Z")

</div>

Elastic server log like below

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/a/0/a0bdc9a0a8cd5a2a31577d43b9323fdacbc3b891.png)

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [November 1, 2023, 4:27pm UTC](https://discuss.elastic.co/t/elastic-nodes-started-to-give-hardware-error-on-esxi-8-01c-servers/346208/6 "2023-11-01T16:27:16Z")

</div>

Yeah, those Elasticsearch errors are normally related to underlying hardware issues, you may need to investigate on the ESXi side, but I'm not sure how.

---

<div class="post-metadata">

### Author: ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)
#### Post date: [November 1, 2023, 4:44pm UTC](https://discuss.elastic.co/t/elastic-nodes-started-to-give-hardware-error-on-esxi-8-01c-servers/346208/7 "2023-11-01T16:44:04Z")

</div>

Yeah this is pretty much certain to be infrastructural, see [Troubleshooting corruption | Elasticsearch Guide [8.10] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/corruption-troubleshooting.html) for more info.

---

<div class="post-metadata">

### Author: ![cemkayar](https://avatars.discourse-cdn.com/v4/letter/c/ec9cab/32.png) [@cemkayar](https://discuss.elastic.co/u/cemkayar)
#### Post date: [November 3, 2023, 9:32am UTC](https://discuss.elastic.co/t/elastic-nodes-started-to-give-hardware-error-on-esxi-8-01c-servers/346208/8 "2023-11-03T09:32:38Z")

</div>

Hello @DavidTurner and @leandrojmp

With the following article, can we say "it should be related to Elasticsearch"?  
In our example, only one thing changed that was esxi version. The guest OS version is the same and elastic VMs are run on the same bare metal servers.

> **[Canonical, Elastic, and Google team up to prevent data corruption in Linux](https://www.elastic.co/blog/canonical-elastic-and-google-team-up-to-prevent-data-corruption-in-linux)**
>
> While testing a new Elastic Stack feature we discovered a Linux kernel bug affecting SSD disks on certain Linux kernels. Learn how the investigation involved a great collaboration with two close partners: Google Cloud and Canonical.

---

<div class="post-metadata">

### Author: ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)
#### Post date: [November 3, 2023, 9:56am UTC](https://discuss.elastic.co/t/elastic-nodes-started-to-give-hardware-error-on-esxi-8-01c-servers/346208/9 "2023-11-03T09:56:09Z")

</div>

No, the bug in the article you linked was entirely in the Linux kernel. Its only relationship with Elasticsearch was that we discovered it.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 1, 2023, 9:56am UTC](https://discuss.elastic.co/t/elastic-nodes-started-to-give-hardware-error-on-esxi-8-01c-servers/346208/10 "2023-12-01T09:56:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
