# Elastic-operator fails to spin up ES cluster

**URL:** <https://discuss.elastic.co/t/elastic-operator-fails-to-spin-up-es-cluster/261029>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Created:** [January 13, 2021, 5:02pm UTC](https://discuss.elastic.co/t/elastic-operator-fails-to-spin-up-es-cluster/261029 "2021-01-13T17:02:17Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![mu44ly](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mu44ly/32/50914_2.png) [@mu44ly](https://discuss.elastic.co/u/mu44ly)\
**Post date:** [January 13, 2021, 5:02pm UTC](https://discuss.elastic.co/t/elastic-operator-fails-to-spin-up-es-cluster/261029/1 "2021-01-13T17:02:17Z")

</div>

Hello,

I've installed eck-operator using all-in-one.yaml example ([https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-deploy-eck.html](https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-deploy-eck.html)). It started ok, but constantly complains in logs (verbosity=1):

```auto
E0113 16:47:58.885664 1 reflector.go:178] pkg/mod/k8s.io/client-go@v0.18.6/tools/cache/reflector.go:125: Failed to list *v1.Secret: stream error when reading response body, may be caused by closed connection. Please retry. Original error: stream error: stream ID 865; INTERNAL_ERROR
I0113 16:49:30.669670 1 trace.go:205] Trace[668989355]: "Reflector ListAndWatch" name:pkg/mod/k8s.io/client-go@v0.18.6/tools/cache/reflector.go:125 (13-Jan-2021 16:48:30.668) (total time: 60001ms):
Trace[668989355]: [1m0.001093298s] [1m0.001093298s] END

```

Creation of quickstart cluster, using [https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-deploy-elasticsearch.html](https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-deploy-elasticsearch.html) example, just creates Elasticsearch resource but no pods or secrets or other artifacts. It looks that operator ignores this definition or just can't find it.

K8s cluster is AWS EKS, version 1.16, supporting set of other resources and services. Any help is appreciated.

---

<div class="post-metadata">

**Author:** ![michael.morello](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michael.morello/32/47448_2.png) [@michael.morello](https://discuss.elastic.co/u/michael.morello)\
**Post date:** [January 14, 2021, 3:40pm UTC](https://discuss.elastic.co/t/elastic-operator-fails-to-spin-up-es-cluster/261029/2 "2021-01-14T15:40:43Z")

</div>

> [@mu44ly](#):
>
> `Failed to list *v1.Secret: stream error when reading response body, may be caused by closed connection`

It looks like a connectivity issue between ECK and the control plane, or an error in the API Server. Can you provide the logs from the API server ?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 4, 2022, 8:21am UTC](https://discuss.elastic.co/t/elastic-operator-fails-to-spin-up-es-cluster/261029/3 "2022-11-04T08:21:34Z")

</div>


