# Elastic Search 5.2.1: \[Error\]- max file descriptors and max virtual memory

**URL:** <https://discuss.elastic.co/t/elastic-search-5-2-1-error-max-file-descriptors-and-max-virtual-memory/77563>\
**Category:** Elasticsearch\
**Created:** [March 6, 2017, 6:39pm UTC](https://discuss.elastic.co/t/elastic-search-5-2-1-error-max-file-descriptors-and-max-virtual-memory/77563 "2017-03-06T18:39:44Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![eramitsinha](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/eramitsinha/32/35032_2.png) [@eramitsinha](https://discuss.elastic.co/u/eramitsinha)\
**Post date:** [March 6, 2017, 6:39pm UTC](https://discuss.elastic.co/t/elastic-search-5-2-1-error-max-file-descriptors-and-max-virtual-memory/77563/1 "2017-03-06T18:39:44Z")

</div>

We are migrating to Elastic Search 5.2.1, and are in development phase. Elastic Search server is hosted on Unix environment. We were able to install server with plugin.  
But when server is started, its giving following error and get shut down. (Error persists when we run without plugin).

ERROR: bootstrap checks failed  
max file descriptors [32768] for elasticsearch process is too low, increase to at least [65536]  
max virtual memory areas vm.max\_map\_count [65536] is too low, increase to at least [262144]

So “max file descriptors” and “max virtual memory” are they sufficient as mentioned in log above or if they should be adjusted higher or lower.

Any Input will be helpful for us.

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [March 6, 2017, 10:22pm UTC](https://discuss.elastic.co/t/elastic-search-5-2-1-error-max-file-descriptors-and-max-virtual-memory/77563/2 "2017-03-06T22:22:31Z")

</div>

> [@eramitsinha](#):
>
> So “max file descriptors” and “max virtual memory” are they sufficient as mentioned in log above or if they should be adjusted higher or lower.

They both need to be adjusted to at least the values that are recommended there (65536 for the max number of file descriptors, which you currently have set to 32768, and 262144 for `vm.max_map_count` which you currently have set to 65536).

---

<div class="post-metadata">

**Author:** ![captaindelirious](https://avatars.discourse-cdn.com/v4/letter/c/ecccb3/32.png) [@captaindelirious](https://discuss.elastic.co/u/captaindelirious)\
**Post date:** [March 6, 2017, 11:10pm UTC](https://discuss.elastic.co/t/elastic-search-5-2-1-error-max-file-descriptors-and-max-virtual-memory/77563/3 "2017-03-06T23:10:15Z")

</div>

Hi, is there a way to come to an exact number for these values depending upon the production host? We will definitely add the minimum needed values for vm.max\_map\_count and ulimit for now. But just wanted to make sure if these values will work on different hosts? Thanks!

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [March 6, 2017, 11:23pm UTC](https://discuss.elastic.co/t/elastic-search-5-2-1-error-max-file-descriptors-and-max-virtual-memory/77563/4 "2017-03-06T23:23:48Z")

</div>

The values that you see here are the minimum required for any host, and they should generally be fine for any host as long as you're not doing anything silly like allocating 65536 shards to a single node.

---

<div class="post-metadata">

**Author:** ![captaindelirious](https://avatars.discourse-cdn.com/v4/letter/c/ecccb3/32.png) [@captaindelirious](https://discuss.elastic.co/u/captaindelirious)\
**Post date:** [March 6, 2017, 11:43pm UTC](https://discuss.elastic.co/t/elastic-search-5-2-1-error-max-file-descriptors-and-max-virtual-memory/77563/5 "2017-03-06T23:43:59Z")

</div>

Good to know. No, we don't have those many shards! Thanks!

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [March 6, 2017, 11:54pm UTC](https://discuss.elastic.co/t/elastic-search-5-2-1-error-max-file-descriptors-and-max-virtual-memory/77563/6 "2017-03-06T23:54:39Z")

</div>

You're very welcome.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 3, 2017, 11:55pm UTC](https://discuss.elastic.co/t/elastic-search-5-2-1-error-max-file-descriptors-and-max-virtual-memory/77563/7 "2017-04-03T23:55:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
