# Elastic Search 7.17.9 ClusterFormationFailure

**URL:** <https://discuss.elastic.co/t/elastic-search-7-17-9-clusterformationfailure/337963>\
**Category:** Elasticsearch\
**Created:** [July 9, 2023, 2:11pm UTC](https://discuss.elastic.co/t/elastic-search-7-17-9-clusterformationfailure/337963 "2023-07-09T14:11:33Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![SSRR](https://avatars.discourse-cdn.com/v4/letter/s/d07c76/32.png) [@SSRR](https://discuss.elastic.co/u/SSRR)\
**Post date:** [July 9, 2023, 2:11pm UTC](https://discuss.elastic.co/t/elastic-search-7-17-9-clusterformationfailure/337963/1 "2023-07-09T14:11:34Z")

</div>

I am facing some issues in my elasticsearch cluster related to Cluster Formation with 2 nodes.  
I'm trying to upgrade from elasticsearch from 7.17.0 to 7.17.9. Node1 is set as master and Node2 is not.

I stopped elasticsearch from 7.17.0 and started 7.17.9 in tha same server.

This are the errors:  
ClusterFormationFailure  
non-master-eligible node found

Logs of liferaydev1 about Master node

[2023-07-07T19:24:44,373][TRACE][o.e.d.HandshakingTransportAddressConnector] [liferaydev1] [connectToRemoteMasterNode[192.168.253.19:9300]] opening probe connection  
[2023-07-07T19:24:44,377][DEBUG][o.e.d.PeerFinder] [liferaydev1] address [192.168.253.19:9300], node [null], requesting [false] connection failed  
org.elasticsearch.transport.ConnectTransportException: [192.168.253.19:9300] connect\_exception

[2023-07-08T19:00:59,129][WARN][o.e.d.PeerFinder] [liferaydev1] address [192.168.253.19:9300], node [null], requesting [false] connection failed: [liferaydev2][192.168.253.19:9300] non-master-eligible node found  
[2023-07-08T19:00:59,428][WARN][o.e.c.c.ClusterFormationFailureHelper] [liferaydev1] master not discovered or elected yet, an election requires one or more nodes that have already participated as master-eligible nodes  
in the cluster but this node was not master-eligible the last time it joined the cluster, have only discovered non-quorum [{liferaydev1}{3DpR5D2oSVaiS3\_ViNr4lw}{4NWhFQBCRRCjrQ3I-7WPQw}{192.168.253.18}{192.168.253.18:9300}{dmr}]; discovery  
will continue using [192.168.253.19:9300] from hosts providers and [{liferaydev1}{3DpR5D2oSVaiS3\_ViNr4lw}{4NWhFQBCRRCjrQ3I-7WPQw}{192.168.253.18}{192.168.253.18:9300}{dmr}] from  
last-known cluster state; node term 5, last-accepted version 770 in term 5

[2023-07-08T09:07:54,564][WARN][o.e.c.c.ClusterFormationFailureHelper] [liferaydev2] master not discovered yet: have discovered  
[{liferaydev2}{3DpR5D2oSVaiS3\_ViNr4lw}{iAl8qK0gTdiYAX9-hiLS1Q}{192.168.253.19}{192.168.253.19:9300}{d}, {liferaydev1}{3DpR5D2oSVaiS3\_ViNr4lw}{JgXAgEsBSXSKY5KgpAGxsg}{192.168.253.18}{192.168.253.18:9300}{dm}]; discovery will continue using [192.168.253.18:9300] from hosts providers and   
from last-known cluster state; node term 5, last-accepted version 770 in term 5

[2023-07-08T18:41:29,394][WARN][o.e.d.PeerFindee] [liferaydev1] address [192.168.253.19:9300], node [null], requesting [false] connection failed: [liferaydev2][192.168.253.19:9300] non-master-eligible node found

As info....in node1 server, I have the cluster name as same in version 7.17.9 and the old 7.17.0

Any help is greatly appreciated.

Thank you.  
SSRR

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [July 9, 2023, 4:29pm UTC](https://discuss.elastic.co/t/elastic-search-7-17-9-clusterformationfailure/337963/2 "2023-07-09T16:29:09Z")

</div>

These logs say that `liferaydev1` was not master-eligible the last time it joined a cluster, and `liferaydev2` is not currently master-eligible. You need a master-eligible node that was previously master-eligible in order to form a cluster.

---

<div class="post-metadata">

**Author:** ![SSRR](https://avatars.discourse-cdn.com/v4/letter/s/d07c76/32.png) [@SSRR](https://discuss.elastic.co/u/SSRR)\
**Post date:** [July 14, 2023, 7:41am UTC](https://discuss.elastic.co/t/elastic-search-7-17-9-clusterformationfailure/337963/3 "2023-07-14T07:41:13Z")

</div>

The node to was failing to join the cluster and not recognized as master node.  
So, I ran the commands for Detaching nodes from their cluster.  
Unsafe-bootstarp of dev1 and "detach-cluster" of dev2 from cluster.

Then added the master node first to the cluster. Once master node is successful, I started the second node which is a non-master node. I did not update anything significantly in dev1 and dev2 other than detaching nodes from cluster.

Thank you so much for your help.  
SSRR

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [July 14, 2023, 7:48am UTC](https://discuss.elastic.co/t/elastic-search-7-17-9-clusterformationfailure/337963/4 "2023-07-14T07:48:12Z")

</div>

The `detach-cluster` command is not safe (risks data loss) and should not be needed unless something else has gone badly wrong in your cluster.

---

<div class="post-metadata">

**Author:** ![SSRR](https://avatars.discourse-cdn.com/v4/letter/s/d07c76/32.png) [@SSRR](https://discuss.elastic.co/u/SSRR)\
**Post date:** [July 14, 2023, 5:28pm UTC](https://discuss.elastic.co/t/elastic-search-7-17-9-clusterformationfailure/337963/5 "2023-07-14T17:28:32Z")

</div>

David,  
I tried several options to have the dev1 server recognized as master in the cluster. For example, I changed the cluster name of Elasticsearch with a new name and master node did not work.  
Since this is a new dev environment, I thought it is okay to detach the cluster.

Thank you.  
SSRR

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [July 14, 2023, 6:29pm UTC](https://discuss.elastic.co/t/elastic-search-7-17-9-clusterformationfailure/337963/6 "2023-07-14T18:29:09Z")

</div>

That's fine, but I don't want the next reader to follow you along this unsafe path without sufficient warning. Something's wrong with your setup if it needs the `detach-cluster` command.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 11, 2023, 6:29pm UTC](https://discuss.elastic.co/t/elastic-search-7-17-9-clusterformationfailure/337963/7 "2023-08-11T18:29:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
