# Elastic Search causing major page memory errors on Azure Kubernetes (AKS)

**URL:** https://discuss.elastic.co/t/elastic-search-causing-major-page-memory-errors-on-azure-kubernetes-aks/351670
**Category:** Elasticsearch
**Created:** [January 23, 2024, 9:28pm UTC](https://discuss.elastic.co/t/elastic-search-causing-major-page-memory-errors-on-azure-kubernetes-aks/351670 "2024-01-23T21:28:01Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![DavidDean](https://avatars.discourse-cdn.com/v4/letter/d/fbc32d/32.png) [@DavidDean](https://discuss.elastic.co/u/DavidDean)
#### Post date: [January 23, 2024, 9:28pm UTC](https://discuss.elastic.co/t/elastic-search-causing-major-page-memory-errors-on-azure-kubernetes-aks/351670/1 "2024-01-23T21:28:01Z")

</div>

ES version: 7.17.5.1  
Hosting: Azure Kubernetes (AKS)  
Kubernetes: 1.24.9  
Virtual machine: D8ads v5 (8 vCPUs, 32 GB RAM)  
Virtual machine OS: Ubuntu 18.04.6 LTS

Prometheus is reporting very high rates of major memory page faults on the virtual machine running Elastic Search.

However there is no SWAP being used, the max\_map\_count is correct (262144) and disk write ahead value seems to be correct at 128.

In terms of resource utilisation, ES is only using a maximum, of 4 vCPU cores of a total available of 8, and the virtual machine is only using 19Gb of a total 32Gb.

The disks are busy but don't seem overloaded:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/f/c/fcfabe3e9eb9632cb39f1fe84055d9d904295e47.png)

...so I cannot understand why there are so many major page faults being reported?

I raised this with Microsoft Support who said this is an application issue and that I should raise it with Elastic Search. So here I am! 🙂

I wasn't sure whether the root cause was the memory mapped storage type used by Elastic Search, which seems to be unique vs other applications?

Would really appreciate some help from the gurus on here!

---

<div class="post-metadata">

### Author: ![DavidDean](https://avatars.discourse-cdn.com/v4/letter/d/fbc32d/32.png) [@DavidDean](https://discuss.elastic.co/u/DavidDean)
#### Post date: [January 23, 2024, 9:29pm UTC](https://discuss.elastic.co/t/elastic-search-causing-major-page-memory-errors-on-azure-kubernetes-aks/351670/2 "2024-01-23T21:29:11Z")

</div>

Worker node resource utilisation:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/a/5/a5996934a1e4c6716bd1e6a0c9765b8d1083a233.png)

---

<div class="post-metadata">

### Author: ![DavidDean](https://avatars.discourse-cdn.com/v4/letter/d/fbc32d/32.png) [@DavidDean](https://discuss.elastic.co/u/DavidDean)
#### Post date: [January 23, 2024, 9:35pm UTC](https://discuss.elastic.co/t/elastic-search-causing-major-page-memory-errors-on-azure-kubernetes-aks/351670/3 "2024-01-23T21:35:18Z")

</div>

We are using PVC disks of type StandardSSD\_LRS - here is the specification:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/7/9/792bc652d5b957e7de07cab451b770b6b813ab92.png)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 20, 2024, 9:35pm UTC](https://discuss.elastic.co/t/elastic-search-causing-major-page-memory-errors-on-azure-kubernetes-aks/351670/4 "2024-02-20T21:35:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
