# Elastic Search Configuration Problem with Kibana.yml

**URL:** <https://discuss.elastic.co/t/elastic-search-configuration-problem-with-kibana-yml/368665>\
**Category:** Kibana\
**Created:** [October 11, 2024, 6:32am UTC](https://discuss.elastic.co/t/elastic-search-configuration-problem-with-kibana-yml/368665 "2024-10-11T06:32:28Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![schwarz\_ravenn](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/schwarz_ravenn/32/138270_2.png) [@schwarz\_ravenn](https://discuss.elastic.co/u/schwarz_ravenn)\
**Post date:** [October 11, 2024, 6:32am UTC](https://discuss.elastic.co/t/elastic-search-configuration-problem-with-kibana-yml/368665/1 "2024-10-11T06:32:28Z")

</div>

So, I'm a newbie in Elasticsearch and Kibana. I've a problem with configuration and connection of Kibana to ES, sadly I couldn't find a solution that would work out for me, so I hope someone could help me out.

Steps I've done:

1. I ran elasticsearch and successfully got token, password and certification;
2. I ran Kibana and got the link to follow to localhost with 5601 port, with verification code;
3. I followed the link, however, when I paste the given token I face with the problem.

Problem is: Generate a new enrollment token or configure manually.

To make everything clear, I have ran with default elasticsearch.yml and kibana.yml with no changes, then I tried to change some of configurations to see if it will work, but nothing helped. I could provide my kibana.yml file if needed.

By the way, when pasting the token, I get this message in terminal of Kibana (I've changed 0 to o so I Could post this):  
[2024-10-11T11:15:31.673+05:00][ERROR][plugins.interactiveSetup.elasticsearch] Unable to connect to host "https://172.16.o.2:92oo", will proceed to the next host if available: Request timed out

When I tried to configure with kibana\_system as login and password I got from ES, it says next: Couldn't configure Elastic. Retry or update the kibana.yml file manually. Also get message in Kibana terminal:  
[2024-10-11T11:15:52.430+05:00][ERROR][plugins.interactiveSetup.elasticsearch] Failed to authenticate with host "https://localhost:92oo": ""

---

<div class="post-metadata">

**Author:** ![Bernt\_Rostad](https://avatars.discourse-cdn.com/v4/letter/b/3ab097/32.png) [@Bernt\_Rostad](https://discuss.elastic.co/u/Bernt_Rostad)\
**Post date:** [October 11, 2024, 8:01am UTC](https://discuss.elastic.co/t/elastic-search-configuration-problem-with-kibana-yml/368665/2 "2024-10-11T08:01:39Z")

</div>

> [@schwarz\_ravenn](#):
>
> "https://localhost:92oo": ""

If this quote is correct you have a typo, using the letter "o" instead of the number 0 (zero). Try with **[https://localhost:9200](https://localhost:9200)**

---

<div class="post-metadata">

**Author:** ![schwarz\_ravenn](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/schwarz_ravenn/32/138270_2.png) [@schwarz\_ravenn](https://discuss.elastic.co/u/schwarz_ravenn)\
**Post date:** [October 11, 2024, 8:15am UTC](https://discuss.elastic.co/t/elastic-search-configuration-problem-with-kibana-yml/368665/3 "2024-10-11T08:15:09Z")

</div>

I've replaced 0 to "o" letter purposely, it didn't allowed me to post with host link

---

<div class="post-metadata">

**Author:** ![Sean\_Story](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sean_story/32/69987_2.png) [@Sean\_Story](https://discuss.elastic.co/u/Sean_Story)\
**Post date:** [October 11, 2024, 1:39pm UTC](https://discuss.elastic.co/t/elastic-search-configuration-problem-with-kibana-yml/368665/4 "2024-10-11T13:39:25Z")

</div>

From #Elasticsearch to #Kibana

---

<div class="post-metadata">

**Author:** ![Sean\_Story](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sean_story/32/69987_2.png) [@Sean\_Story](https://discuss.elastic.co/u/Sean_Story)\
**Post date:** [October 11, 2024, 1:39pm UTC](https://discuss.elastic.co/t/elastic-search-configuration-problem-with-kibana-yml/368665/5 "2024-10-11T13:39:26Z")

</div>

Removed #esre-elasticsearch-relevance-engine
