# Elastic Search - Connection Refused error

**URL:** <https://discuss.elastic.co/t/elastic-search-connection-refused-error/57582>\
**Category:** Elasticsearch\
**Created:** [August 9, 2016, 10:17am UTC](https://discuss.elastic.co/t/elastic-search-connection-refused-error/57582 "2016-08-09T10:17:17Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sanjay\_M](https://avatars.discourse-cdn.com/v4/letter/s/439d5e/32.png) [@Sanjay\_M](https://discuss.elastic.co/u/Sanjay_M)\
**Post date:** [August 9, 2016, 10:17am UTC](https://discuss.elastic.co/t/elastic-search-connection-refused-error/57582/1 "2016-08-09T10:17:17Z")

</div>

I am integrating Elastic search in my project. I used the various packages out of them now I am with one of following - [https://github.com/sleimanx2/plastic](https://github.com/sleimanx2/plastic). While running the instance it gives me error while running the search request as follow.

log.WARNING: Curl exception encountered. [] []  
log.WARNING: Request Failure: {"method":"GET","uri":"[http://127.0.0.1:9200/plastic/books/\_search","headers":{"host":["127.0.0.1:9200"]},"HTTP](http://127.0.0.1:9200/plastic/books/_search%22,%22headers%22:%7B%22host%22:%5B%22127.0.0.1:9200%22%5D%7D,%22HTTP) code":null,"duration":0.202,"error":"cURL error 7: Failed to connect to 127.0.0.1 port 9200: Connection refused"} []  
log.WARNING: Response [null] []  
log.WARNING: Marking node 127.0.0.1:9200 dead. [] []  
log.WARNING: Retries left? true [] []  
log.CRITICAL: No alive nodes found in cluster [] []

Any help would be appreciable. Thanks in advance

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [August 9, 2016, 10:29am UTC](https://discuss.elastic.co/t/elastic-search-connection-refused-error/57582/2 "2016-08-09T10:29:27Z")

</div>

Please format your code using `</>` icon. It will make your post more readable.

Is your elasticsearch node running at 127.0.0.1:9200?

A simple `curl 127.0.0.1:9200` should tell you that.

---

<div class="post-metadata">

**Author:** ![Sanjay\_M](https://avatars.discourse-cdn.com/v4/letter/s/439d5e/32.png) [@Sanjay\_M](https://discuss.elastic.co/u/Sanjay_M)\
**Post date:** [August 9, 2016, 10:57am UTC](https://discuss.elastic.co/t/elastic-search-connection-refused-error/57582/3 "2016-08-09T10:57:20Z")

</div>

Hello , When I run the command as you provided it shows Blank.

---

<div class="post-metadata">

**Author:** ![Sanjay\_M](https://avatars.discourse-cdn.com/v4/letter/s/439d5e/32.png) [@Sanjay\_M](https://discuss.elastic.co/u/Sanjay_M)\
**Post date:** [August 9, 2016, 11:09am UTC](https://discuss.elastic.co/t/elastic-search-connection-refused-error/57582/4 "2016-08-09T11:09:07Z")

</div>

Can you please suggest me a way to get it resolved. I have searched a lot but not able to identify the proper solution for this.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [August 9, 2016, 11:15am UTC](https://discuss.elastic.co/t/elastic-search-connection-refused-error/57582/5 "2016-08-09T11:15:13Z")

</div>

Start Elasticsearch ?

---

<div class="post-metadata">

**Author:** ![Sanjay\_M](https://avatars.discourse-cdn.com/v4/letter/s/439d5e/32.png) [@Sanjay\_M](https://discuss.elastic.co/u/Sanjay_M)\
**Post date:** [August 9, 2016, 11:28am UTC](https://discuss.elastic.co/t/elastic-search-connection-refused-error/57582/6 "2016-08-09T11:28:50Z")

</div>

> [@dadoonet](#):
>
> Elasticsearch

I am using this Elasticsearch with Laravel. I use this package to integrate  
[GitHub - sleimanx2/plastic: Plastic is an Elasticsearch ODM and mapper for Laravel. It renders the developer experience more enjoyable while using Elasticsearch, by providing a fluent syntax for mapping, querying, and storing eloquent models.](https://github.com/sleimanx2/plastic) How could I Start the elasticsearch?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [August 9, 2016, 12:00pm UTC](https://discuss.elastic.co/t/elastic-search-connection-refused-error/57582/7 "2016-08-09T12:00:39Z")

</div>

Download elasticsearch, unzip it and launch it.  
As you would do for a MySQL database.

Read also [https://www.elastic.co/guide/en/elasticsearch/reference/current/setup.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/setup.html)

---

<div class="post-metadata">

**Author:** ![Sanjay\_M](https://avatars.discourse-cdn.com/v4/letter/s/439d5e/32.png) [@Sanjay\_M](https://discuss.elastic.co/u/Sanjay_M)\
**Post date:** [August 10, 2016, 8:54am UTC](https://discuss.elastic.co/t/elastic-search-connection-refused-error/57582/8 "2016-08-10T08:54:13Z")

</div>

Hello, I have installed elasticsearch and started the instance

D:\elasticsearch-2.3.5\bin\>service.bat start  
The service 'elasticsearch-service-x86' has been started

However still there is an issue like as follow

{"error":{"root\_cause":[{"type":"index\_not\_found\_exception","reason":"no such index","resource.type":"index\_or\_alias","[resource.id](http://resource.id)":"plastic","index":"plastic"}],"type":"index\_not\_found\_exception","reason":"no such index","resource.type":"index\_or\_alias","[resource.id](http://resource.id)":"plastic","index":"plastic"},"status":404}

Please let me know if I am missing anything

---

<div class="post-metadata">

**Author:** ![Sanjay\_M](https://avatars.discourse-cdn.com/v4/letter/s/439d5e/32.png) [@Sanjay\_M](https://discuss.elastic.co/u/Sanjay_M)\
**Post date:** [August 10, 2016, 12:51pm UTC](https://discuss.elastic.co/t/elastic-search-connection-refused-error/57582/9 "2016-08-10T12:51:05Z")

</div>

Hello, I have installed elasticsearch and started the instance

D:\elasticsearch-2.3.5\bin\>service.bat start  
The service 'elasticsearch-service-x86' has been started

However still there is an issue like as follow

{"error":{"root\_cause":[{"type":"index\_not\_found\_exception","reason":"no such index","resource.type":"index\_or\_alias","[resource.id](http://resource.id)":"plastic","index":"plastic"}],"type":"index\_not\_found\_exception","reason":"no such index","resource.type":"index\_or\_alias","[resource.id](http://resource.id)":"plastic","index":"plastic"},"status":404}

Please let me know if I am missing anything

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [August 10, 2016, 1:03pm UTC](https://discuss.elastic.co/t/elastic-search-connection-refused-error/57582/10 "2016-08-10T13:03:12Z")

</div>

I don't know "plastic" and I believe your question is related to it here?

You should ask this question to the plastic project, no?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:28pm UTC](https://discuss.elastic.co/t/elastic-search-connection-refused-error/57582/11 "2017-07-05T22:28:48Z")

</div>


