# Elastic Search Does not overwrite data from Hive overwrite insert statement

**URL:** <https://discuss.elastic.co/t/elastic-search-does-not-overwrite-data-from-hive-overwrite-insert-statement/123806>\
**Category:** Elasticsearch\
**Created:** [March 13, 2018, 8:48pm UTC](https://discuss.elastic.co/t/elastic-search-does-not-overwrite-data-from-hive-overwrite-insert-statement/123806 "2018-03-13T20:48:33Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![naresh523](https://avatars.discourse-cdn.com/v4/letter/n/e480ec/32.png) [@naresh523](https://discuss.elastic.co/u/naresh523)\
**Post date:** [March 13, 2018, 8:48pm UTC](https://discuss.elastic.co/t/elastic-search-does-not-overwrite-data-from-hive-overwrite-insert-statement/123806/1 "2018-03-13T20:48:33Z")

</div>

Trying to do insert overwrite es\_table from select \*;  
Does not overwrites the data in es\_tables, instead count on es\_tables doubles;

My data does not have a unique column, so used two column as mapping.id, then while trying to insert data into es\_table, it is throwing following error.

Caused by: org.apache.hadoop.hive.ql.metadata.HiveException: Hive Runtime Error while processing row

Tried following ways:  
'es.mapping.id'='field1(string column), field2(stringcolumn)'

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 10, 2018, 8:56pm UTC](https://discuss.elastic.co/t/elastic-search-does-not-overwrite-data-from-hive-overwrite-insert-statement/123806/2 "2018-04-10T20:56:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
