# Elastic-search maintenance in Azure

**URL:** <https://discuss.elastic.co/t/elastic-search-maintenance-in-azure/168558>\
**Category:** Elasticsearch\
**Created:** [February 15, 2019, 10:01am UTC](https://discuss.elastic.co/t/elastic-search-maintenance-in-azure/168558 "2019-02-15T10:01:35Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ramasami](https://avatars.discourse-cdn.com/v4/letter/r/13edae/32.png) [@Ramasami](https://discuss.elastic.co/u/Ramasami)\
**Post date:** [February 15, 2019, 10:01am UTC](https://discuss.elastic.co/t/elastic-search-maintenance-in-azure/168558/1 "2019-02-15T10:01:36Z")

</div>

Hey!  
I am new to elastic search. I have set up an elastic cluster in azure using “Elastic Stack - Elasticsearch, Kibana and Logstash” resource. I had a few questions related to this approach.

What happens when a node fails?  
What are the reasons for it to fail?  
and how to recover?  
if a node gets automatically replaced by azure on failure, does it have to be set up manually or azure takes care of it automatically?

Any help would be appreciated 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 15, 2019, 10:01am UTC](https://discuss.elastic.co/t/elastic-search-maintenance-in-azure/168558/2 "2019-03-15T10:01:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
