# Elastic search not esponding

**URL:** <https://discuss.elastic.co/t/elastic-search-not-esponding/35772>\
**Category:** Elasticsearch\
**Created:** [November 27, 2015, 3:57pm UTC](https://discuss.elastic.co/t/elastic-search-not-esponding/35772 "2015-11-27T15:57:20Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![bubu.senapati](https://avatars.discourse-cdn.com/v4/letter/b/45deac/32.png) [@bubu.senapati](https://discuss.elastic.co/u/bubu.senapati)\
**Post date:** [November 27, 2015, 3:57pm UTC](https://discuss.elastic.co/t/elastic-search-not-esponding/35772/1 "2015-11-27T15:57:20Z")

</div>

Hi I am getting following error .  
Can somebody suggest the work around

[2015-11-27 15:41:33,426][WARN][indices.cluster] [R4PVAP1030-MON] [[famonitor][4]] marking and sending shard failed due to [failed recovery]  
org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [famonitor][4] failed recovery  
at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:162)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: org.elasticsearch.index.engine.EngineCreationFailureException: [famonitor][4] failed to upgrade 3x segments  
at org.elasticsearch.index.engine.InternalEngine.(InternalEngine.java:121)  
at org.elasticsearch.index.engine.InternalEngineFactory.newReadWriteEngine(InternalEngineFactory.java:24)  
at org.elasticsearch.index.shard.IndexShard.newEngine(IndexShard.java:1256)  
at org.elasticsearch.index.shard.IndexShard.createNewEngine(IndexShard.java:1251)  
at org.elasticsearch.index.shard.IndexShard.prepareForTranslogRecovery(IndexShard.java:782)  
at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:226)  
at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:112)  
... 3 more  
Caused by: java.io.EOFException: read past EOF: NIOFSIndexInput(path="/opt/fvanalytics/elasticsearch-1.5.1/data/fvanalytics/nodes/0/indices/famonitor/4/index/se gments\_1ec")  
at org.apache.lucene.store.BufferedIndexInput.refill(BufferedIndexInput.java:336)  
at org.apache.lucene.store.BufferedIndexInput.readByte(BufferedIndexInput.java:54)  
at org.apache.lucene.store.DataInput.readInt(DataInput.java:98)  
at org.apache.lucene.store.BufferedIndexInput.readInt(BufferedIndexInput.java:183)  
at org.elasticsearch.common.lucene.Lucene.indexNeeds3xUpgrading(Lucene.java:738)  
at org.elasticsearch.common.lucene.Lucene.upgradeLucene3xSegmentsMetadata(Lucene.java:749)  
at org.elasticsearch.index.engine.InternalEngine.upgrade3xSegments(InternalEngine.java:1072)  
at org.elasticsearch.index.engine.InternalEngine.(InternalEngine.java:119)  
... 9 more

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:35pm UTC](https://discuss.elastic.co/t/elastic-search-not-esponding/35772/2 "2017-07-05T23:35:19Z")

</div>


