# Elastic Search on Azure Kubernetes Service - Readiness Probe fails for Kibana

**URL:** <https://discuss.elastic.co/t/elastic-search-on-azure-kubernetes-service-readiness-probe-fails-for-kibana/332558>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Created:** [May 4, 2023, 1:13pm UTC](https://discuss.elastic.co/t/elastic-search-on-azure-kubernetes-service-readiness-probe-fails-for-kibana/332558 "2023-05-04T13:13:10Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![patkoch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/patkoch/32/120644_2.png) [@patkoch](https://discuss.elastic.co/u/patkoch)\
**Post date:** [May 4, 2023, 1:13pm UTC](https://discuss.elastic.co/t/elastic-search-on-azure-kubernetes-service-readiness-probe-fails-for-kibana/332558/1 "2023-05-04T13:13:10Z")

</div>

Hi,  
I'm sorry, this questions occurs several times - but some answers were closed without a solution - and maybe my approach is different.  
I try to deploy Elastic Search on my Azure Kubernetes Cluster and unfortunately, my Kibana deployment does not get into a running state as the readiness probe fails.

I'm following that manual: [Deploy a Kibana instance | Elastic Cloud on Kubernetes [2.8] | Elastic](https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-deploy-kibana.html)

My kibana.yaml can be seen below:

```auto
apiVersion: kibana.k8s.elastic.co/v1
kind: Kibana
metadata:
  name: kibana
spec:
  version: 7.17.9
  count: 1
  elasticsearchRef:
    name: elasticsearch
  config:
      xpack.security.enabled: false

```

After applying that, I had to add to manually edit the YAML of the workload - I added "host" and port to get the desired url, which will be used for the readiness probe.

```auto
readinessProbe:
          failureThreshold: 3
          httpGet:
            host: elasticsearch-es-internal-http
            path: /login
            port: 9200
            scheme: HTTP

```

Afterwards I get following:

 ![es-pic](https://us1.discourse-cdn.com/elastic/original/3X/7/7/77ab3ed95233ae133f76cd59987493a7e92ccd46.png)

When I attach the Kibana Pod, I can access from that the resolved IP of the host (elasticsearch-es-internal-http).

What is wrong with my config...

Thank you a lot in advance!

Patrick

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [May 29, 2023, 6:39pm UTC](https://discuss.elastic.co/t/elastic-search-on-azure-kubernetes-service-readiness-probe-fails-for-kibana/332558/2 "2023-05-29T18:39:35Z")

</div>

Hi @patkoch

Welcome to the community!

I highly recommend looking at this.

> **[GitHub - sunileman/ElasticKonductor: 1Click Automation of Elastic Cloud on...](https://github.com/sunileman/ElasticKonductor)**
>
> 1Click Automation of Elastic Cloud on Kubernetes. Contribute to sunileman/ElasticKonductor development by creating an account on GitHub.

It is written by one of our ECK Experts.. it may help you get running much faster.

Cc @Sunile_Manjee

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 26, 2023, 6:40pm UTC](https://discuss.elastic.co/t/elastic-search-on-azure-kubernetes-service-readiness-probe-fails-for-kibana/332558/3 "2023-06-26T18:40:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
