# Elastic search refuses to start after update

**URL:** <https://discuss.elastic.co/t/elastic-search-refuses-to-start-after-update/373394>\
**Category:** Elasticsearch\
**Created:** [January 20, 2025, 10:08am UTC](https://discuss.elastic.co/t/elastic-search-refuses-to-start-after-update/373394 "2025-01-20T10:08:45Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![masara](https://avatars.discourse-cdn.com/v4/letter/m/5fc32e/32.png) [@masara](https://discuss.elastic.co/u/masara)\
**Post date:** [January 20, 2025, 10:08am UTC](https://discuss.elastic.co/t/elastic-search-refuses-to-start-after-update/373394/1 "2025-01-20T10:08:45Z")

</div>

So downgraded my Elasticsearch to 7.17 for me to achieve the all in one deployment with wazuh which was i have been using all along until someone updated the server and in then update the server. I then regenerated the keystore and even used debian to install another elasticsearch 7.17 using debian. but now Elasticsearch is refusing to start. this is the error am getting from logs

\*_[2025-01-20T09:57:15,961][ERROR][o.e.b.Bootstrap] [node-1] Exception_  
_org.elasticsearch.ElasticsearchException: failed to bind service_

- at org.elasticsearch.node.Node.(Node.java:1089) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.node.Node.(Node.java:309) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:234) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:234) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:434) [elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:169) [elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:160) [elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:77) [elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112) [elasticsearch-cli-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.cli.Command.main(Command.java:77) [elasticsearch-cli-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:125) [elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80) [elasticsearch-7.17.13.jar:7.17.13]\*  
_Caused by: java.io.IOException: failed to test writes in data directory [/var/lib/elasticsearch/nodes/0/indices/4acQvuK3QquuBDtX4aMNlA/0/index] write permission is required_
- at org.elasticsearch.env.NodeEnvironment.tryWriteTempFile(NodeEnvironment.java:1318) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.env.NodeEnvironment.assertCanWrite(NodeEnvironment.java:1295) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:342) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.node.Node.(Node.java:429) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- ... 11 more\*  
_Caused by: java.nio.file.FileSystemException: /var/lib/elasticsearch/nodes/0/indices/4acQvuK3QquuBDtX4aMNlA/0/index/.es\_temp\_file: Not a directory_
- at sun.nio.fs.UnixException.translateToIOException(UnixException.java:100) ~[?:?]\*
- at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:106) ~[?:?]\*
- at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111) ~[?:?]\*
- at sun.nio.fs.UnixFileSystemProvider.implDelete(UnixFileSystemProvider.java:291) ~[?:?]\*
- at sun.nio.fs.AbstractFileSystemProvider.deleteIfExists(AbstractFileSystemProvider.java:109) ~[?:?]\*
- at java.nio.file.Files.deleteIfExists(Files.java:1190) ~[?:?]\*
- at org.elasticsearch.env.NodeEnvironment.tryWriteTempFile(NodeEnvironment.java:1314) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.env.NodeEnvironment.assertCanWrite(NodeEnvironment.java:1295) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:342) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.node.Node.(Node.java:429) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- ... 11 more\*  
_[2025-01-20T09:57:15,967][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [node-1] uncaught exception in thread [main]_  
_org.elasticsearch.bootstrap.StartupException: ElasticsearchException[failed to bind service]; nested: IOException[failed to test writes in data directory [/var/lib/elasticsearch/nodes/0/indices/4acQvuK3QquuBDtX4aMNlA/0/index] write permission is required]; nested: FileSystemException[/var/lib/elasticsearch/nodes/0/indices/4acQvuK3QquuBDtX4aMNlA/0/index/.es\_temp\_file: Not a directory];_
- at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:173) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:160) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:77) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112) ~[elasticsearch-cli-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.cli.Command.main(Command.java:77) ~[elasticsearch-cli-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:125) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80) ~[elasticsearch-7.17.13.jar:7.17.13]\*  
_Caused by: org.elasticsearch.ElasticsearchException: failed to bind service_
- at org.elasticsearch.node.Node.(Node.java:1089) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.node.Node.(Node.java:309) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:234) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:234) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:434) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:169) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- ... 6 more\*  
_Caused by: java.io.IOException: failed to test writes in data directory [/var/lib/elasticsearch/nodes/0/indices/4acQvuK3QquuBDtX4aMNlA/0/index] write permission is required_
- at org.elasticsearch.env.NodeEnvironment.tryWriteTempFile(NodeEnvironment.java:1318) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.env.NodeEnvironment.assertCanWrite(NodeEnvironment.java:1295) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:342) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.node.Node.(Node.java:429) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.node.Node.(Node.java:309) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:234) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:234) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:434) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:169) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- ... 6 more\*  
_Caused by: java.nio.file.FileSystemException: /var/lib/elasticsearch/nodes/0/indices/4acQvuK3QquuBDtX4aMNlA/0/index/.es\_temp\_file: Not a directory_
- at sun.nio.fs.UnixException.translateToIOException(UnixException.java:100) ~[?:?]\*
- at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:106) ~[?:?]\*
- at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111) ~[?:?]\*
- at sun.nio.fs.UnixFileSystemProvider.implDelete(UnixFileSystemProvider.java:291) ~[?:?]\*
- at sun.nio.fs.AbstractFileSystemProvider.deleteIfExists(AbstractFileSystemProvider.java:109) ~[?:?]\*
- at java.nio.file.Files.deleteIfExists(Files.java:1190) ~[?:?]\*
- at org.elasticsearch.env.NodeEnvironment.tryWriteTempFile(NodeEnvironment.java:1314) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.env.NodeEnvironment.assertCanWrite(NodeEnvironment.java:1295) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:342) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.node.Node.(Node.java:429) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.node.Node.(Node.java:309) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:234) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:234) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:434) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:169) ~[elasticsearch-7.17.13.jar:7.17.13]\*
- ... 6 more \*\*

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [January 20, 2025, 10:28am UTC](https://discuss.elastic.co/t/elastic-search-refuses-to-start-after-update/373394/2 "2025-01-20T10:28:43Z")

</div>

> [@masara](#):
>
> So downgraded my Elasticsearch to 7.17

Elasticsearch does not support in place downgrades so you can not go from a higher version to a lower version. If you need to do this you need to spin up a new cluster and restore from a snapshot taken from the old version or possibly reindex from remote into the older version cluster from the new one.
