# Elastic search showing error

**URL:** <https://discuss.elastic.co/t/elastic-search-showing-error/208270>\
**Category:** Elasticsearch\
**Created:** [November 18, 2019, 8:53am UTC](https://discuss.elastic.co/t/elastic-search-showing-error/208270 "2019-11-18T08:53:36Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Aditya\_kumar\_kar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aditya_kumar_kar/32/53365_2.png) [@Aditya\_kumar\_kar](https://discuss.elastic.co/u/Aditya_kumar_kar)\
**Post date:** [November 18, 2019, 8:53am UTC](https://discuss.elastic.co/t/elastic-search-showing-error/208270/1 "2019-11-18T08:53:37Z")

</div>

.NoShardAvailableActionException error showing elastic search.  
{"type": "server", "timestamp": "2019-11-18T04:35:16,649Z", "level": "WARN", "component": "r.suppressed", "cluster.name": "docker-cluster", "node.name": "elasticsearch", "message": "path: /.kibana/\_doc/space%3Adefault, params: {index=.kibana, id=space:default}", "cluster.uuid": "0Oew9QxAT\_SEpyNsmOSKYA", "node.id": "BO2WoJTfQOSBfidN2cdNSw" ,  
"stacktrace": ["org.elasticsearch.action.NoShardAvailableActionException: No shard available for [get [.kibana][\_doc][space:default]: routing [null]]",  
"at org.elasticsearch.action.support.single.shard.TransportSingleShardAction$AsyncSingleAction.perform(TransportSingleShardAction.java:224) [elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.action.support.single.shard.TransportSingleShardAction$AsyncSingleAction.onFailure(TransportSingleShardAction.java:210) [elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.action.support.single.shard.TransportSingleShardAction$AsyncSingleAction.access$1100(TransportSingleShardAction.java:136) [elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.action.support.single.shard.TransportSingleShardAction$AsyncSingleAction$2.handleException(TransportSingleShardAction.java:266) [elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.transport.TransportService$ContextRestoreResponseHandler.handleException(TransportService.java:1120) [elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.transport.TransportService$DirectResponseChannel.processException(TransportService.java:1229) [elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.transport.TransportService$DirectResponseChannel.sendResponse(TransportService.java:1203) [elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.transport.TaskTransportChannel.sendResponse(TaskTransportChannel.java:60) [elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.action.support.ChannelActionListener.onFailure(ChannelActionListener.java:56) [elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.action.ActionRunnable.onFailure(ActionRunnable.java:60) [elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.onFailure(ThreadContext.java:758) [elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:39) [elasticsearch-7.4.1.jar:7.4.1]",  
"at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]",  
"at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]",  
"at java.lang.Thread.run(Thread.java:830) [?:?]",  
"Caused by: org.elasticsearch.transport.RemoteTransportException: [elasticsearch][172.18.0.3:9300][indices:data/read/get[s]]",  
"Caused by: org.elasticsearch.index.shard.IllegalIndexShardStateException: CurrentState[RECOVERING] operations only allowed when shard state is one of [POST\_RECOVERY, STARTED]",  
"at org.elasticsearch.index.shard.IndexShard.readAllowed(IndexShard.java:1713) ~[elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.index.shard.IndexShard.get(IndexShard.java:923) ~[elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.index.get.ShardGetService.innerGet(ShardGetService.java:169) ~[elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.index.get.ShardGetService.get(ShardGetService.java:93) ~[elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.index.get.ShardGetService.get(ShardGetService.java:84) ~[elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.action.get.TransportGetAction.shardOperation(TransportGetAction.java:106) ~[elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.action.get.TransportGetAction.shardOperation(TransportGetAction.java:45) ~[elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.action.support.single.shard.TransportSingleShardAction.lambda$asyncShardOperation$0(TransportSingleShardAction.java:110) ~[elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.action.ActionRunnable$1.doRun(ActionRunnable.java:45) ~[elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:773) ~[elasticsearch-7.4.1.jar:7.4.1]",  
"at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) ~[elasticsearch-7.4.1.jar:7.4.1]",  
"... 3 more"] }

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [November 19, 2019, 7:08am UTC](https://discuss.elastic.co/t/elastic-search-showing-error/208270/2 "2019-11-19T07:08:21Z")

</div>

Just putting a stack trace without any context is not very useful. If you want to improve your chances of getting help, please provide more information about your cluster and how this problem occurred.

---

<div class="post-metadata">

**Author:** ![Aditya\_kumar\_kar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aditya_kumar_kar/32/53365_2.png) [@Aditya\_kumar\_kar](https://discuss.elastic.co/u/Aditya_kumar_kar)\
**Post date:** [November 20, 2019, 8:17am UTC](https://discuss.elastic.co/t/elastic-search-showing-error/208270/3 "2019-11-20T08:17:12Z")

</div>

Thank You so much for response.  
version: '2.2'  
services:  
elasticsearch:  
image: [docker.elastic.co/elasticsearch/elasticsearch:7.4.1](http://docker.elastic.co/elasticsearch/elasticsearch:7.4.1)  
container\_name: elasticsearch  
environment:  
- node.name=elasticsearch  
- discovery.seed\_hosts=elasticsearch2  
- cluster.initial\_master\_nodes=elasticsearch,elasticsearch2  
- cluster.name=docker-cluster  
- bootstrap.memory\_lock=true  
- "ES\_JAVA\_OPTS=-Xms512m -Xmx512m"  
ulimits:  
memlock:  
soft: -1  
hard: -1  
volumes:  
- ./esdata1:/usr/share/elasticsearch/data  
ports:  
- 9200:9200  
networks:  
- esnet  
elasticsearch2:  
image: [docker.elastic.co/elasticsearch/elasticsearch:7.4.1](http://docker.elastic.co/elasticsearch/elasticsearch:7.4.1)  
container\_name: elasticsearch2  
environment:  
- node.name=elasticsearch2  
- discovery.seed\_hosts=elasticsearch  
- cluster.initial\_master\_nodes=elasticsearch,elasticsearch2  
- cluster.name=docker-cluster  
- bootstrap.memory\_lock=true  
- "ES\_JAVA\_OPTS=-Xms512m -Xmx512m"  
ulimits:  
memlock:  
soft: -1  
hard: -1  
volumes:  
-./esdata2:/usr/share/elasticsearch/data  
networks:  
- esnet

```
kibana:
  image: docker.elastic.co/kibana/kibana:7.4.1
  container_name: kibana-01
  environment:
    ELASTICSEARCH_URL: "http://elasticsearch:9200"
  ports:
    - 5601:5601
  depends_on:
      - elasticsearch
  networks:
    - esnet

```

volumes:  
esdata1:  
driver: local  
esdata2:  
driver: local

networks:  
esnet:  
driver: bridge  
I am using this docker compose . i have five index and total 1.1 gb of data and all my index status are green.

---

<div class="post-metadata">

**Author:** ![Aditya\_kumar\_kar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aditya_kumar_kar/32/53365_2.png) [@Aditya\_kumar\_kar](https://discuss.elastic.co/u/Aditya_kumar_kar)\
**Post date:** [November 20, 2019, 8:52am UTC](https://discuss.elastic.co/t/elastic-search-showing-error/208270/4 "2019-11-20T08:52:40Z")

</div>

elastic search server stop responding with this error.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 18, 2019, 8:52am UTC](https://discuss.elastic.co/t/elastic-search-showing-error/208270/5 "2019-12-18T08:52:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
