# Elastic search start service is failing

**URL:** <https://discuss.elastic.co/t/elastic-search-start-service-is-failing/206388>\
**Category:** Elasticsearch\
**Created:** [November 4, 2019, 11:36am UTC](https://discuss.elastic.co/t/elastic-search-start-service-is-failing/206388 "2019-11-04T11:36:37Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Shradha\_Bharti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shradha_bharti/32/45398_2.png) [@Shradha\_Bharti](https://discuss.elastic.co/u/Shradha_Bharti)\
**Post date:** [November 4, 2019, 11:36am UTC](https://discuss.elastic.co/t/elastic-search-start-service-is-failing/206388/1 "2019-11-04T11:36:38Z")

</div>

Hi  
I am trying to install the elastic search 7.3.0 version in my centos server  
when i m checking the status with **systemctl status elasticsearch -l** command  
I am getting the below error  
elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Mon 2019-11-04 11:32:17 UTC; 7s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 30707 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 30707 (code=exited, status=1/FAILURE)

Nov 04 11:32:17 nt-e2e-elk.novalocal elasticsearch[30707]: 2019-11-04 11:32:16,653 main ERROR Unable to locate appender "index\_indexing\_slowlog\_rolling\_old" for logger config "index.indexing.slowlog.index"  
Nov 04 11:32:17 nt-e2e-elk.novalocal elasticsearch[30707]: 2019-11-04 11:32:16,654 main ERROR Unable to locate appender "index\_indexing\_slowlog\_rolling" for logger config "index.indexing.slowlog.index"  
Nov 04 11:32:17 nt-e2e-elk.novalocal elasticsearch[30707]: 2019-11-04 11:32:16,654 main ERROR Unable to locate appender "audit\_rolling" for logger config "org.elasticsearch.xpack.security.audit.logfile.LoggingAuditTrail"  
Nov 04 11:32:17 nt-e2e-elk.novalocal elasticsearch[30707]: 2019-11-04 11:32:16,655 main ERROR Unable to locate appender "index\_search\_slowlog\_rolling\_old" for logger config "index.search.slowlog"  
Nov 04 11:32:17 nt-e2e-elk.novalocal elasticsearch[30707]: 2019-11-04 11:32:16,655 main ERROR Unable to locate appender "index\_search\_slowlog\_rolling" for logger config "index.search.slowlog"  
Nov 04 11:32:17 nt-e2e-elk.novalocal elasticsearch[30707]: 2019-11-04 11:32:16,656 main ERROR Unable to locate appender "deprecation\_rolling\_old" for logger config "org.elasticsearch.deprecation"  
Nov 04 11:32:17 nt-e2e-elk.novalocal elasticsearch[30707]: 2019-11-04 11:32:16,656 main ERROR Unable to locate appender "deprecation\_rolling" for logger config "org.elasticsearch.deprecation"  
Nov 04 11:32:17 nt-e2e-elk.novalocal systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Nov 04 11:32:17 nt-e2e-elk.novalocal systemd[1]: Unit elasticsearch.service entered failed state.  
Nov 04 11:32:17 nt-e2e-elk.novalocal systemd[1]: elasticsearch.service failed.

---

<div class="post-metadata">

**Author:** ![thom](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thom/32/4321_2.png) [@thom](https://discuss.elastic.co/u/thom)\
**Post date:** [November 27, 2019, 12:13am UTC](https://discuss.elastic.co/t/elastic-search-start-service-is-failing/206388/2 "2019-11-27T00:13:02Z")

</div>

hi @Shradha_Bharti - I saw this error on Elasticsearch 7.4.2 on CentOS 7. I realized that the problem was being caused because /etc/elasticsearch/elasticsearch.yml was missing on my system (I had accidentally checked it into RCS without checking it back out again). Upon replacing /etc/elasticsearch/elasticsearch.yml again, "systemctl start elasticsearch.service" worked properly again. Perhaps that will work for you - good luck

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 25, 2019, 12:13am UTC](https://discuss.elastic.co/t/elastic-search-start-service-is-failing/206388/3 "2019-12-25T00:13:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
