# Elastic search working after install but then I again it show this error when I restart my mac

**URL:** <https://discuss.elastic.co/t/elastic-search-working-after-install-but-then-i-again-it-show-this-error-when-i-restart-my-mac/196703>\
**Category:** Elasticsearch\
**Created:** [August 26, 2019, 5:03am UTC](https://discuss.elastic.co/t/elastic-search-working-after-install-but-then-i-again-it-show-this-error-when-i-restart-my-mac/196703 "2019-08-26T05:03:17Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![nijanthan0](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nijanthan0/32/52668_2.png) [@nijanthan0](https://discuss.elastic.co/u/nijanthan0)\
**Post date:** [August 26, 2019, 5:03am UTC](https://discuss.elastic.co/t/elastic-search-working-after-install-but-then-i-again-it-show-this-error-when-i-restart-my-mac/196703/1 "2019-08-26T05:03:17Z")

</div>

````auto
Macintosh:~ rs$ elasticsearch
Java HotSpot(TM) 64-Bit Server VM warning: Cannot open file logs/gc.log due to No such file or directory

[2019-08-26T10:28:04,353][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [unknown] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: failed to obtain node locks, tried [[/usr/local/var/lib/elasticsearch]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-6.8.2.jar:6.8.2]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-6.8.2.jar:6.8.2]
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.8.2.jar:6.8.2]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.8.2.jar:6.8.2]
	at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.8.2.jar:6.8.2]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:116) ~[elasticsearch-6.8.2.jar:6.8.2]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) ~[elasticsearch-6.8.2.jar:6.8.2]
Caused by: java.lang.IllegalStateException: failed to obtain node locks, tried [[/usr/local/var/lib/elasticsearch]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?
	at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:300) ~[elasticsearch-6.8.2.jar:6.8.2]
	at org.elasticsearch.node.Node.<init>(Node.java:296) ~[elasticsearch-6.8.2.jar:6.8.2]
	at org.elasticsearch.node.Node.<init>(Node.java:266) ~[elasticsearch-6.8.2.jar:6.8.2]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:212) ~[elasticsearch-6.8.2.jar:6.8.2]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:212) ~[elasticsearch-6.8.2.jar:6.8.2]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:333) ~[elasticsearch-6.8.2.jar:6.8.2]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-6.8.2.jar:6.8.2]
	... 6 more```
````

---

<div class="post-metadata">

**Author:** ![wangqinghuan](https://avatars.discourse-cdn.com/v4/letter/w/d26b3c/32.png) [@wangqinghuan](https://discuss.elastic.co/u/wangqinghuan)\
**Post date:** [August 26, 2019, 5:15am UTC](https://discuss.elastic.co/t/elastic-search-working-after-install-but-then-i-again-it-show-this-error-when-i-restart-my-mac/196703/2 "2019-08-26T05:15:45Z")

</div>

> [@nijanthan0](#):
>
> maybe these locations are not writable or multiple nodes were started without increasing

Sounds a Elasticsearch instance is already running. Do you set it to start automatically at boot time? I guess.

---

<div class="post-metadata">

**Author:** ![nijanthan0](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nijanthan0/32/52668_2.png) [@nijanthan0](https://discuss.elastic.co/u/nijanthan0)\
**Post date:** [August 26, 2019, 5:38am UTC](https://discuss.elastic.co/t/elastic-search-working-after-install-but-then-i-again-it-show-this-error-when-i-restart-my-mac/196703/3 "2019-08-26T05:38:08Z")

</div>

How can I stop the automatic start?

---

<div class="post-metadata">

**Author:** ![wangqinghuan](https://avatars.discourse-cdn.com/v4/letter/w/d26b3c/32.png) [@wangqinghuan](https://discuss.elastic.co/u/wangqinghuan)\
**Post date:** [August 26, 2019, 5:46am UTC](https://discuss.elastic.co/t/elastic-search-working-after-install-but-then-i-again-it-show-this-error-when-i-restart-my-mac/196703/4 "2019-08-26T05:46:46Z")

</div>

You can check Elasticsearch is running by several methods:

1. test 9200 port (default Es port) is listening.
2. run ps -ef | grep java to check.

If it is running, you don't have to start a another instance.

---

<div class="post-metadata">

**Author:** ![nijanthan0](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nijanthan0/32/52668_2.png) [@nijanthan0](https://discuss.elastic.co/u/nijanthan0)\
**Post date:** [August 26, 2019, 5:49am UTC](https://discuss.elastic.co/t/elastic-search-working-after-install-but-then-i-again-it-show-this-error-when-i-restart-my-mac/196703/5 "2019-08-26T05:49:15Z")

</div>

But I will check the port whether it works or not. It will not work. So I uninstall and then reinstall it and start the Elasticsearch .

I working in mac. So I give `ps all` command to see whether Elastic search is running in background or not. Sometimes there is no background process and Elasticsearch is also not starting.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 23, 2019, 5:50am UTC](https://discuss.elastic.co/t/elastic-search-working-after-install-but-then-i-again-it-show-this-error-when-i-restart-my-mac/196703/6 "2019-09-23T05:50:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
