# Elastic search working after install but then I again it show this error when I restart

**URL:** <https://discuss.elastic.co/t/elastic-search-working-after-install-but-then-i-again-it-show-this-error-when-i-restart/197031>\
**Category:** Elasticsearch\
**Created:** [August 28, 2019, 5:18am UTC](https://discuss.elastic.co/t/elastic-search-working-after-install-but-then-i-again-it-show-this-error-when-i-restart/197031 "2019-08-28T05:18:00Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![nijanthan0](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nijanthan0/32/52668_2.png) [@nijanthan0](https://discuss.elastic.co/u/nijanthan0)\
**Post date:** [August 28, 2019, 5:18am UTC](https://discuss.elastic.co/t/elastic-search-working-after-install-but-then-i-again-it-show-this-error-when-i-restart/197031/1 "2019-08-28T05:18:00Z")

</div>

```auto
Macintosh:~ developer$ elasticsearch
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Exception in thread "main" 2019-08-28 10:44:46,645 main ERROR No Log4j 2 configuration file found. Using default configuration (logging only errors to the console), or user programmatically provided configurations. Set system property 'log4j2.debug' to show Log4j 2 internal initialization logging. See https://logging.apache.org/log4j/2.x/manual/configuration.html for instructions on how to configure Log4j 2
SettingsException[Failed to load settings from [elasticsearch.yml]]; nested: MarkedYAMLException[while scanning for the next token
found character '\t(TAB)' that cannot start any token. (Do not use \t(TAB) for indentation)
 in 'reader', line 89, column 1:
    	
    ^

 at [Source: sun.nio.ch.ChannelInputStream@ab7395e; line: 37, column: 45]]; nested: ScannerException[while scanning for the next token
found character '\t(TAB)' that cannot start any token. (Do not use \t(TAB) for indentation)
 in 'reader', line 89, column 1:
    	
    ^
];
	at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1097)
	at org.elasticsearch.common.settings.Settings$Builder.loadFromPath(Settings.java:1070)
	at org.elasticsearch.node.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:83)
	at org.elasticsearch.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:95)
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)
	at org.elasticsearch.cli.Command.main(Command.java:90)
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115)
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)
Caused by: com.fasterxml.jackson.dataformat.yaml.snakeyaml.error.MarkedYAMLException: while scanning for the next token
found character '\t(TAB)' that cannot start any token. (Do not use \t(TAB) for indentation)
 in 'reader', line 89, column 1:
    	
    ^

 at [Source: sun.nio.ch.ChannelInputStream@ab7395e; line: 37, column: 45]
	at com.fasterxml.jackson.dataformat.yaml.snakeyaml.error.MarkedYAMLException.from(MarkedYAMLException.java:27)
	at com.fasterxml.jackson.dataformat.yaml.YAMLParser.nextToken(YAMLParser.java:343)
	at org.elasticsearch.common.xcontent.json.JsonXContentParser.nextToken(JsonXContentParser.java:52)
	at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:645)
	at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:620)
	at org.elasticsearch.common.settings.Settings.access$400(Settings.java:82)
	at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1093)
	... 8 more
Caused by: while scanning for the next token
found character '\t(TAB)' that cannot start any token. (Do not use \t(TAB) for indentation)
 in 'reader', line 89, column 1:
    	
    ^

	at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:420)
	at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:226)
	at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:557)
	at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:157)
	at org.yaml.snakeyaml.parser.ParserImpl.getEvent(ParserImpl.java:167)
	at com.fasterxml.jackson.dataformat.yaml.YAMLParser.nextToken(YAMLParser.java:340)
	... 13 more

```

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [August 28, 2019, 9:49am UTC](https://discuss.elastic.co/t/elastic-search-working-after-install-but-then-i-again-it-show-this-error-when-i-restart/197031/3 "2019-08-28T09:49:41Z")

</div>

have you checked line 89 in the elasticsearch configuration file, what is in there? Try to remove the likely tab in that line and replace it with spaces.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 25, 2019, 9:49am UTC](https://discuss.elastic.co/t/elastic-search-working-after-install-but-then-i-again-it-show-this-error-when-i-restart/197031/4 "2019-09-25T09:49:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
