# Elastic Security is missing in kibana \[9.0.2\]

**URL:** <https://discuss.elastic.co/t/elastic-security-is-missing-in-kibana-9-0-2/379228>\
**Category:** Elastic Security\
**Tags:** docker\
**Created:** [June 17, 2025, 6:45am UTC](https://discuss.elastic.co/t/elastic-security-is-missing-in-kibana-9-0-2/379228 "2025-06-17T06:45:25Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Anacleto\_Barzetti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anacleto_barzetti/32/140131_2.png) [@Anacleto\_Barzetti](https://discuss.elastic.co/u/Anacleto_Barzetti)\
**Post date:** [June 17, 2025, 6:45am UTC](https://discuss.elastic.co/t/elastic-security-is-missing-in-kibana-9-0-2/379228/1 "2025-06-17T06:45:25Z")

</div>

![image](https://us1.discourse-cdn.com/elastic/original/3X/d/d/dd22905c42f1e23efa035323c177610b504f3781.png)

Elastic Security is not showing up, I installed via `docker compose`.

kibana.yml

```yml
server.host: "0.0.0.0"
telemetry.enabled: "false"
xpack.fleet.packages:
  - name: fleet_server
    version: latest
  - name: system
    version: latest
  - name: elastic_agent
    version: latest
xpack.fleet.agentPolicies:
  - name: Fleet-Server-Policy
    id: fleet-server-policy
    namespace: default
    monitoring_enabled:
      - logs
      - metrics
    package_policies:
      - name: fleet_server-1
        package:
          name: fleet_server
      - name: system-1
        package:
          name: system
      - name: elastic_agent-1
        package:
          name: elastic_agent

```

docker-compose.yml

```yml
  es01:
    depends_on:
      setup:
        condition: service_healthy
    image: docker.elastic.co/elasticsearch/elasticsearch:${STACK_VERSION}
    labels:
      co.elastic.logs/module: elasticsearch
    volumes:
      - certs:/usr/share/elasticsearch/config/certs
      - esdata01:/usr/share/elasticsearch/data
      - suricata_logs:/var/log/suricata
    ports:
      - ${ES_PORT}:9200
    environment:
      - node.name=es01
      - cluster.name=${CLUSTER_NAME}
      - discovery.type=single-node
      - ELASTIC_PASSWORD=${ELASTIC_PASSWORD}
      - bootstrap.memory_lock=true
      - xpack.security.enabled=true
      - xpack.security.authc.api_key.enabled=true
      - xpack.security.http.ssl.enabled=true
      - xpack.security.http.ssl.key=certs/es01/es01.key
      - xpack.security.http.ssl.certificate=certs/es01/es01.crt
      - xpack.security.http.ssl.certificate_authorities=certs/ca/ca.crt
      - xpack.security.transport.ssl.enabled=true
      - xpack.security.transport.ssl.key=certs/es01/es01.key
      - xpack.security.transport.ssl.certificate=certs/es01/es01.crt
      - xpack.security.transport.ssl.certificate_authorities=certs/ca/ca.crt
      - xpack.security.transport.ssl.verification_mode=certificate
      - xpack.license.self_generated.type=${LICENSE}
    mem_limit: ${ES_MEM_LIMIT}
    ulimits:
      memlock:
        soft: -1
        hard: -1
    healthcheck:
      test:
        [
          "CMD-SHELL",
          "curl -s --cacert config/certs/ca/ca.crt https://localhost:9200 | grep -q 'missing authentication credentials'",
        ]
      interval: 10s
      timeout: 10s
      retries: 120

  kibana:
    depends_on:
      es01:
        condition: service_healthy
    image: docker.elastic.co/kibana/kibana:${STACK_VERSION}
    labels:
      co.elastic.logs/module: kibana
    volumes:
      - certs:/usr/share/kibana/config/certs
      - kibanadata:/usr/share/kibana/data
      - ./kibana.yml:/usr/share/kibana/config/kibana.yml:ro
    ports:
      - ${KIBANA_PORT}:5601
    environment:
      - SERVERNAME=kibana
      - ELASTICSEARCH_HOSTS=https://es01:9200
      - ELASTICSEARCH_USERNAME=kibana_system
      - ELASTICSEARCH_PASSWORD=${KIBANA_PASSWORD}
      - ELASTICSEARCH_SSL_CERTIFICATEAUTHORITIES=config/certs/ca/ca.crt
      - XPACK_SECURITY_ENCRYPTIONKEY=${ENCRYPTION_KEY}
      - XPACK_ENCRYPTEDSAVEDOBJECTS_ENCRYPTIONKEY=${ENCRYPTION_KEY}
      - XPACK_REPORTING_ENCRYPTIONKEY=${ENCRYPTION_KEY}
      - XPACK_REPORTING_KIBANASERVER_HOSTNAME=localhost
      - SERVER_SSL_ENABLED=true
      - SERVER_SSL_CERTIFICATE=config/certs/kibana/kibana.crt
      - SERVER_SSL_KEY=config/certs/kibana/kibana.key
      - SERVER_SSL_CERTIFICATEAUTHORITIES=config/certs/ca/ca.crt
    mem_limit: ${KB_MEM_LIMIT}
    healthcheck:
      test:
        [
          "CMD-SHELL",
          "curl -I -s --cacert config/certs/ca/ca.crt https://localhost:5601 | grep 'location: /login'",
        ]
      interval: 10s
      timeout: 10s
      retries: 120

```

---

<div class="post-metadata">

**Author:** ![Tortoise](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tortoise/32/147587_2.png) [@Tortoise](https://discuss.elastic.co/u/Tortoise)\
**Post date:** [June 17, 2025, 6:52am UTC](https://discuss.elastic.co/t/elastic-security-is-missing-in-kibana-9-0-2/379228/2 "2025-06-17T06:52:58Z")

</div>

Hello @Anacleto_Barzetti

Welcome to the community.

Please go to Stack Management \> Kibana \> Spaces \> Edit Space \> Enable security so that it can be visible

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/4/f/4fd67d81e81c30a027d67b2721b1fca2d55ea766.png)

Thanks!!

---

<div class="post-metadata">

**Author:** ![Anacleto\_Barzetti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anacleto_barzetti/32/140131_2.png) [@Anacleto\_Barzetti](https://discuss.elastic.co/u/Anacleto_Barzetti)\
**Post date:** [June 17, 2025, 7:07am UTC](https://discuss.elastic.co/t/elastic-security-is-missing-in-kibana-9-0-2/379228/3 "2025-06-17T07:07:06Z")

</div>

Hello. First of all, thank you for such a quick response.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/0/f/0f09dd04c133877cf369c807e7d79c11dd074afd.png)

I don't see the **security** feature here. I'm using `9.0.2` version.

Thank you.

---

<div class="post-metadata">

**Author:** ![qasidmubashir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/qasidmubashir/32/144187_2.png) [@qasidmubashir](https://discuss.elastic.co/u/qasidmubashir)\
**Post date:** [July 16, 2025, 7:33am UTC](https://discuss.elastic.co/t/elastic-security-is-missing-in-kibana-9-0-2/379228/4 "2025-07-16T07:33:42Z")

</div>

New to elk ,  
but I guess you need to enable x pack security in Elasticsearch.yml  
that's how i did it on my local machine

---

<div class="post-metadata">

**Author:** ![Florian\_Heigl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/florian_heigl/32/123692_2.png) [@Florian\_Heigl](https://discuss.elastic.co/u/Florian_Heigl)\
**Post date:** [August 13, 2025, 1:18am UTC](https://discuss.elastic.co/t/elastic-security-is-missing-in-kibana-9-0-2/379228/5 "2025-08-13T01:18:16Z")

</div>

did you figure out how to fix that? I just got the same thing, kinda funny though.

and it’s not related to xpack / elasticsearchy.yml, right? I certainly had it enabled.

in my case it already announced itself during the upgrade with kibana not recognizing some fields and thus failing to start. I had to allow it to delete them, but effectively the problem was in whatever caused it to no longer work with elastic security and not my step that allowed it to start.

(would be nice if things wouldn’t always fail so fatally)

if you set ‘security’ as ‘solution view’ you get an near empty UI.

if you go back to the main URI, you get

## **Application Not Found**

No application was found at this URL. Try going back or choosing an app from the menu.

It’s no longer possible to access stack management then. But you can still move backwards via the browser.

once you set the UI to ‘classic’ again, you’ll find that suddenly observability is no longer selected. so there’s some ripple damage kind of problems here.

tl;dr: something lets you lose the application thinggy as a whole.

- xpack.security.enabled in elasticsearch.yml is related but it does happen when it's set in elasticsearch.yml
- kibana.yml: must also have the setting but doesn't like it (`kibana | FATAL Error: [config validation of [xpack.security].enabled]: definition for this key is missing`, no longer needed as per [FATAL Error: [config validation of [xpack.security].enabled]: definition for this key is missing - #2 by TimV](https://discuss.elastic.co/t/fatal-error-config-validation-of-xpack-security-enabled-definition-for-this-key-is-missing/300396/2) )
- happens with clusters used for endpoint security alone, so where you’d have no manually defined elements at all
- reinstall the Elastic Defend integration / assets: no effect
- migrations.discardCorruptObjects: "8.18.5" / migrations.discardUnknownObjects: "8.18.5" help to unbreak kibana but don’t solve issue
- migration issue: possible but should not kill a security solution
- version: not related to 9.x but related to very recent versions
- plugins / integrations: stay in place, seem functional
- feature itself: leaves no forwarding address
- integrations -\> elastic security: might be missing! -\> add elastic security -\> install 3 assets
- still missing in spaces-\>feature visibilty
- independently of that, certainly need to attach to agent policy
- need to re-configure api access too, take a break since that looks like a nightmare
- can't be the whole issue, at least the empty menu and dashboard should exist without data

please check if you also got these errors, or _WHICH_ of them you do

```auto
kibana | [2025-08-13T01:34:38.191+00:00][ERROR][plugins.osquery] Not starting transform osquery_manager.action_responses-default-0.0.1 since it's state is: failed
kibana | [2025-08-13T01:34:38.211+00:00][ERROR][plugins.cloudSecurityPosture] Failed to update index [Name: logs-cloud_security_posture.scores-default]
kibana | [2025-08-13T01:34:38.211+00:00][ERROR][plugins.cloudSecurityPosture] ResponseError: illegal_argument_exception
kibana | [2025-08-13T02:01:07.185+00:00][ERROR][plugins.osquery] Not starting transform osquery_manager.action_responses-default-0.0.1 since it's state is: failed
kibana | [2025-08-13T02:01:07.197+00:00][ERROR][plugins.cloudSecurityPosture] Failed to update index [Name: logs-cloud_security_posture.scores-default]
kibana | [2025-08-13T02:01:07.197+00:00][ERROR][plugins.cloudSecurityPosture] ResponseError: illegal_argument_exception
kibana | [2025-08-13T02:03:09.614+00:00][ERROR][plugins.fleet] [elastic_security] package not installed or found in registry
kibana | [2025-08-13T02:03:09.617+00:00][ERROR][plugins.fleet] [elastic_security] package not installed or found in registry
kibana | [2025-08-13T02:03:10.836+00:00][ERROR][plugins.fleet] [elastic_security] package not installed or found in registry
kibana | [2025-08-13T02:03:12.921+00:00][ERROR][plugins.fleet] [elastic_security] package not installed or found in registry
kibana | [2025-08-13T02:03:13.093+00:00][ERROR][plugins.fleet] Error: Saved object [epm-packages/elastic_security] not found
kibana | [2025-08-13T02:03:17.001+00:00][ERROR][plugins.fleet] [elastic_security] package not installed or found in registry
kibana | [2025-08-13T02:03:25.151+00:00][ERROR][plugins.fleet] [elastic_security] package not installed or found in registry
kibana | [2025-08-13T02:03:41.309+00:00][ERROR][plugins.fleet] [elastic_security] package not installed or found in registry
kibana | [2025-08-13T02:03:58.872+00:00][ERROR][savedobjects-service.importer] Failed to import saved objects. 2 errors: [{"type":"index-pattern","id":"logs-*","meta":{"title":"logs-*"},"error":{"type":"conflict"}},{"type":"index-pattern","id":"metrics-*","meta":{"title":"metrics-*"},"error":{"type":"conflict"}}]

```

-\> gave it another hard look and then wiped it all.

---

<div class="post-metadata">

**Author:** ![MoritzAtManserv](https://avatars.discourse-cdn.com/v4/letter/m/5f9b8f/32.png) [@MoritzAtManserv](https://discuss.elastic.co/u/MoritzAtManserv)\
**Post date:** [April 28, 2026, 2:14pm UTC](https://discuss.elastic.co/t/elastic-security-is-missing-in-kibana-9-0-2/379228/6 "2026-04-28T14:14:37Z")

</div>

It's been a while, but we had the same issue while evaluating a license for our Elastic installation. Same behavior as here; Security was just not available and we just got the "Application Not Found" error message.

Turns out this is caused by using the deprecated(!) setting `telemetry.enabled: "false"` in `kibana.yml`. This was changed to `telemetry.optIn: false` + `telemetry.allowChangingOptInStatus: false` and some validation errors caused Security (as well as other plugins) to be deactivated when telemetry was disabled in the old way. I am not going to go into further detail — there is a GitHub PR that you can reference if you want more information: [Gracefully handle deprecated telemetry config by eokoneyo · Pull Request #266029 · elastic/kibana](https://github.com/elastic/kibana/pull/266029)

So in short: Should be fixed soon. Best fix is to update the telemetry option in `kibana.yml`.
