# Elastic Tutorial for ELK

**URL:** https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501
**Category:** Elasticsearch
**Created:** [October 7, 2016, 2:59pm UTC](https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501 "2016-10-07T14:59:42Z")
**Posts on this page:** 12
**Page:** 1

<div class="post-metadata">

### Author: ![syswombat](https://avatars.discourse-cdn.com/v4/letter/s/ecae2f/32.png) [@syswombat](https://discuss.elastic.co/u/syswombat)
#### Post date: [October 7, 2016, 2:59pm UTC](https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501/1 "2016-10-07T14:59:42Z")

</div>

Hello  
i have found a lots of Tutorial in the net to Install ELK. Some don't work other have old release.  
Is there a Elastic Tutorial place for installing ELK and working together?  
have a nice day  
vinc

---

<div class="post-metadata">

### Author: ![abeyad](https://avatars.discourse-cdn.com/v4/letter/a/278dde/32.png) [@abeyad](https://discuss.elastic.co/u/abeyad)
#### Post date: [October 7, 2016, 7:25pm UTC](https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501/2 "2016-10-07T19:25:01Z")

</div>

You will find plenty of information here: [https://www.elastic.co/guide/index.html](https://www.elastic.co/guide/index.html)

---

<div class="post-metadata">

### Author: ![syswombat](https://avatars.discourse-cdn.com/v4/letter/s/ecae2f/32.png) [@syswombat](https://discuss.elastic.co/u/syswombat)
#### Post date: [October 7, 2016, 9:12pm UTC](https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501/3 "2016-10-07T21:12:54Z")

</div>

hello  
i just feel a bit stupid to download the file  
wget [https://download.elastic.co/elasticsearch/release/org/elasticsearch/distribution/deb/elasticsearch/2.4.1/elasticsearch-2.4.1.deb](https://download.elastic.co/elasticsearch/release/org/elasticsearch/distribution/deb/elasticsearch/2.4.1/elasticsearch-2.4.1.deb)  
converted '[https://download.elastic.co/elasticsearch/release/org/elasticsearch/distribution/deb/elasticsearch/2.4.1/elasticsearch-2.4.1.deb](https://download.elastic.co/elasticsearch/release/org/elasticsearch/distribution/deb/elasticsearch/2.4.1/elasticsearch-2.4.1.deb)' (ANSI\_X3.4-1968) -\> '[https://download.elastic.co/elasticsearch/release/org/elasticsearch/distribution/deb/elasticsearch/2.4.1/elasticsearch-2.4.1.deb](https://download.elastic.co/elasticsearch/release/org/elasticsearch/distribution/deb/elasticsearch/2.4.1/elasticsearch-2.4.1.deb)' (UTF-8)  
--2016-10-07 23:02:04-- [https://download.elastic.co/elasticsearch/release/org/elasticsearch/distribution/deb/elasticsearch/2.4.1/elasticsearch-2.4.1.deb](https://download.elastic.co/elasticsearch/release/org/elasticsearch/distribution/deb/elasticsearch/2.4.1/elasticsearch-2.4.1.deb)  
Resolving [download.elastic.co](http://download.elastic.co) ([download.elastic.co](http://download.elastic.co))... 2406:da00:ff00::6b16:e25d, 2406:da00:ff00::6b16:f4cb, 2406:da00:ff00::6b16:f078, ...  
Connecting to [download.elastic.co](http://download.elastic.co) ([download.elastic.co](http://download.elastic.co))|2406:da00:ff00::6b16:e25d|:443... connected.  
ERROR: The certificate of '[download.elastic.co](http://download.elastic.co)' is not trusted.  
ERROR: The certificate of '[download.elastic.co](http://download.elastic.co)' hasn't got a known issuer.

---

<div class="post-metadata">

### Author: ![syswombat](https://avatars.discourse-cdn.com/v4/letter/s/ecae2f/32.png) [@syswombat](https://discuss.elastic.co/u/syswombat)
#### Post date: [October 8, 2016, 8:30pm UTC](https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501/4 "2016-10-08T20:30:38Z")

</div>

hello  
i found this two offizial turial  
[https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-repositories.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-repositories.html)  
[https://www.elastic.co/guide/en/elasticsearch/reference/2.4/\_installation.html](https://www.elastic.co/guide/en/elasticsearch/reference/2.4/_installation.html)

this with wget i described below the error

## if i do the installation with the curl comand i got also a error but later :/elasticsearch-2.4.1/bin# ./elasticsearch Exception in thread "main" java.lang.RuntimeException: don't run elasticsearch as root. at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:94) at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:160) at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:286) at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35) Refer to the log for complete error details.

my java Version should be alright

# java -version

java version "1.8.0\_101"  
Java(TM) SE Runtime Environment (build 1.8.0\_101-b13)  
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

---

<div class="post-metadata">

### Author: ![syswombat](https://avatars.discourse-cdn.com/v4/letter/s/ecae2f/32.png) [@syswombat](https://discuss.elastic.co/u/syswombat)
#### Post date: [October 10, 2016, 11:57am UTC](https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501/5 "2016-10-10T11:57:27Z")

</div>

i am the only own having problem with this? what i am doing wrong ;-(

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [October 10, 2016, 12:07pm UTC](https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501/6 "2016-10-10T12:07:33Z")

</div>

> [@syswombat](#):
>
> Exception in thread "main" java.lang.RuntimeException: **don't run elasticsearch as root.**

I think the error message is quite clear - you need to run Elasticsearch as a non-root user. You should not run Elasticsearch as root, and it checks this on startup and refuses to start.

---

<div class="post-metadata">

### Author: ![syswombat](https://avatars.discourse-cdn.com/v4/letter/s/ecae2f/32.png) [@syswombat](https://discuss.elastic.co/u/syswombat)
#### Post date: [October 10, 2016, 1:39pm UTC](https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501/7 "2016-10-10T13:39:27Z")

</div>

sorry i missed that, im not used user root is not enough so i will have do find out how to do a sudo su ...

---

<div class="post-metadata">

### Author: ![syswombat](https://avatars.discourse-cdn.com/v4/letter/s/ecae2f/32.png) [@syswombat](https://discuss.elastic.co/u/syswombat)
#### Post date: [October 10, 2016, 3:27pm UTC](https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501/8 "2016-10-10T15:27:05Z")

</div>

Hello Again  
i have done a Sudo add a new user i have all Installed and downloadet like this  
[https://www.elastic.co/guide/en/elasticsearch/reference/2.4/\_installation.html](https://www.elastic.co/guide/en/elasticsearch/reference/2.4/_installation.html)

at the end i should do a ./elasticsearch

elkuser@elk-01:~/elasticsearch-2.4.1/bin$ **sudo ./elasticsearch**  
Exception in thread "main" java.lang.RuntimeException: don't run elasticsearch as root.  
at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:94)  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:160)  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:286)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)  
Refer to the log for complete error details.

* * *

without sudo i got a 3 page error like  
elkuser@elk-01:~/elasticsearch-2.4.1/bin$ **./elasticsearch**  
log4j:ERROR setFile(null,true) call failed.  
java.io.FileNotFoundException: /home/elkuser/elasticsearch-2.4.1/logs/elasticsearch.log (Permission denied)  
at java.io.FileOutputStream.open0(Native Method)  
at java.io.FileOutputStream.open(FileOutputStream.java:270)  
at java.io.FileOutputStream.(FileOutputStream.java:213)  
at java.io.FileOutputStream.(FileOutputStream.java:133)  
at org.apache.log4j.FileAppender.setFile(FileAppender.java:294)  
at org.apache.log4j.FileAppender.activateOptions(FileAppender.java:165)  
at org.apache.log4j.DailyRollingFileAppender.activateOptions(DailyRollingFileAppender.java:223)  
at org.apache.log4j.config.PropertySetter.activate(PropertySetter.java:307)  
at org.apache.log4j.config.PropertySetter.setProperties(PropertySetter.java:172)  
at org.apache.log4j.config.PropertySetter.setProperties(PropertySetter.java:104)  
at org.apache.log4j.PropertyConfigurator.parseAppender(PropertyConfigurator.java:842)  
at org.apache.log4j.PropertyConfigurator.parseCategory(PropertyConfigurator.java:768)  
at org.apache.log4j.PropertyConfigurator.configureRootCategory(PropertyConfigurator.java:648)  
at org.apache.log4j.PropertyConfigurator.doConfigure(PropertyConfigurator.java:514)  
at org.apache.log4j.PropertyConfigurator.configure(PropertyConfigurator.java:440)  
at org.elasticsearch.common.logging.log4j.LogConfigurator.configure(LogConfigurator.java:128)  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:259)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)  
log4j:ERROR Either File or DatePattern options are not set for appender [file].  
log4j:ERROR setFile(null,true) call failed.  
java.io.FileNotFoundException: /home/elkuser/elasticsearch-2.4.1/logs/elasticsearch\_deprecation.log (Permission denied)  
at java.io.FileOutputStream.open0(Native Method)  
at java.io.FileOutputStream.open(FileOutputStream.java:270)  
at java.io.FileOutputStream.(FileOutputStream.java:213)  
at java.io.FileOutputStream.(FileOutputStream.java:133)  
at org.apache.log4j.FileAppender.setFile(FileAppender.java:294)  
at org.apache.log4j.FileAppender.activateOptions(FileAppender.java:165)  
at org.apache.log4j.DailyRollingFileAppender.activateOptions(DailyRollingFileAppender.java:223)  
at org.apache.log4j.config.PropertySetter.activate(PropertySetter.java:307)  
at org.apache.log4j.config.PropertySetter.setProperties(PropertySetter.java:172)  
at org.apache.log4j.config.PropertySetter.setProperties(PropertySetter.java:104)  
at org.apache.log4j.PropertyConfigurat

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [October 13, 2016, 5:18am UTC](https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501/9 "2016-10-13T05:18:52Z")

</div>

Don't use sudo, as that will start it as root. In the second attempt it seems there are some files and directory paths that the user you are starting Elasticsearch as do not have permissions to.

---

<div class="post-metadata">

### Author: ![syswombat](https://avatars.discourse-cdn.com/v4/letter/s/ecae2f/32.png) [@syswombat](https://discuss.elastic.co/u/syswombat)
#### Post date: [October 14, 2016, 9:57pm UTC](https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501/10 "2016-10-14T21:57:01Z")

</div>

it seems i am to stupid to follow the guide to install it, or they are steps missing.  
Some of the Installation needs root access to install, others don't ...  
i have got a empty VM with a minimal Debian 8 on it...

---

<div class="post-metadata">

### Author: ![syswombat](https://avatars.discourse-cdn.com/v4/letter/s/ecae2f/32.png) [@syswombat](https://discuss.elastic.co/u/syswombat)
#### Post date: [November 6, 2016, 3:39pm UTC](https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501/11 "2016-11-06T15:39:35Z")

</div>

if i should not start elasticsearch as root so i will have to add it. Do i also have to do a spezial group, too?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:06pm UTC](https://discuss.elastic.co/t/elastic-tutorial-for-elk/62501/12 "2017-07-05T22:06:19Z")

</div>


