# Elastic user not authenticate properly (Kibana Login)

**URL:** <https://discuss.elastic.co/t/elastic-user-not-authenticate-properly-kibana-login/282301>\
**Category:** Kibana\
**Tags:** elastic-stack-security\
**Created:** [August 24, 2021, 6:28am UTC](https://discuss.elastic.co/t/elastic-user-not-authenticate-properly-kibana-login/282301 "2021-08-24T06:28:08Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![yasith1994](https://avatars.discourse-cdn.com/v4/letter/y/e495f1/32.png) [@yasith1994](https://discuss.elastic.co/u/yasith1994)\
**Post date:** [August 24, 2021, 6:28am UTC](https://discuss.elastic.co/t/elastic-user-not-authenticate-properly-kibana-login/282301/1 "2021-08-24T06:28:08Z")

</div>

Hi,

We have elastic cluster with 7 nodes.

Because of some misconfiguration right now we can not log in to the kibana GUI. It shows username or password wrong.

Then we did below steps,

1. Try to create new super user  
/usr/share/elasticsearch/bin/elasticsearch-users useradd newadmin -p kamisama123 -r  
superuser
2. Use the local administrator account to change the password of the account named Elastic.  
curl -s --user newadmin:kamisama123 -XPUT "[http://localhost:9200/\_xpack/security/user/elastic/\_password?pretty](http://localhost:9200/_xpack/security/user/elastic/_password?pretty)" -H 'Content-Type: application/json' -d'  
{  
"password" : "kamisama123"  
}  
'

But it not change the password of elastic user. And show the below out put as error.

"error" : {  
"root\_cause" : [  
{  
"type" : "unavailable\_shards\_exception",  
"reason" : "[.security-7][0] [1] shardIt, [0] active : Timeout waiting for [1m], request: indices:data/write/update"

We run this commands from master nodes and elastic log we can see as below,

Authentication of [kibana] was terminated by realm [reserved] - failed to authenticate user [kibana]

Please help to resolve this issue.

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [August 24, 2021, 6:58am UTC](https://discuss.elastic.co/t/elastic-user-not-authenticate-properly-kibana-login/282301/2 "2021-08-24T06:58:53Z")

</div>

> [@yasith1994](#):
>
> "error" : {  
> "root\_cause" : [  
> {  
> "type" : "unavailable\_shards\_exception",  
> "reason" : "[.security-7][0] [1] shardIt, [0] active : Timeout waiting for [1m], request: indices:data/write/update"

Your cluster is missing data.  
You will need to work out what has happened, and whether you can fix it, or if you need to restore from a snapshot (assuming you have a snapshot).

The possible causes are too diverse for us to try and guess - you will need to look at the Elasticsearch logs, and check APIs such as

- [Cluster health API | Elasticsearch Guide [7.14] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/7.14/cluster-health.html)
- [Cluster allocation explain API | Elasticsearch Guide [7.14] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/7.14/cluster-allocation-explain.html)

---

<div class="post-metadata">

**Author:** ![yasith1994](https://avatars.discourse-cdn.com/v4/letter/y/e495f1/32.png) [@yasith1994](https://discuss.elastic.co/u/yasith1994)\
**Post date:** [September 13, 2021, 3:50am UTC](https://discuss.elastic.co/t/elastic-user-not-authenticate-properly-kibana-login/282301/3 "2021-09-13T03:50:42Z")

</div>

Thanks @Timv for the reply

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 11, 2021, 3:50am UTC](https://discuss.elastic.co/t/elastic-user-not-authenticate-properly-kibana-login/282301/4 "2021-10-11T03:50:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
