# Elastic xpack security

**URL:** <https://discuss.elastic.co/t/elastic-xpack-security/108885>\
**Category:** Elasticsearch\
**Created:** [November 23, 2017, 12:33pm UTC](https://discuss.elastic.co/t/elastic-xpack-security/108885 "2017-11-23T12:33:06Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Raj\_Kumar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/raj_kumar/32/25420_2.png) [@Raj\_Kumar](https://discuss.elastic.co/u/Raj_Kumar)\
**Post date:** [November 23, 2017, 12:33pm UTC](https://discuss.elastic.co/t/elastic-xpack-security/108885/1 "2017-11-23T12:33:06Z")

</div>

Hi All,

Am trying to enable the xpack security in my elastic stack machine, but iam unable to do so  
initially i tried to generate the auto password  
using **bin/x-pack/setup-passwords auto**  
i received some default passwords and when i tried to curl

like curl [http://localhost:9200](http://localhost:9200) -u elastic and then I entered the password  
and it was giving me security exception error even though I tried the generated password.

Later I tried to use interactive

bin/x-pack/setup-passwords interactive

Failed to authenticate user 'elastic' against [http://127.0.0.1:9200/\_xpack/security/\_authenticate?pretty](http://127.0.0.1:9200/_xpack/security/_authenticate?pretty)  
Possible causes include:

- The password for the 'elastic' user has already been changed on this cluster
- Your elasticsearch node is running against a different keystore  
This tool used the keystore at /etc/elasticsearch/elasticsearch.keystore

ERROR: Failed to verify bootstrap password

I dont know how to proceed further please do help me

Thanks in advance ,  
Raj

---

<div class="post-metadata">

**Author:** ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)\
**Post date:** [November 24, 2017, 12:44pm UTC](https://discuss.elastic.co/t/elastic-xpack-security/108885/2 "2017-11-24T12:44:46Z")

</div>

Hi Raj,

[setup-passwords](https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-passwords.html) uses the [bootstrap password](https://www.elastic.co/guide/en/x-pack/6.0/setting-up-authentication.html#bootstrap-elastic-passwords) in order to set the password for the users. After you set a password for the elastic user, the bootstrap password is no longer active and this is why you get the second error

> ERROR: Failed to verify bootstrap password.

Were you able to login with either `kibana` or `logstash_system` users and their auto-generated passwords ?

Now, if you don't remember the original password for elastic that `setup-passwords` created, or if you in any case need to reset it to something new, you can follow the instructions that @TimV has shared in [this answer](https://discuss.elastic.co/t/i-lost-the-password-that-has-been-changed/91867/2)

---

<div class="post-metadata">

**Author:** ![Raj\_Kumar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/raj_kumar/32/25420_2.png) [@Raj\_Kumar](https://discuss.elastic.co/u/Raj_Kumar)\
**Post date:** [November 26, 2017, 5:24pm UTC](https://discuss.elastic.co/t/elastic-xpack-security/108885/3 "2017-11-26T17:24:49Z")

</div>

Thank you so much for the reply

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 24, 2017, 5:25pm UTC](https://discuss.elastic.co/t/elastic-xpack-security/108885/4 "2017-12-24T17:25:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
