# Elasticsearch 1.7 unable to create Azure Repository for snapshot

**URL:** <https://discuss.elastic.co/t/elasticsearch-1-7-unable-to-create-azure-repository-for-snapshot/91812>\
**Category:** Elasticsearch\
**Created:** [July 4, 2017, 7:50pm UTC](https://discuss.elastic.co/t/elasticsearch-1-7-unable-to-create-azure-repository-for-snapshot/91812 "2017-07-04T19:50:23Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Carl\_Tierney](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carl_tierney/32/19765_2.png) [@Carl\_Tierney](https://discuss.elastic.co/u/Carl_Tierney)\
**Post date:** [July 4, 2017, 7:50pm UTC](https://discuss.elastic.co/t/elasticsearch-1-7-unable-to-create-azure-repository-for-snapshot/91812/1 "2017-07-04T19:50:23Z")

</div>

I am unable to snapshot to azure with the plugin installed.

Here is what I did to install

1. plugin -install elasticsearch/elasticsearch-cloud-azure/2.0.0
2. stopped the elastic search service
3. modified the elasticsearch.yml file to include the following

cloud:  
azure:  
storage:  
account: armorbackups  
key: XXXXX

1. then verified the plugin was installed (which seemed to be the most likely issue based on previous articles) and verified i have a one node cluster and the plugin is on the node.  
running [http://localhost:9200/\_nodes/plugins](http://localhost:9200/_nodes/plugins) produces

{  
"cluster\_name": "elasticsearch",  
"nodes": {  
"cTRBf4pPSyO7y7m\_q0CIZA": {  
"name": "Taurus",  
"transport\_address": "inet[/10.0.0.237:9300]",  
"host": "REBELBASE6",  
"ip": "10.0.0.237",  
"version": "1.7.4",  
"build": "0d3159b",  
"http\_address": "inet[/10.0.0.237:9200]",  
"plugins": [  
{  
"name": "cloud-azure",  
"version": "2.0.0",  
"description": "Cloud Azure Plugin",  
"jvm": true,  
"site": false  
}  
]  
}  
}  
}

So any idea why I am getting the following error when I attempt the following:

[http://localhost:9200/\_snapshot/rebelbase6\_test](http://localhost:9200/_snapshot/rebelbase6_test)  
-d { "type": "azure"}

{  
"error": "RepositoryException[[rebelbase6\_test] failed to create repository]; nested: NoClassSettingsException[failed to load class with value [azure]; tried [azure, org.elasticsearch.repositories.AzureRepositoryModule, org.elasticsearch.repositories.azure.AzureRepositoryModule, org.elasticsearch.repositories.azure.AzureRepositoryModule]]; nested: ClassNotFoundException[org.elasticsearch.repositories.azure.AzureRepositoryModule]; ",  
"status": 500  
}

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 4, 2017, 8:10pm UTC](https://discuss.elastic.co/t/elasticsearch-1-7-unable-to-create-azure-repository-for-snapshot/91812/2 "2017-07-04T20:10:30Z")

</div>

Install 2.8.3 instead.

But definitely upgrade your cluster

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 1, 2017, 8:10pm UTC](https://discuss.elastic.co/t/elasticsearch-1-7-unable-to-create-azure-repository-for-snapshot/91812/3 "2017-08-01T20:10:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
