# Elasticsearch 2.2.x vs Grafana 2.6.x

**URL:** https://discuss.elastic.co/t/elasticsearch-2-2-x-vs-grafana-2-6-x/44746
**Category:** Elasticsearch
**Created:** [March 17, 2016, 5:43pm UTC](https://discuss.elastic.co/t/elasticsearch-2-2-x-vs-grafana-2-6-x/44746 "2016-03-17T17:43:42Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Marcello\_A](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marcello_a/32/78018_2.png) [@Marcello\_A](https://discuss.elastic.co/u/Marcello_A)
#### Post date: [March 17, 2016, 5:43pm UTC](https://discuss.elastic.co/t/elasticsearch-2-2-x-vs-grafana-2-6-x/44746/1 "2016-03-17T17:43:42Z")

</div>

Hi All,  
we have installed on our staging environment a stack composed by Logstash 2.2.x, Elasticsearch 2.2.x and we tried to add as monitoring dashboard a new version of Grafana 2.6.0 in parallel with Kibana 4.4.3.

The dashboards on Kibana 4.4.3 works fine but on Grafana we noticed some strage behavior. We added the source ad Elasticsearch 2.x and when we tried to require some terms we received an error reported below

`indent preformatted text by 4 spaces`  
[2016-03-16 15:18:35,861][DEBUG][action.search.type]  
[cw-stms-ebe01] [logstash-apache-it-2016.03.16][0],  
node[aZHu4TEORJ6gLY-avVDrVQ], [P], v[2], s[STARTED],  
a[id=ZMvdL6ToQcSJiTQHC4wcjQ]: Failed to execute [org.elasticsearch.action.search.SearchRequest@482439b]

RemoteTransportException[[cw-stms-ebe01][10.175.241.191:9300][indices:data/read/search[phase/query]]];  
nested: QueryPhaseExecutionException[Query Failed [Failed to execute  
main query]]; nested:  
ElasticsearchException[java.lang.IllegalStateException: Field data  
loading is forbidden on response]; nested:  
UncheckedExecutionException[java.lang.IllegalStateException: Field data  
loading is forbidden on response]; nested: IllegalStateException[Field  
data loading is forbidden on response];

Caused by: QueryPhaseExecutionException[Query Failed [Failed to execute  
main query]]; nested:  
ElasticsearchException[java.lang.IllegalStateException: Field data  
loading is forbidden on response]; nested:  
UncheckedExecutionException[java.lang.IllegalStateException: Field data  
loading is forbidden on response]; nested: IllegalStateException[Field  
data loading is forbidden on response];

```
    at org.elasticsearch.search.query.QueryPhase.execute(QueryPhase.java:409)

    at org.elasticsearch.search.query.QueryPhase.execute(QueryPhase.java:113)

    at org.elasticsearch.search.SearchService.loadOrExecuteQueryPhase(SearchService.java:364)

    at org.elasticsearch.search.SearchService.executeQueryPhase(SearchService.java:376)

    at 

```

org.elasticsearch.search.action.SearchServiceTransportAction$SearchQueryTransportHandler.messageReceived(SearchServiceTransportAction.java:368)

```
    at 

```

org.elasticsearch.search.action.SearchServiceTransportAction$SearchQueryTransportHandler.messageReceived(SearchServiceTransportAction.java:365)

```
    at org.elasticsearch.transport.TransportService$4.doRun(TransportService.java:350)

    at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37)

    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

    at java.lang.Thread.run(Thread.java:745)

```

Could someone help us to identify the issue?

Thanks,  
Marcello

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [March 17, 2016, 11:01pm UTC](https://discuss.elastic.co/t/elasticsearch-2-2-x-vs-grafana-2-6-x/44746/2 "2016-03-17T23:01:51Z")

</div>

[Field data loading is forbidden on [FIELDNAME] · Issue #15267 · elastic/elasticsearch · GitHub](https://github.com/elastic/elasticsearch/issues/15267) may be of assistance.

From that issue;

> The problem happens when "fielddata" : { "format" : "disabled" } is set in a field's mapping, which is the default as of Logstash 2.1, due to this [issue](https://github.com/logstash-plugins/logstash-output-elasticsearch/issues/308).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 11:07pm UTC](https://discuss.elastic.co/t/elasticsearch-2-2-x-vs-grafana-2-6-x/44746/3 "2017-07-05T23:07:24Z")

</div>


