# Elasticsearch 2.3.4 connection refused

**URL:** <https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073>\
**Category:** Elasticsearch\
**Created:** [July 21, 2016, 8:24am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073 "2016-07-21T08:24:08Z")\
**Posts on this page:** 18\
**Page:** 1

<div class="post-metadata">

**Author:** ![sunilmchaudhari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sunilmchaudhari/32/9475_2.png) [@sunilmchaudhari](https://discuss.elastic.co/u/sunilmchaudhari)\
**Post date:** [July 21, 2016, 8:24am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/1 "2016-07-21T08:24:08Z")

</div>

Hi,  
I have upgraded ES 1.5 to 2.3.4

After that I am getting connection issues from client machine (Indexer in my case).

I haven't changed any Elasticsearch.yml configuration. I checked with IT team, there is no FW or any network issue.  
It happened only when I upgraded ES version.

Please put some focus on it.

thanks  
Sunil

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 21, 2016, 8:35am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/2 "2016-07-21T08:35:31Z")

</div>

`network.host` I guess.

Read the breaking changes if you did not yet.  
This section might help: [https://www.elastic.co/guide/en/elasticsearch/reference/current/breaking\_20\_network\_changes.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/breaking_20_network_changes.html)

---

<div class="post-metadata">

**Author:** ![sunilmchaudhari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sunilmchaudhari/32/9475_2.png) [@sunilmchaudhari](https://discuss.elastic.co/u/sunilmchaudhari)\
**Post date:** [July 21, 2016, 9:20am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/3 "2016-07-21T09:20:42Z")

</div>

Hi,  
Does that mean...

I have which accesses :9200. So I have to put netowrk setting below  
network.host:

is that correct?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 21, 2016, 9:25am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/4 "2016-07-21T09:25:17Z")

</div>

Yes.

---

<div class="post-metadata">

**Author:** ![sunilmchaudhari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sunilmchaudhari/32/9475_2.png) [@sunilmchaudhari](https://discuss.elastic.co/u/sunilmchaudhari)\
**Post date:** [July 21, 2016, 9:27am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/5 "2016-07-21T09:27:16Z")

</div>

> [@warkolm](#):
>
> Yes

Thanks and sorry to bother you again.

How can I set master and data node. I found there are no default setting in ES 2.3.4 as in previous version?

---

<div class="post-metadata">

**Author:** ![sunilmchaudhari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sunilmchaudhari/32/9475_2.png) [@sunilmchaudhari](https://discuss.elastic.co/u/sunilmchaudhari)\
**Post date:** [July 21, 2016, 9:33am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/6 "2016-07-21T09:33:34Z")

</div>

Hi,  
I got below exception after setting network host: indexer-host-ip  
Starting elasticsearch: ^[[A^[[AException in thread "main" BindTransportException[Failed to bind to [9300-9400]]; nested: ChannelException[Failed to bind to: / **indexer-host-ip** :9400]; nested: BindException[Cannot assign requested address];  
Likely root cause: java.net.BindException: Cannot assign requested address  
at sun.nio.ch.Net.bind0(Native Method)

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 21, 2016, 9:37am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/7 "2016-07-21T09:37:42Z")

</div>

It's set by default. You don't need to explicitly set them.

---

<div class="post-metadata">

**Author:** ![sunilmchaudhari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sunilmchaudhari/32/9475_2.png) [@sunilmchaudhari](https://discuss.elastic.co/u/sunilmchaudhari)\
**Post date:** [July 21, 2016, 9:44am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/8 "2016-07-21T09:44:52Z")

</div>

Hi,  
When I set network.host: _non\_loopback_ it works. I can access it too form indexer.  
But when I set it to some IP address of indexer, then it shows above exception.

??

br,  
Sunil

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 21, 2016, 10:01am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/9 "2016-07-21T10:01:05Z")

</div>

The doc says: [Network Settings | Elasticsearch Guide [2.3] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/2.3/modules-network.html#common-network-settings)

> The node will bind to this hostname or IP address and publish (advertise) this host to other nodes in the cluster. Accepts an IP address, hostname, a special value, or an array of any combination of these.

So here you have to set the IP of the machine elasticsearch is running on.

---

<div class="post-metadata">

**Author:** ![sunilmchaudhari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sunilmchaudhari/32/9475_2.png) [@sunilmchaudhari](https://discuss.elastic.co/u/sunilmchaudhari)\
**Post date:** [July 21, 2016, 10:04am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/10 "2016-07-21T10:04:41Z")

</div>

OK.  
But my problem is, If I dont sent this value and keep this at it is, I am not able to access ES from other machine which was possible in previous version.

That means curl [http://ES-host:9200](http://ES-host:9200) is not possible from indexer-host, which is the host where logstash is running.

it works only when I set network.host: nonloopback\_

How to allow ES to be acessed form other host? is it only loopback setting?

br,  
Sunil

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 21, 2016, 10:36am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/11 "2016-07-21T10:36:27Z")

</div>

Yes. You have to define something like:

```auto
network.host: x.x.x.x

```

Where x.x.x.x is the IP address of the machine where elasticsearch runs.  
Which is the same as `_nonloopback_` if you have only one network card.

What is wrong with that?

---

<div class="post-metadata">

**Author:** ![sunilmchaudhari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sunilmchaudhari/32/9475_2.png) [@sunilmchaudhari](https://discuss.elastic.co/u/sunilmchaudhari)\
**Post date:** [July 21, 2016, 10:39am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/12 "2016-07-21T10:39:32Z")

</div>

Hi,  
I don't know what is wrong with that? I want to know whether its the only way to make it accessible from other clients or any other way?

I am just afraid if that ES instance will be accessible from any other machine in that case.

br,  
Sunil

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 21, 2016, 10:46am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/13 "2016-07-21T10:46:17Z")

</div>

> [@sunilmchaudhari](#):
>
> I am just afraid if that ES instance will be accessible from any other machine in that case.

That was the case with 1.5 with default settings.  
The difference is that now you are aware of it because you explicitly set it.

For sure, it's a bad idea to open that on internet without any security layer.  
Where is your cluster running? In cloud?  
What are the other machines which can have an access to it? Machines running in the same network?

---

<div class="post-metadata">

**Author:** ![sunilmchaudhari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sunilmchaudhari/32/9475_2.png) [@sunilmchaudhari](https://discuss.elastic.co/u/sunilmchaudhari)\
**Post date:** [July 21, 2016, 10:54am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/14 "2016-07-21T10:54:17Z")

</div>

Hi,

> [@dadoonet](#):
>
> Where is your cluster running? In cloud?

My cluster is running in our environment, not in cloud.[quote="dadoonet, post:13, topic:56073"]  
What are the other machines which can have an access to it? Machines running in the same network?  
[/quote]

Those are machine in same network.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 21, 2016, 11:34am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/15 "2016-07-21T11:34:50Z")

</div>

So that should not be an issue if your elasticsearch instance is in the backend layer. No one but the other services can access it.

If you want to add a security layer, you could look at Shield (X-Pack/Security in 5.0) and add ip filtering if you wish.

---

<div class="post-metadata">

**Author:** ![sunilmchaudhari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sunilmchaudhari/32/9475_2.png) [@sunilmchaudhari](https://discuss.elastic.co/u/sunilmchaudhari)\
**Post date:** [July 21, 2016, 11:36am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/16 "2016-07-21T11:36:35Z")

</div>

OK. Thanks for this. We are already in discussion with sales team for Shield 🙂

One more issue from elastic-hq. I am not able to connect to cluster from HQ after I put the URL of ES-Host:9200 in the input field ?

---

<div class="post-metadata">

**Author:** ![sunilmchaudhari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sunilmchaudhari/32/9475_2.png) [@sunilmchaudhari](https://discuss.elastic.co/u/sunilmchaudhari)\
**Post date:** [July 21, 2016, 11:47am UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/17 "2016-07-21T11:47:46Z")

</div>

OK, I got it.

java version where ES-HQ us running is not compatible with the one where ES is running.  
Need to bring both in synch. 🙂

thanks  
Sunil

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:33pm UTC](https://discuss.elastic.co/t/elasticsearch-2-3-4-connection-refused/56073/18 "2017-07-05T22:33:43Z")

</div>


