# ElasticSearch 2.4.1 to 5.0.2 upgrade fails

**URL:** https://discuss.elastic.co/t/elasticsearch-2-4-1-to-5-0-2-upgrade-fails/67636
**Category:** Elasticsearch
**Created:** [November 30, 2016, 3:05pm UTC](https://discuss.elastic.co/t/elasticsearch-2-4-1-to-5-0-2-upgrade-fails/67636 "2016-11-30T15:05:30Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Der-3](https://avatars.discourse-cdn.com/v4/letter/d/8c91f0/32.png) [@Der-3](https://discuss.elastic.co/u/Der-3)
#### Post date: [November 30, 2016, 3:05pm UTC](https://discuss.elastic.co/t/elasticsearch-2-4-1-to-5-0-2-upgrade-fails/67636/1 "2016-11-30T15:05:30Z")

</div>

Hello all  
I am trying to upgrade my ES install.  
I stopped all the nodes in the cluster, upgraded one and tries to start it.  
However, it fails with a lot of those errors :

[2016-11-30T15:28:36,932][INFO][o.e.n.Node] [es-node-iam-rec-002-1] initializing ...  
[2016-11-30T15:28:37,024][INFO][o.e.e.NodeEnvironment] [es-node-iam-rec-002-1] using [1] data paths, mounts [[/var/opt/novell (/dev/sdc1)]], net usable\_space [6.4gb], net total\_space [9.8gb], spins? [possibly], types [ext3]  
[2016-11-30T15:28:37,024][INFO][o.e.e.NodeEnvironment] [es-node-iam-rec-002-1] heap size [123.7mb], compressed ordinary object pointers [true]  
[2016-11-30T15:28:37,109][INFO][o.e.n.Node] [es-node-iam-rec-002-1] version[5.0.2], pid[3025], build[f6b4951/2016-11-24T10:07:18.101Z], OS[Linux/3.0.101-65-default/amd64], JVM[Oracle Corporation/Java HotSpot(TM) 64-Bit Server VM/1.8.0\_66/25.66-b17]  
[2016-11-30T15:28:38,182][INFO][o.e.p.PluginsService] [es-node-iam-rec-002-1] loaded module [aggs-matrix-stats]  
[2016-11-30T15:28:38,182][INFO][o.e.p.PluginsService] [es-node-iam-rec-002-1] loaded module [ingest-common]  
[2016-11-30T15:28:38,182][INFO][o.e.p.PluginsService] [es-node-iam-rec-002-1] loaded module [lang-expression]  
[2016-11-30T15:28:38,183][INFO][o.e.p.PluginsService] [es-node-iam-rec-002-1] loaded module [lang-groovy]  
[2016-11-30T15:28:38,183][INFO][o.e.p.PluginsService] [es-node-iam-rec-002-1] loaded module [lang-mustache]  
[2016-11-30T15:28:38,183][INFO][o.e.p.PluginsService] [es-node-iam-rec-002-1] loaded module [lang-painless]  
[2016-11-30T15:28:38,183][INFO][o.e.p.PluginsService] [es-node-iam-rec-002-1] loaded module [percolator]  
[2016-11-30T15:28:38,183][INFO][o.e.p.PluginsService] [es-node-iam-rec-002-1] loaded module [reindex]  
[2016-11-30T15:28:38,183][INFO][o.e.p.PluginsService] [es-node-iam-rec-002-1] loaded module [transport-netty3]  
[2016-11-30T15:28:38,183][INFO][o.e.p.PluginsService] [es-node-iam-rec-002-1] loaded module [transport-netty4]  
[2016-11-30T15:28:38,183][INFO][o.e.p.PluginsService] [es-node-iam-rec-002-1] no plugins loaded  
[2016-11-30T15:28:40,563][INFO][o.e.c.u.IndexFolderUpgrader] [clara\_users/KZs9OJNLTlySLaBjq0JFYg] upgrading [/var/opt/novell/idm/rbpm/vinci\_elasticsearch\_data/es-cluster-iam-rec/nodes/0/indices/clara\_users] to new naming convention  
[2016-11-30T15:28:40,565][ERROR][o.e.g.GatewayMetaState] [es-node-iam-rec-002-1] failed to read local state, exiting...  
java.nio.file.FileSystemException: /var/opt/novell/idm/rbpm/vinci\_elasticsearch\_data/es-cluster-iam-rec/nodes/0/indices/clara\_users -\> /var/opt/novell/idm/rbpm/vinci\_elasticsearch\_data/es-cluster-iam-rec/nodes/0/indices/KZs9OJNLTlySLaBjq0JFYg: Directory not empty  
at sun.nio.fs.UnixException.translateToIOException(UnixException.java:91) ~[?:?]  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102) ~[?:?]  
at sun.nio.fs.UnixCopyFile.move(UnixCopyFile.java:396) ~[?:?]  
at sun.nio.fs.UnixFileSystemProvider.move(UnixFileSystemProvider.java:262) ~[?:?]  
at java.nio.file.Files.move(Files.java:1395) ~[?:1.8.0\_66]

I have 4 nodes in my cluster and 6 index for a total of only 4 Go of data.  
I read and followed the documentation and can't find what i did wrong...  
Thanks

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 28, 2016, 3:05pm UTC](https://discuss.elastic.co/t/elasticsearch-2-4-1-to-5-0-2-upgrade-fails/67636/2 "2016-12-28T15:05:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
