# Elasticsearch-5.0.0 & 5.0.1 not able to start the service

**URL:** <https://discuss.elastic.co/t/elasticsearch-5-0-0-5-0-1-not-able-to-start-the-service/66237>\
**Category:** Elasticsearch\
**Created:** [November 16, 2016, 10:29am UTC](https://discuss.elastic.co/t/elasticsearch-5-0-0-5-0-1-not-able-to-start-the-service/66237 "2016-11-16T10:29:47Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![bumenga](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bumenga/32/13202_2.png) [@bumenga](https://discuss.elastic.co/u/bumenga)\
**Post date:** [November 16, 2016, 10:29am UTC](https://discuss.elastic.co/t/elasticsearch-5-0-0-5-0-1-not-able-to-start-the-service/66237/1 "2016-11-16T10:29:47Z")

</div>

![](https://us1.discourse-cdn.com/elastic/original/2X/4/4e53de124e5f591b4d202723747843f865d80ccc.jpg)

jvm.options :

-Xms20g  
-Xmx20g  
-Xss1m

![](https://us1.discourse-cdn.com/elastic/original/2X/f/ff36a534500841a8134da8701eb61ce110b367d2.jpg)

Logs :

[2016-11-16 13:18:20] [info] [7892] Commons Daemon procrun (1.0.15.0 64-bit) started  
[2016-11-16 13:18:20] [info] [7892] Starting service 'ES' ...  
[2016-11-16 13:18:20] [warn] [7892] Failed to obtain service description  
[2016-11-16 13:18:21] [error] [7892] Failed to start 'ES' service  
[2016-11-16 13:18:21] [error] [7892] The data area passed to a system call is too small.  
[2016-11-16 13:18:21] [info] [7892] Start service finished.  
[2016-11-16 13:18:21] [error] [7892] Commons Daemon procrun failed with exit value: 5 (Failed to start service)  
[2016-11-16 13:18:21] [error] [7892] The data area passed to a system call is too small.

The data area passed to a system call is too small.  
Failed to start service

elasticsearch.bat works perfectly

Thank you.

---

<div class="post-metadata">

**Author:** ![Habib\_Pleines](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/habib_pleines/32/13326_2.png) [@Habib\_Pleines](https://discuss.elastic.co/u/Habib_Pleines)\
**Post date:** [November 21, 2016, 3:28pm UTC](https://discuss.elastic.co/t/elasticsearch-5-0-0-5-0-1-not-able-to-start-the-service/66237/2 "2016-11-21T15:28:01Z")

</div>

Hi, I have the same issue...  
starting the search engine stand alone works perfectly.  
I already found all the threads for the older version concerning jvm.dll... I installed the newest jdk 1.8 and set the jvm.dll explicitly.  
Same result as bumenga

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 19, 2016, 3:28pm UTC](https://discuss.elastic.co/t/elasticsearch-5-0-0-5-0-1-not-able-to-start-the-service/66237/3 "2016-12-19T15:28:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
