# Elasticsearch 5.0.1 fails to be set as a cluster on AWS

**URL:** <https://discuss.elastic.co/t/elasticsearch-5-0-1-fails-to-be-set-as-a-cluster-on-aws/66547>\
**Category:** Elasticsearch\
**Created:** [November 18, 2016, 2:07pm UTC](https://discuss.elastic.co/t/elasticsearch-5-0-1-fails-to-be-set-as-a-cluster-on-aws/66547 "2016-11-18T14:07:54Z")\
**Posts on this page:** 1\
**Showing post:** 4

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 18, 2016, 4:06pm UTC](https://discuss.elastic.co/t/elasticsearch-5-0-1-fails-to-be-set-as-a-cluster-on-aws/66547/4 "2016-11-18T16:06:55Z")

</div>

So you are using Docker? It was not explicitly said here or I missed that.

I see now that you actually opened another discussion

> [@Elasticsearch 5.0.1 fails to start on AWS with discovery-ec2: BindException\[Cannot assign requested address\]](https://discuss.elastic.co/t/elasticsearch-5-0-1-fails-to-start-on-aws-with-discovery-ec2-bindexception-cannot-assign-requested-address/66524):
>
> Hi friends, With the following elasticsearch.yaml: [cluster.name](http://cluster.name): \*\*\* [node.name](http://node.name): ${HOSTNAME} cloud: aws: region: eu-west-1 discovery: type: ec2 network: host: \_ec2 discovery.zen.minimum\_master\_nodes: 1 discovery.zen.ping\_timeout: 10s Dockerfile: FROM elasticsearch:5.0 RUN /usr/share/elasticsearch/bin/elasticsearch-plugin install discovery-ec2 COPY elasticsearch.yml /usr/share/elasticsearch/config/ COPY log4j2.properties /usr/share/elasticsearch/config/ USER elasti…

---

_[View the full topic](https://discuss.elastic.co/t/elasticsearch-5-0-1-fails-to-be-set-as-a-cluster-on-aws/66547)._
