# Elasticsearch 5.2 service don't start

**URL:** <https://discuss.elastic.co/t/elasticsearch-5-2-service-dont-start/73722>\
**Category:** Elasticsearch\
**Created:** [February 2, 2017, 4:50pm UTC](https://discuss.elastic.co/t/elasticsearch-5-2-service-dont-start/73722 "2017-02-02T16:50:13Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Deuneuv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/deuneuv/32/15151_2.png) [@Deuneuv](https://discuss.elastic.co/u/Deuneuv)\
**Post date:** [February 2, 2017, 4:50pm UTC](https://discuss.elastic.co/t/elasticsearch-5-2-service-dont-start/73722/1 "2017-02-02T16:50:14Z")

</div>

Hello,  
I need some help, and please excuse my english it's not my monther tongue.

I installed Elasticsearch 5.2 on Redhat 7 and after installation the service started.  
I then turned it off to modify the configuration files /etc/elasticsearch/elasticsearch.yml and /etc/sysconfig/elasticsearch

Then I restarted it and I get this error:  
[root@machine]# systemctl status elasticsearch.service  
elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled)  
Active: failed (Result: exit-code) since Thu 2017-02-02 17:23:48 CET; 4s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 4932 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)  
Process: 4930 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 4932 (code=exited, status=1/FAILURE)

```
Feb 02 17:23:48 vmc8f9ab50.dev.sopra.asip.hst.fluxus.net elasticsearch[4932]: at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121)
Feb 02 17:23:48 vmc8f9ab50.dev.sopra.asip.hst.fluxus.net elasticsearch[4932]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112)
Feb 02 17:23:48 vmc8f9ab50.dev.sopra.asip.hst.fluxus.net elasticsearch[4932]: at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54)
Feb 02 17:23:48 vmc8f9ab50.dev.sopra.asip.hst.fluxus.net elasticsearch[4932]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)
Feb 02 17:23:48 vmc8f9ab50.dev.sopra.asip.hst.fluxus.net elasticsearch[4932]: at org.elasticsearch.cli.Command.main(Command.java:88)
Feb 02 17:23:48 vmc8f9ab50.dev.sopra.asip.hst.fluxus.net elasticsearch[4932]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)
Feb 02 17:23:48 vmc8f9ab50.dev.sopra.asip.hst.fluxus.net elasticsearch[4932]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)
Feb 02 17:23:48 vmc8f9ab50.dev.sopra.asip.hst.fluxus.net elasticsearch[4932]: Refer to the log for complete error details.
Feb 02 17:23:48 vmc8f9ab50.dev.sopra.asip.hst.fluxus.net systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE
Feb 02 17:23:48 vmc8f9ab50.dev.sopra.asip.hst.fluxus.net systemd[1]: Unit elasticsearch.service entered failed state.

```

I read several topics concerning not start but none solved my problem.

Thank you for reading and help ^\_^.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 2, 2017, 7:29pm UTC](https://discuss.elastic.co/t/elasticsearch-5-2-service-dont-start/73722/2 "2017-02-02T19:29:36Z")

</div>

Check the actual ES log rather than this one, usually under `/var/log/elasticsearch`.

---

<div class="post-metadata">

**Author:** ![Deuneuv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/deuneuv/32/15151_2.png) [@Deuneuv](https://discuss.elastic.co/u/Deuneuv)\
**Post date:** [February 3, 2017, 8:35am UTC](https://discuss.elastic.co/t/elasticsearch-5-2-service-dont-start/73722/3 "2017-02-03T08:35:15Z")

</div>

this is the log file  
[2017-02-02T15:08:43,594][INFO][o.e.n.Node] [node-1] initializing ...  
[2017-02-02T15:08:43,649][INFO][o.e.e.NodeEnvironment] [node-1] using [1] data paths, mounts [[/var (/dev/mapper/vg\_root-lv\_var)]], net usable\_space [590.9mb], net total\_space [975.8mb], spins? [possibly], types [ext4]  
[2017-02-02T15:08:43,649][INFO][o.e.e.NodeEnvironment] [node-1] heap size [1.9gb], compressed ordinary object pointers [true]  
[2017-02-02T15:08:43,650][INFO][o.e.n.Node] [node-1] node name [node-1], node ID [45YU-ETaR82DhoEfzcFs1A]  
[2017-02-02T15:08:43,651][INFO][o.e.n.Node] [node-1] version[5.2.0], pid[2831], build[24e05b9/2017-01-24T19:52:35.800Z], OS[Linux/3.10.0-229.7.2.el7.x86\_64/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/1.8.0\_31/25.31-b07]  
[2017-02-02T15:08:44,459][ERROR][o.e.b.Bootstrap] Exception  
java.lang.IllegalStateException: Could not load plugin descriptor for existing plugin [head]. Was the plugin built before 2.0?  
at org.elasticsearch.plugins.PluginsService.getPluginBundles(PluginsService.java:295) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:131) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.node.Node.(Node.java:297) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.node.Node.(Node.java:232) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Bootstrap$6.(Bootstrap.java:241) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:241) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:333) [elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) [elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) [elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) [elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) [elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.cli.Command.main(Command.java:88) [elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89) [elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82) [elasticsearch-5.2.0.jar:5.2.0]  
Caused by: java.nio.file.AccessDeniedException: /usr/share/elasticsearch/plugins/head/plugin-descriptor.properties  
at sun.nio.fs.UnixException.translateToIOException(UnixException.java:84) ~[?:?]  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102) ~[?:?]  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107) ~[?:?]  
at sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:214) ~[?:?]  
at java.nio.file.Files.newByteChannel(Files.java:361) ~[?:1.8.0\_31]  
at java.nio.file.Files.newByteChannel(Files.java:407) ~[?:1.8.0\_31]  
at java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:384) ~[?:1.8.0\_31]  
at java.nio.file.Files.newInputStream(Files.java:152) ~[?:1.8.0\_31]  
at org.elasticsearch.plugins.PluginInfo.readFromProperties(PluginInfo.java:86) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.plugins.PluginsService.getPluginBundles(PluginsService.java:292) ~[elasticsearch-5.2.0.jar:5.2.0]  
... 13 more  
[2017-02-02T15:08:44,465][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [node-1] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: Could not load plugin descriptor for existing plugin [head]. Was the plugin built before 2.0?

But it's a 16:32 and the starting failed was at 17:23:48 (Even if I tried several times to start it).  
I will remove the plugin that looks badly installed and start again

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 3, 2017, 8:35am UTC](https://discuss.elastic.co/t/elasticsearch-5-2-service-dont-start/73722/4 "2017-02-03T08:35:41Z")

</div>

> [@Deuneuv](#):
>
> [2017-02-02T15:08:44,459][ERROR][o.e.b.Bootstrap] Exception java.lang.IllegalStateException: Could not load plugin descriptor for existing plugin [head]. Was the plugin built before 2.0?

That's why.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [February 3, 2017, 8:58am UTC](https://discuss.elastic.co/t/elasticsearch-5-2-service-dont-start/73722/5 "2017-02-03T08:58:52Z")

</div>

Adding that you can't install site plugins in elasticsearch: [https://www.elastic.co/blog/running-site-plugins-with-elasticsearch-5-0](https://www.elastic.co/blog/running-site-plugins-with-elasticsearch-5-0)

---

<div class="post-metadata">

**Author:** ![Deuneuv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/deuneuv/32/15151_2.png) [@Deuneuv](https://discuss.elastic.co/u/Deuneuv)\
**Post date:** [February 3, 2017, 10:59am UTC](https://discuss.elastic.co/t/elasticsearch-5-2-service-dont-start/73722/6 "2017-02-03T10:59:07Z")

</div>

Thank you all for your support. I fixed it.

After removing the plugin, it still does not start.  
Being user root, the elasticsearch service starts with the elasticsearch user in default and the /etc/elasticsearch folder did not have sufficient rights. So I did a **chmod 777** on /etc/elasticserach and this solved the problem.

---

<div class="post-metadata">

**Author:** ![Nanne](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nanne/32/14086_2.png) [@Nanne](https://discuss.elastic.co/u/Nanne)\
**Post date:** [February 3, 2017, 2:02pm UTC](https://discuss.elastic.co/t/elasticsearch-5-2-service-dont-start/73722/7 "2017-02-03T14:02:52Z")

</div>

I'm not sure that's such a great idea: you have given all users all rights on your ES settings. As far as I know `chmod 777` is almost never a solution.

I doubt there is write-access needed? You could either `chown` the stuff that needs to be written, but better would be to just give some _read_ access to users, or maybe something like `755` ?

---

<div class="post-metadata">

**Author:** ![Deuneuv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/deuneuv/32/15151_2.png) [@Deuneuv](https://discuss.elastic.co/u/Deuneuv)\
**Post date:** [February 22, 2017, 1:33pm UTC](https://discuss.elastic.co/t/elasticsearch-5-2-service-dont-start/73722/8 "2017-02-22T13:33:49Z")

</div>

Ok, i will follow your advise in the futtur. Thank

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 22, 2017, 1:34pm UTC](https://discuss.elastic.co/t/elasticsearch-5-2-service-dont-start/73722/9 "2017-03-22T13:34:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
