# Elasticsearch 5.2 ubuntu 14.04 apt-get fails to install config

**URL:** <https://discuss.elastic.co/t/elasticsearch-5-2-ubuntu-14-04-apt-get-fails-to-install-config/74304>\
**Category:** Elasticsearch\
**Created:** [February 8, 2017, 12:36am UTC](https://discuss.elastic.co/t/elasticsearch-5-2-ubuntu-14-04-apt-get-fails-to-install-config/74304 "2017-02-08T00:36:05Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![csobchuk](https://avatars.discourse-cdn.com/v4/letter/c/a8b319/32.png) [@csobchuk](https://discuss.elastic.co/u/csobchuk)\
**Post date:** [February 8, 2017, 12:36am UTC](https://discuss.elastic.co/t/elasticsearch-5-2-ubuntu-14-04-apt-get-fails-to-install-config/74304/1 "2017-02-08T00:36:05Z")

</div>

I am trying to install elasticsearch 5.2 on Ubuntu 14.04 via apt-get with the new repository artifacts.... However, when the install is complete there is no config files generated. "sudo ls /etc/elasticsearch" has one subdirectory "scripts" which is also empty - no files.Trying to start the server results in the following failures.  
sudo /usr/share/elasticsearch/bin/elasticsearch  
2017-02-08 00:33:26,063 main ERROR Could not register mbeans java.security.AccessControlException: access denied ("javax.management.MBeanTrustPermission" "register")  
at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)  
at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)  
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrustPermission(DefaultMBeanServerInterceptor.java:1848)  
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(DefaultMBeanServerInterceptor.java:322)  
at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.java:522)  
at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)  
at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:167)  
at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:140)  
at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:541)  
at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:258)  
at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:206)  
at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:220)  
at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:197)  
at org.elasticsearch.common.logging.LogConfigurator.configureStatusLogger(LogConfigurator.java:125)  
at org.elasticsearch.common.logging.LogConfigurator.configureWithoutConfig(LogConfigurator.java:67)  
at org.elasticsearch.cli.Command.main(Command.java:85)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)

```
Exception in thread "main" org.elasticsearch.bootstrap.BootstrapException: java.nio.file.NoSuchFileException: /usr/share/elasticsearch/config
Likely root cause: java.nio.file.NoSuchFileException: /usr/share/elasticsearch/config
        at sun.nio.fs.UnixException.translateToIOException(UnixException.java:86)
        at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)
        at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)
        at sun.nio.fs.UnixFileAttributeViews$Basic.readAttributes(UnixFileAttributeViews.java:55)
        at sun.nio.fs.UnixFileSystemProvider.readAttributes(UnixFileSystemProvider.java:144)
        at sun.nio.fs.LinuxFileSystemProvider.readAttributes(LinuxFileSystemProvider.java:99)
        at java.nio.file.Files.readAttributes(Files.java:1737)
        at java.nio.file.FileTreeWalker.getAttributes(FileTreeWalker.java:225)
        at java.nio.file.FileTreeWalker.visit(FileTreeWalker.java:276)
        at java.nio.file.FileTreeWalker.walk(FileTreeWalker.java:322)
        at java.nio.file.Files.walkFileTree(Files.java:2662)
        at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:100)
        at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:83)
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:299)
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121)
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112)
        at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54)
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)
        at org.elasticsearch.cli.Command.main(Command.java:88)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)
Refer to the log for complete error details.
```

---

<div class="post-metadata">

**Author:** ![csobchuk](https://avatars.discourse-cdn.com/v4/letter/c/a8b319/32.png) [@csobchuk](https://discuss.elastic.co/u/csobchuk)\
**Post date:** [February 8, 2017, 12:50am UTC](https://discuss.elastic.co/t/elasticsearch-5-2-ubuntu-14-04-apt-get-fails-to-install-config/74304/2 "2017-02-08T00:50:30Z")

</div>

sudo apt-get purge followed by sudo apt-get install seemed to fix the issue. It isn't clear why since there were no configuration files. After the reinstall, the config files are in /etc/elasticsearch as expected.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 8, 2017, 12:50am UTC](https://discuss.elastic.co/t/elasticsearch-5-2-ubuntu-14-04-apt-get-fails-to-install-config/74304/3 "2017-03-08T00:50:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
