# Elasticsearch 5.4.1 service failed to start

**URL:** <https://discuss.elastic.co/t/elasticsearch-5-4-1-service-failed-to-start/211501>\
**Category:** Elasticsearch\
**Created:** [December 11, 2019, 5:15pm UTC](https://discuss.elastic.co/t/elasticsearch-5-4-1-service-failed-to-start/211501 "2019-12-11T17:15:10Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![fengliplatform](https://avatars.discourse-cdn.com/v4/letter/f/e99b99/32.png) [@fengliplatform](https://discuss.elastic.co/u/fengliplatform)\
**Post date:** [December 11, 2019, 5:15pm UTC](https://discuss.elastic.co/t/elasticsearch-5-4-1-service-failed-to-start/211501/1 "2019-12-11T17:15:10Z")

</div>

It seems it failed to start and status stayed to RED. Any idea? Thanks

Following errors are in elasticsearch log file:

[2019-11-26T10:53:03,141][WARN][o.e.b.Natives] cannot register console handler because JNA is not available  
[2019-11-26T10:53:03,143][WARN][o.e.b.Natives] cannot getrlimit RLIMIT\_NPROC because JNA is not available  
[2019-11-26T10:53:03,143][WARN][o.e.b.Natives] cannot getrlimit RLIMIT\_AS beacuse JNA is not available  
[2019-11-26T10:53:03,672][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [elasticsearch-node1] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unable to parse policy file `file:/....../modules/lang-expression/plugin-security.policy`  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:127) ~[elasticsearch-5.4.1.jar:5.4.1]  
...  
Caused by: java.lang.IllegalArgumentException: unable to parse policy file `file:/.../modules/lang-expression/plugin-security.policy`  
...  
Caused by: java.security.NoSuchAlgorithmException: JavaPolicy Policy not available  
......

The plugin-security.policy file looks normal as following

grant {  
// needed to generate runtime classes  
permission java.lang.RuntimePermission "createClassLoader";

// expression runtime  
permission org.elasticsearch.script.ClassPermission "java.lang.String";  
permission org.elasticsearch.script.ClassPermission "org.apache.lucene.expressions.Expression";  
permission org.elasticsearch.script.ClassPermission "org.apache.lucene.search.DoubleValues";  
// available functions  
permission org.elasticsearch.script.ClassPermission "java.lang.Math";  
permission org.elasticsearch.script.ClassPermission "org.apache.lucene.util.MathUtil";  
permission org.elasticsearch.script.ClassPermission "org.apache.lucene.util.SloppyMath";  
};

---

<div class="post-metadata">

**Author:** ![rameshkr1994](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rameshkr1994/32/59029_2.png) [@rameshkr1994](https://discuss.elastic.co/u/rameshkr1994)\
**Post date:** [December 12, 2019, 2:40pm UTC](https://discuss.elastic.co/t/elasticsearch-5-4-1-service-failed-to-start/211501/2 "2019-12-12T14:40:58Z")

</div>

Hi @fengliplatform.

Please try with below 👎

> [@Elasticsearch 2.0 warning: JNA is not available](https://discuss.elastic.co/t/elasticsearch-2-0-warning-jna-is-not-available/33320):
>
> Hi, I'm evaluating Elasticsearch for a project and since 2.0 was released just now I thought why not upgrade my installation. I have two questions: Question 1: In my log file, I see the following on startup: [2015-10-29 23:50:57,024][WARN][bootstrap] cannot check if running as root because JNA is not available [2015-10-29 23:50:57,024][WARN][bootstrap] cannot mlockall because JNA is not available [2015-10-29 23:50:57,025][WARN][bootstrap] …

Thanks  
HadoopHelp

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 9, 2020, 2:46pm UTC](https://discuss.elastic.co/t/elasticsearch-5-4-1-service-failed-to-start/211501/3 "2020-01-09T14:46:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
