# Elasticsearch 5.4.1 service failed to start

**URL:** <https://discuss.elastic.co/t/elasticsearch-5-4-1-service-failed-to-start/211501>\
**Category:** Elasticsearch\
**Created:** [December 11, 2019, 5:15pm UTC](https://discuss.elastic.co/t/elasticsearch-5-4-1-service-failed-to-start/211501 "2019-12-11T17:15:10Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![rameshkr1994](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rameshkr1994/32/59029_2.png) [@rameshkr1994](https://discuss.elastic.co/u/rameshkr1994)\
**Post date:** [December 12, 2019, 2:40pm UTC](https://discuss.elastic.co/t/elasticsearch-5-4-1-service-failed-to-start/211501/2 "2019-12-12T14:40:58Z")

</div>

Hi @fengliplatform.

Please try with below 👎

> [@Elasticsearch 2.0 warning: JNA is not available](https://discuss.elastic.co/t/elasticsearch-2-0-warning-jna-is-not-available/33320):
>
> Hi, I'm evaluating Elasticsearch for a project and since 2.0 was released just now I thought why not upgrade my installation. I have two questions: Question 1: In my log file, I see the following on startup: [2015-10-29 23:50:57,024][WARN][bootstrap] cannot check if running as root because JNA is not available [2015-10-29 23:50:57,024][WARN][bootstrap] cannot mlockall because JNA is not available [2015-10-29 23:50:57,025][WARN][bootstrap] …

Thanks  
HadoopHelp

---

_[View the full topic](https://discuss.elastic.co/t/elasticsearch-5-4-1-service-failed-to-start/211501)._
