# Elasticsearch 5.5 Jar hell problem

**URL:** <https://discuss.elastic.co/t/elasticsearch-5-5-jar-hell-problem/96281>\
**Category:** Elasticsearch\
**Created:** [August 8, 2017, 1:44pm UTC](https://discuss.elastic.co/t/elasticsearch-5-5-jar-hell-problem/96281 "2017-08-08T13:44:15Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![sankard](https://avatars.discourse-cdn.com/v4/letter/s/eada6e/32.png) [@sankard](https://discuss.elastic.co/u/sankard)\
**Post date:** [August 8, 2017, 1:44pm UTC](https://discuss.elastic.co/t/elasticsearch-5-5-jar-hell-problem/96281/1 "2017-08-08T13:44:16Z")

</div>

Hello

I build elasticsearch 5.5.1 rpm using alsticsearch tar file, I see below error while trying to start elasticsearch service. Could not able find the reason. Please help me

[2017-08-08T12:52:52,615][ERROR][o.e.b.Bootstrap] Exception  
java.lang.IllegalStateException: failed to load plugin - Plugin information:  
Name: reindex  
Description: The Reindex module adds APIs to reindex from one index to another or update documents in place.  
Version: 5.5.1  
Native Controller: false

- Classname: org.elasticsearch.index.reindex.ReindexPlugin due to jar hell  
at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:376) ~[elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:140) ~[elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.node.Node.(Node.java:312) ~[elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.node.Node.(Node.java:244) ~[elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:232) ~[elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:232) ~[elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:351) [elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) [elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) [elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67) [elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) [elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.cli.Command.main(Command.java:88) [elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) [elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) [elasticsearch-5.5.1.jar:5.5.1]  
Caused by: java.lang.IllegalStateException: jar hell! duplicate codebases between plugin and core: [file:/usr/share/elasticsearch/modules/reindex/httpcore-4.4.5.jar, file:/usr/share/elasticsearch/modules/reindex/commons-logging-1.1.3.jar, file:/usr/share/elasticsearch/modules/reindex/rest-5.5.1.jar, file:/usr/share/elasticsearch/modules/reindex/httpcore-nio-4.4.5.jar, file:/usr/share/elasticsearch/modules/reindex/httpclient-4.5.2.jar, file:/usr/share/elasticsearch/modules/reindex/reindex-5.5.1.jar, file:/usr/share/elasticsearch/modules/reindex/commons-codec-1.10.jar, file:/usr/share/elasticsearch/modules/reindex/httpasyncclient-4.1.2.jar]  
at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:368) ~[elasticsearch-5.5.1.jar:5.5.1]  
... 13 more  
[2017-08-08T12:52:52,620][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: failed to load plugin - Plugin information:  
Name: reindex  
Description: The Reindex module adds APIs to reindex from one index to another or update documents in place.  
Version: 5.5.1  
Native Controller: false
- Classname: org.elasticsearch.index.reindex.ReindexPlugin due to jar hell  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:127) ~[elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) ~[elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67) ~[elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) ~[elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.cli.Command.main(Command.java:88) ~[elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) ~[elasticsearch-5.5.1.jar:5.5.1]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) ~[elasticsearch-5.5.1.jar:5.5.1]  
Caused by: java.lang.IllegalStateException: failed to load plugin - Plugin information:

Please help me

Thanks  
Sankar

---

<div class="post-metadata">

**Author:** ![rjernst](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rjernst/32/6363_2.png) [@rjernst](https://discuss.elastic.co/u/rjernst)\
**Post date:** [August 9, 2017, 3:11am UTC](https://discuss.elastic.co/t/elasticsearch-5-5-jar-hell-problem/96281/2 "2017-08-09T03:11:00Z")

</div>

Why are you building your own rpm? Elasticsearch [provides an rpm](https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html).

---

<div class="post-metadata">

**Author:** ![rjernst](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rjernst/32/6363_2.png) [@rjernst](https://discuss.elastic.co/u/rjernst)\
**Post date:** [August 9, 2017, 5:23pm UTC](https://discuss.elastic.co/t/elasticsearch-5-5-jar-hell-problem/96281/4 "2017-08-09T17:23:27Z")

</div>

A few things have changed in the startup scripts over those versions. I'm not sure what exactly, but the rpm is setup with the correct paths for bin/elasticsearch to know how to start as a service.

---

<div class="post-metadata">

**Author:** ![sankard](https://avatars.discourse-cdn.com/v4/letter/s/eada6e/32.png) [@sankard](https://discuss.elastic.co/u/sankard)\
**Post date:** [August 10, 2017, 9:28am UTC](https://discuss.elastic.co/t/elasticsearch-5-5-jar-hell-problem/96281/5 "2017-08-10T09:28:41Z")

</div>

Sorry, its due to wrong configuration in my post install script. Thanks a lot for your support.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 7, 2017, 9:28am UTC](https://discuss.elastic.co/t/elasticsearch-5-5-jar-hell-problem/96281/6 "2017-09-07T09:28:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
