# Elasticsearch 5.6.3 upgrade to 6.0 Node will not start "failed to read local state"

**URL:** https://discuss.elastic.co/t/elasticsearch-5-6-3-upgrade-to-6-0-node-will-not-start-failed-to-read-local-state/108252
**Category:** Elasticsearch
**Created:** [November 18, 2017, 10:32pm UTC](https://discuss.elastic.co/t/elasticsearch-5-6-3-upgrade-to-6-0-node-will-not-start-failed-to-read-local-state/108252 "2017-11-18T22:32:31Z")
**Posts on this page:** 1
**Showing post:** 22

<div class="post-metadata">

### Author: ![tatdat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tatdat/32/113160_2.png) [@tatdat](https://discuss.elastic.co/u/tatdat)
#### Post date: [November 24, 2017, 4:02pm UTC](https://discuss.elastic.co/t/elasticsearch-5-6-3-upgrade-to-6-0-node-will-not-start-failed-to-read-local-state/108252/22 "2017-11-24T16:02:17Z")

</div>

@dkyle. I have 5 node in cluster, 3 data node, 1 client. X-Pack installed in all of them and dont have any node upgrade success to 6.0.0

> [@dkyle](#):
>
> The error comes from X-Pack Monitoring but I suspect you would see it even if monitoring was disabled.

Yeah, before i got this error, i saw some error from x-pack security, but i try to disable x-pack security .

---

_[View the full topic](https://discuss.elastic.co/t/elasticsearch-5-6-3-upgrade-to-6-0-node-will-not-start-failed-to-read-local-state/108252)._
