# Elasticsearch 6.1.0 settings parser error

**URL:** <https://discuss.elastic.co/t/elasticsearch-6-1-0-settings-parser-error/112805>\
**Category:** Elasticsearch\
**Created:** [December 21, 2017, 10:53am UTC](https://discuss.elastic.co/t/elasticsearch-6-1-0-settings-parser-error/112805 "2017-12-21T10:53:48Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![trondhindenes](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/trondhindenes/32/10534_2.png) [@trondhindenes](https://discuss.elastic.co/u/trondhindenes)\
**Post date:** [December 21, 2017, 10:53am UTC](https://discuss.elastic.co/t/elasticsearch-6-1-0-settings-parser-error/112805/1 "2017-12-21T10:53:48Z")

</div>

It seems that 6.1.0 is more strict in how it parses settings. We're trying to upgrade to 6.1.0 but are blocked because our config file is no longer working. We're using readonlyrest, and with this config, ES refuses to start, throwing a  
`Exception in thread "main" SettingsException[Failed to load settings from [elasticsearch.yml]]; nested: IllegalStateException[only value lists are allowed in serialized settings]`

If I remove the following section from settings, everything works. I can't see anything wrong with this yml block, and its been working great on ES 6.0.0

```auto
readonlyrest:
    audit_collector: true

    external_authentication_service_configs:
      - name: elasticsearch_auth
        authentication_endpoint: "https://stuff.stuff/api/auth"
        success_status_code: 200
        cache_ttl_in_sec: 60

```

---

<div class="post-metadata">

**Author:** ![rjernst](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rjernst/32/6363_2.png) [@rjernst](https://discuss.elastic.co/u/rjernst)\
**Post date:** [December 21, 2017, 5:44pm UTC](https://discuss.elastic.co/t/elasticsearch-6-1-0-settings-parser-error/112805/2 "2017-12-21T17:44:36Z")

</div>

This is a result of a refactoring that occurred to improve array/list handling in settings parsing. You should be able to simply remove the `-`.

---

<div class="post-metadata">

**Author:** ![trondhindenes](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/trondhindenes/32/10534_2.png) [@trondhindenes](https://discuss.elastic.co/u/trondhindenes)\
**Post date:** [December 23, 2017, 10:09am UTC](https://discuss.elastic.co/t/elasticsearch-6-1-0-settings-parser-error/112805/3 "2017-12-23T10:09:12Z")

</div>

But removing the '-' would no longer make it a list item?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 20, 2018, 10:09am UTC](https://discuss.elastic.co/t/elasticsearch-6-1-0-settings-parser-error/112805/4 "2018-01-20T10:09:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
